Grub error: no such cryptodisk found

Hello,

I have Garuda Linux (KDE, but I guess it doesn't matter) installed with default LUKS encryption from the installer. I have been using this for nearly half a year, no problem at all.

But recently (2 weeks ago, maybe) I got one.
But it isn't too critical, I guess. So far, I have mostly ignored it, it doesn't cause any problem aside from a little annoyance.

How it behaves:
I turn on my PC, I enter my LUKS password, I wait. Then there is grub graphical menu, I select Garuda. And then I see

error: no such cryptodisk found
loading Linux linux-zen ...
loading initial ramdisk ...

Press any key to continue...

And that's it. After pressing any key or waiting ~10s it just proceeds to boot as usual, nothing strange.

How it's different from similar issues on this forum:

Mainly, I don't have any problem with rebooting. I have done it, maybe, 15 times since the first appearance of this message.
So far, nothing has broken.

What I want to know:
A way to get rid of this annoying line.
And also the reason, why it has appeared.

What I think may be the reason:
I have 2 different theories about the source of the problem:

  1. Broken grub update.
    This possibility is mentioned in here and here . Yet I don't understand enough, what should I do. I tried to uncomment GRUB_ENABLE_CRYPTODISK=y and add "cryptodisk" into the GRUB_PRELOAD_MODULES, everything in /etc/default/grub, but this does nothing for my problem. (I did run grub-mkconfig)
  2. It's because of me breaking something while trying to set up auto-mount of second SSD (also encrypted) in my laptop, using different guides from the internet.
    Maybe, i have wrote something in fstab-like file. I don't know, I'm too noob for this.
    Btw in the end I have set up auto-mount using gnome-disks gui.
    And no, I did it after the first occurance of my error, so this can't be the reason.

Anyway, I will be grateful for any sort of help.

Thank you.

Hi @Marenleka, welcome to the community. :slightly_smiling_face:

The garuda-inxi output is missing from your post.

You can take a look at the UUID of your mounted volumes by running lsblk -f. Check to see if there is a UUID specified in /etc/fstab or /etc/crypttab that does not appear on the output of lsblk -f. If you are not sure, paste into the thread so we can take a look.

lsblk -f
cat /etc/fstab
cat /etc/crypttab

If there are any UUIDs listed that no longer exist (from the effort to set up auto-mount of the second SSD, perhaps), that could cause the error message you are seeing because systemd will continue to attempt a mount at every boot.

Updating Grub is not a bad instinct, but you may get a different result by reinstalling Grub first. I'm not sure if you have an EFI system or not (no garuda-inxi posted), but if so you can simply run:

sudo grub-install

Then regenerate the configuration file.

sudo update-grub

Paste the input and output into the thread if you see anything unexpected.

2 Likes

Hello, and thank you!

So, firstly, here's my garuda-inxi output:

System:
  Kernel: 5.15.85-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=f9d3287a-9274-4a6c-a6ca-9c0a5f7526a7 rw [email protected]
    quiet
    cryptdevice=UUID=f1c0a5c1-bfb1-49a5-84d1-ff150cd64506:luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
    root=/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
    wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: EVOO Products product: EVC141-12 v: Standard
    serial: <filter>
  Mobo: EVOO Products model: EVOO Products v: Standard serial: <filter>
    UEFI-[Legacy]: American Megatrends v: N.1.01 date: 10/12/2020
Battery:
  ID-1: BAT0 charge: 35.3 Wh (100.0%) condition: 35.3/46.7 Wh (75.6%)
    volts: 12.8 min: 11.4 model: standard type: Li-ion serial: <filter>
    status: full
CPU:
  Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx socket: FP5
    bits: 64 type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3
    note: check built: 2019 process: GF 12nm family: 0x17 (23)
    model-id: 0x18 (24) stepping: 1 microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1400 min/max: 1400/2100 boost: enabled
    base/boost: 2100/3700 scaling: driver: acpi-cpufreq governor: powersave
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1400 2: 1400 3: 1400 4: 1400
    5: 1400 6: 1400 7: 1400 8: 1400 bogomips: 33538
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Tongfang Hongkong driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 43.0 C
  Device-2: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 3-1:2
    chip-ID: 5986:9101 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x07c9 built: 2018
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
    diag: 345mm (13.6") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon Vega 8 Graphics
    (raven LLVM 14.0.6 DRM 3.42 5.15.85-1-lts) direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
    v: kernel alternate: snd_rn_pci_acp3x,snd_pci_acp5x pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.15.85-1-lts running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Tongfang Hongkong driver: N/A modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: ultra-ger state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 3-2.4:4 chip-ID: 8087:0025 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 704.24 GiB used: 272.41 GiB (38.7%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 28.9 C scheme: MBR
  SMART: yes health: PASSED on: 235d 19h cycles: 1,238
    read-units: 90,324,700 [46.2 TB] written-units: 36,605,247 [18.7 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: BIWIN model: SSD size: 238.47 GiB
    block-size: physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4A0 temp: 49 C scheme: MBR
  SMART: yes state: enabled health: PASSED on: 193d 21h cycles: 1450
    read: 49.9 MiB written: 33.6 MiB
Partition:
  ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
    used: 185.39 GiB (39.8%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
  ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
    used: 185.39 GiB (39.8%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
  ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
    used: 185.39 GiB (39.8%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
  ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
    used: 185.39 GiB (39.8%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 13.59 GiB used: 2.05 GiB (15.1%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 320 Uptime: 16h 45m wakeups: 3 Memory: 13.59 GiB
  used: 6.02 GiB (44.3%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2319
  pm: pacman pkgs: 2302 libs: 525 tools: aura,pamac,paru,yay pm: flatpak
  pkgs: 17 Shell: garuda-inxi (sudo) default: Zsh v: 5.9 running-in: yakuake
  inxi: 3.3.24
Garuda (2.6.12-1):
  System install date:     2022-04-03
  Last full system update: 2022-12-27 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

Secondly, the output of lsblk -f:

NAME                  FSTYPE      FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                               
└─sda1                crypto_LUKS 1           ab5e5466-39f5-4055-98a6-90bbb6b86002                
  └─luks-ab5e5466-39f5-4055-98a6-90bbb6b86002
                      btrfs             chmo  9dd43197-1dd0-4df0-93e6-f24de85fdbe1  150,7G    36% /home/marenleka/chmo
zram0                                                                                             [SWAP]
nvme0n1                                                                                           
└─nvme0n1p1           crypto_LUKS 1           f1c0a5c1-bfb1-49a5-84d1-ff150cd64506                
  └─luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
                      btrfs                   f9d3287a-9274-4a6c-a6ca-9c0a5f7526a7  278,1G    40% /var/log
                                                                                                  /var/tmp
                                                                                                  /var/cache
                                                                                                  /srv
                                                                                                  /root
                                                                                                  /home
                                                                                                  /

The output of cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /              btrfs   subvol=/@,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /home          btrfs   subvol=/@home,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /root          btrfs   subvol=/@root,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /srv           btrfs   subvol=/@srv,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /var/cache     btrfs   subvol=/@cache,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /var/log       btrfs   subvol=/@log,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
/dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,autodefrag,compress=zstd,discard=async,ssd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-uuid/9dd43197-1dd0-4df0-93e6-f24de85fdbe1 /home/marenleka/chmo/ auto nosuid,nodev,nofail,autodefrag,x-gvfs-show,user,compress=zstd,ssd 0 0

And the cat /etc/crypttab:

# /etc/crypttab: mappings for encrypted partitions.
#
# Each mapped device will be created in /dev/mapper, so your /etc/fstab
# should use the /dev/mapper/<name> paths for encrypted devices.
#
# See crypttab(5) for the supported syntax.
#
# NOTE: You need not list your root (/) partition here, but it must be set up
#       beforehand by the initramfs (/etc/mkinitcpio.conf). The same applies
#       to encrypted swap, which should be set up with mkinitcpio-openswap
#       for resume support.
#
# <name>               <device>                         <password> <options>
luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506 UUID=f1c0a5c1-bfb1-49a5-84d1-ff150cd64506     /crypto_keyfile.bin luks
luks-ab5e5466-39f5-4055-98a6-90bbb6b86002 UUID=ab5e5466-39f5-4055-98a6-90bbb6b86002 /etc/luks-keys/luks-ab5e5466-39f5-4055-98a6-90bbb6b86002 nofail

Honestly, I don't see anything out of order here.

Trying to run sudo grub-install leaves this output:

Installing for i386-pc platform.
grub-install: error: install device isn't specified.

And I'm too scared to write anything in options and arguments, so to not break system even more.

However, sudo update-grub generated a far more adequate output:

Generating grub configuration file ...
Found theme: /home/marenleka/breeze-grub/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-lts-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Garuda Linux on /dev/mapper/luks-f1c0a5c1-bfb1-49a5-84d1-ff150cd64506
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2022-12-27 14:52:51 | @/.snapshots/2575/snapshot | post | a2ps a52dec aalib btrfs-progs cockpit device-mapper easyeffects firefox- |
Found snapshot: 2022-12-27 14:51:09 | @/.snapshots/2574/snapshot | pre  | pacman -Su                                                               |
Found snapshot: 2022-12-26 23:17:46 | @/.snapshots/2573/snapshot | post | ntfsprogs-ntfs3                                                          |
Found snapshot: 2022-12-26 23:17:44 | @/.snapshots/2572/snapshot | pre  | pacman -S -y -u --config /etc/pacman.conf --                             |
Found snapshot: 2022-12-26 14:17:08 | @/.snapshots/2571/snapshot | post | btrfs-progs palemoon-gtk3-bin                                            |
Found snapshot: 2022-12-26 14:16:23 | @/.snapshots/2570/snapshot | pre  | pacman -S -y -u --config /etc/pacman.conf --                             |
Found snapshot: 2022-12-25 22:11:10 | @/.snapshots/2569/snapshot | post | graphviz perl-alien-build suitesparse                                    |
Found snapshot: 2022-12-25 22:11:07 | @/.snapshots/2568/snapshot | pre  | pacman -S -y -u --config /etc/pacman.conf --                             |
Found snapshot: 2022-12-25 01:00:55 | @/.snapshots/2567/snapshot | post | marksman-bin                                                             |
Found snapshot: 2022-12-25 01:00:54 | @/.snapshots/2566/snapshot | pre  | pacman -U --noconfirm --config /etc/pacman.conf -- /home/marenleka/.cach |
Found snapshot: 2022-12-25 01:00:27 | @/.snapshots/2565/snapshot | post | appstream appstream-qt bind czkawka-git default-cursors garuda-gamer gar |
Found snapshot: 2022-12-25 00:58:31 | @/.snapshots/2564/snapshot | pre  | pacman -S -u -y --config /etc/pacman.conf --                             |
Found 12 snapshot(s)
Unmount /tmp/grub-btrfs.TCGg8zcjTM .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I guess I will reboot now and see if anything has changed

Upd. post reboot — nothing has changed. Error is still there.

It looks like you are not using EFI after all:

"Legacy" indicates the installation was done in BIOS mode, in which case you will have to reinstall Grub like so:

sudo grub-install --target=i386-pc /dev/nvme0n1

Then run sudo update-grub again.

3 Likes

So, doing sudo grub-install --target=i386-pc /dev/nvme0n1 left this output:

Installing for i386-pc platform.
Installation finished. No error reported.

Which seems good so far.

And the output of sudo update-grub is similar to the previous one.

So rebooting again.

UPDATE: So yeah, that really was because of some Grub breakage after some package update (I guess).
And the reinstallation of Grub really solved my problem.

Thank you very much!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.