Greetd failed when booting live ISO (sway)

I’m getting Failed to start Greeter daemon issue when booting to the live environment. After running systemctl status greetd.service as suggested, I’m seeing the following:

In another thread, I’ve found suggestion to run journalctl -u greetd.service -b and it shows exactly the same error at the end.

I downloaded the ISO from two different mirrors and used two different programs to flash it, so I don’t think that’s the issue. I also tried to boot in using the open drivers (Nvidia user), but I’m getting a black screen with a flashing line (looks kinda like empty tty screen, but I can’t type anything either)

Are you using open source drivers while booting? Sway doesn’t support proprietary nvidia drivers at all and this might be the cause of issue.


Good to know, thanks. Still, I tried booting with os drivers, and I was met with black screen with just a flashing cursor EDIT: where I can’t type anything

What ISO are you using? 231029 from the downloads page, or something else?

1 Like

the one from downloads page. I tried torrent and then sourceforge

Is your Nvidia card very new, or very old?

somewhat in the middle? rtx 3060

Hmm, that’s weird that the open source drivers are not working. :thinking:

To get the greeter to work, you’ll have to adjust a few config files and maybe set up a wrapper script for launching the session. For getting to the live environment, it’s kind of not worth it. If you’d like to push forward with the installation, just launch the session manually from that TTY prompt in your picture:

sway --unsupported-gpu

Bummer. I actually wanted to try the live version to see if I like it. I think I’ll just search yt for some showcase, and perhaps a comparison with qtile. Still, thanks a lot for the command. It’ll be helpful if I decide to use sway :slight_smile:

That is the command to get to the live session. The greeter is just the login screen, it’s not actually needed for getting a session.


Misread. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.