GreenWithEnvy not opening

Hi again,

GWE doesn't open when i click on it from the menu, when I use "gwe" in the terminal it gives me:

Traceback (most recent call last):
File "/usr/bin/gwe", line 53, in <module>
from gwe import __main__
File "/usr/lib/python3.9/site-packages/gwe/__main__.py", line 52, in <module>
locale.setlocale(locale.LC_ALL, locale.getlocale())
File "/usr/lib/python3.9/locale.py", line 610, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting

Any help is greatly appreciated :))

What's the output of locale ?

1 Like

Thanks for the reply,

Heres the output:

LANG=en_IN
LC_CTYPE="en_IN"
LC_NUMERIC=en_IN
LC_TIME=en_IN
LC_COLLATE="en_IN"
LC_MONETARY=en_IN
LC_MESSAGES="en_IN"
LC_PAPER=en_IN
LC_NAME=en_IN
LC_ADDRESS=en_IN
LC_TELEPHONE=en_IN
LC_MEASUREMENT=en_IN
LC_IDENTIFICATION=en_IN
LC_ALL=

First, edit /etc/locale.gen and make sure

en_IN UTF-8

is uncommented, then run sudo locale-gen .

Then, edit /etc/locale.conf and make sure it has

LANG=en_IN.UTF-8

Then try again (you may need to log out/in or restart).

If that doesn't help, edit /etc/locale.gen then uncomment en_US UTF-8 and run locale-gen again - some software only works with en_US (for stupid reasons).

4 Likes

Unfortunately both don't work, still shows the same error

What was the output of locale-gen in both cases?

What is the contents of /etc/locale.conf and the output of locale after you rebooted?

3 Likes

GreenWithEnvy does not starts temp fix

$gwe
Traceback (most recent call last):
File "/usr/bin/gwe", line 53, in
from gwe import main
File "/usr/lib/python3.9/site-packages/gwe/main.py", line 52, in
locale.setlocale(locale.LC_ALL, locale.getlocale())
File "/usr/lib/python3.9/locale.py", line 610, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting

However running these two lines fixes this problem till next reboot

Run following commands in terminal

export LC_ALL="en_US.UTF-8"
export LC_CTYPE="en_US.UTF-8"

I think gwe dev has hardcoded it for en_US only .

1 Like