Graphics no workie, Zen 6.5.5.zen1-1

So, on getting to the graphics target, X tries to start - the screen goes blank as expected just before SDDM shows up. But instead of the ol’ familiar login, it re-shows the text of the boot monologue. Just sits there. Menacingly.
I tried manually starting X, but it just quietly quits, too. I can’t find anything in the logs about it.

It works fine with the LTS kernel. Which is why I can post this (without the post being stained with tears).

(Coincidental: Seems my i7-8700K’s UHD Graphics 630 has simply vanished. Doesn’t show up in UEFI setup. (Does show up in inxi? WTH?) Mentioned only because of very slight possibility this is related. Doubt it though.)

  Kernel: 6.1.55-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=efefd612-7990-4b02-adb6-ac19697acc64 rw rootflags=subvol=@
    fbcon=map:0 rd.udev.log_priority=3 loglevel=4 mitigations=off
    amdgpu.ppfeaturemask=0xffffffff ibt=off
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z390-A v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 1802 date: 12/01/2020
  Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4355 high: 4400 min/max: 800/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4400 2: 4301 3: 4392
    4: 4399 5: 4300 6: 4301 7: 4308 8: 4396 9: 4400 10: 4387 11: 4378 12: 4300
    bogomips: 88824
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: none empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:3e92 class-ID: 0380
  Device-2: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    vendor: XFX driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-2,DP-3 empty: DP-4,HDMI-A-3 bus-ID: 03:00.0
    chip-ID: 1002:73df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting unloaded: radeon
    alternate: fbdev,intel,vesa dri: radeonsi,iris gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,left model: AOC 24G1WG4
    serial: <filter> built: 2019 res: 1920x1080 dpi: 94 gamma: 1.2
    size: 521x293mm (20.51x11.54") diag: 598mm (23.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: DP-3 mapped: DisplayPort-2 pos: right model: AOC 24G1WG4
    serial: <filter> built: 2019 res: 1920x1080 dpi: 94 gamma: 1.2
    size: 521x293mm (20.51x11.54") diag: 598mm (23.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: intel iris drv: amd radeonsi platforms: device: 0
    drv: radeonsi device: 1 drv: iris device: 2 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: radeonsi x11: drv: radeonsi inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.8-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6700 XT (navi22 LLVM
    16.0.6 DRM 3.49 6.1.55-1-lts) device-ID: 1002:73df memory: 11.72 GiB
    unified: no
  API: Vulkan v: 1.3.264 layers: 8 device: 0 type: discrete-gpu name: AMD
    Radeon RX 6700 XT (RADV NAVI22) driver: mesa radv v: 23.1.8-arch1.1
    device-ID: 1002:73df surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: Intel UHD Graphics 630 (CFL GT2) driver: mesa intel
    v: 23.1.8-arch1.1 device-ID: 8086:3e92 surfaces: xcb,xlib device: 2
    type: cpu name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.1.8-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-3: C-Media Audio Adapter (Unitek Y-247A)
    driver: cmedia_hs100b,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-6.4:6 chip-ID: 0d8c:0014 class-ID: 0300
  API: ALSA v: k6.1.55-1-lts status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 0bda:8771
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 1.59 TiB used: 315.39 GiB (19.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Corsair model: Force MP500
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: E7FM04.C temp: 57.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Sabrent model: N/A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: RKT303.3 temp: 58.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A02 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU650 size: 111.79 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
    serial: <filter> fw-rev: 1C0 scheme: GPT
  ID-1: / raw-size: 54.53 GiB size: 54.53 GiB (100.00%)
    used: 37.17 GiB (68.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
  ID-2: /boot/efi raw-size: 976 MiB size: 974.1 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
  ID-3: /home raw-size: 466.94 GiB size: 466.94 GiB (100.00%)
    used: 139.8 GiB (29.9%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-4: /var/log raw-size: 54.53 GiB size: 54.53 GiB (100.00%)
    used: 37.17 GiB (68.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
  ID-5: /var/tmp raw-size: 54.53 GiB size: 54.53 GiB (100.00%)
    used: 37.17 GiB (68.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.46 GiB used: 72 MiB (0.5%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 49.0 C
    mem: 48.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1348
  Processes: 429 Uptime: 16m wakeups: 0 Memory: total: 16 GiB
  available: 15.46 GiB used: 4.8 GiB (31.0%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
  clang: 16.0.6 Packages: 1884 pm: pacman pkgs: 1879 libs: 510
  tools: pamac,paru pm: flatpak pkgs: 5 Shell: Zsh v: 5.9 running-in: konsole
  inxi: 3.3.30
Garuda (2.6.16-1):
  System install date:     2023-02-25
  Last full system update: 2023-09-30
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

I have an old i7-3770K machine that won’t work with the zen kernel either, LTS works fine. Now I have both and test the Zen sometimes.
Sporadically I build an ISO with LTS kernel and upload it to the cloud, which is unfortunately down right now :frowning:
Sometimes there’s just something wrong :wink:


Kit can be so weird.

I just booted after turning it all off and giving the hardware a good looking over. You know, to be sure connectors are in fact connected and stuff.

Graphics came up just fine under that same Zen kernel.

crazy ex-girlfriend what GIF
(So seltsam, oder?)


…and now it doesn’t work again.

Angry Chicken GIF by happydog


Boot with LTS and stay for a month on it.


Yeah. Test zen each new release until fixed, or sick of waiting.


I had the same issue with zen kernel except it happens when I resume from hibernate. No indication of anything gone wrong in logs it thinks that it reached graphical target and started x which clearly never happened since I was stuck at the loading initramfs page and had to force shutdown the system.

I have tried other kernels since then and they all seem to work fine… Seems like problem is only with zen kernel and moved over to linux-clear bcoz performance. :racehorse: :grin:


Huh. Never heard of the clear kernel. I shall try it!

after downloading the clear kernel it gives a bunch of recommended kernel command line parameters. Do append them to your current existing command line params (not replace).


Just one question is that v1 or v3 kernel ?
And which schedular it uses ?

from what I understand linux-clear is a set of config files and patches used to affect how kernel is compiled so that it performs better on intel based platform hence the scheduler it uses is the one used by mainline kernel.

as can be seen the pkgbuild pulls both the mainline kernel, it’s patches and then the clear kernel patches to compile


You can also go through it’s repo to view what patches are being applied.

I am not sure what this means but the latest linux-clear has patches for the kernel 6.5.5-1366


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.