GrapeJuice gives locale error when starting

Hello Garuda Forum,
My problem is that grapejuice will not open. After installing grapejuice, I attempted to open it from my application launcher, the grapejuice icon bounced next to my mouse for a second then disappeared suddenly without grapejuice opening. I tried a few more times with the app icon bouncing next to my mouse for a second then suddenly disappearing. I knew right away something was wrong because I had set in the settings for the icon to bounce for 5 seconds. I then proceeded to uninstall and reinstall grapejuice with pacman and yay. it still did not open. then I proceeded to attempt to run grapejuice through the terminal and this was the output:

grapejuice
Traceback (most recent call last):
File "/home/mountainhunr/.local/bin/grapejuice", line 33, in <module>
sys.exit(load_entry_point('grapejuice==4.10.2', 'console_scripts', 'grapejuice')())
File "/usr/lib/python3.10/grapejuice/cli/main.py", line 191, in easy_install_main
main()
File "/usr/lib/python3.10/grapejuice/cli/main.py", line 179, in main
common_prepare()
File "/usr/lib/python3.10/grapejuice/cli/cli_common.py", line 27, in common_prepare
locale.setlocale(locale.LC_ALL, "")
File "/usr/lib/python3.10/locale.py", line 620, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting

I have very little idea what the output means. Please help me decipher the output and get to the root problem

I would like to end with a little bit about me: I am very grateful for everything you guys do. I moved from windows 10 to Garuda Linux because I got tired of how I couldn't easily change everything about it and I wanted something Arch-based and did not mind a slight challenge (I also love the Dragonised Flavor). I don't mind getting my hands dirty in the terminal (I actually enjoy the terminal to some extent but wished I knew more :wink:) I have had to reinstall Garuda Linux 3 times (because of something I did in my infancy of a Linux user :wink: ), each time grabbing my USB flash drive and starting over. Why? because I love Linux and love what the Garuda team has done to arch Linux! Also if you tell me to run a command, I will run it, if you ask me to edit a file, I will do it. I am also the kind of person who will search for hours on end trying to find a solution to a problem when I could spend 15 minutes putting in a ticket.

Thanks for all that you do,
mountain

Here is the garuda-inxi output:

garuda-inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "en_US.UTF-8",
LC_NAME = "en_US.UTF-8",
LC_MONETARY = "en_US.UTF-8",
LC_PAPER = "en_US.UTF-8",
LC_IDENTIFICATION = "en_US.UTF-8",
LC_TELEPHONE = "en_US.UTF-8",
LC_MEASUREMENT = "en_US.UTF-8",
LC_TIME = "Default.UTF-8",
LC_NUMERIC = "en_US.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
Kernel: 5.16.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f79b7d3f-db53-44a8-bee8-dc744db91530 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Portable System: Dell product: Dell System Inspiron N7110 v: N/A
serial: <superuser required> Chassis: type: 8 v: 0.1
serial: <superuser required>
Mobo: Dell model: 0YH79Y v: A00 serial: <superuser required>
UEFI-[Legacy]: Dell v: A04 date: 03/25/2011
Battery:
ID-1: BAT0 charge: 0.6 Wh (85.7%) condition: 0.7/4.4 Wh (14.8%) volts: 12.2
min: 11.1 model: LGC Dell type: Li-ion serial: <filter> status: N/A
Device-1: hidpp_battery_2 model: Logitech Wireless Keyboard K330
serial: <filter> charge: 50% (should be ignored) rechargeable: yes
status: Discharging
Device-2: hidpp_battery_3 model: Logitech Wireless Keyboard K330
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: Discharging
Device-3: hidpp_battery_4 model: Logitech Wireless Mouse M560
serial: <filter> charge: 5% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: model: Intel Core i7-2630QM bits: 64 type: MT MCP arch: Sandy Bridge
family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1589 high: 2701 min/max: 800/2900 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 797 2: 948 3: 797
4: 2314 5: 2688 6: 2701 7: 1283 8: 1191 bogomips: 31895
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel ports: active: HDMI-A-1,LVDS-1
empty: DP-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0116 class-ID: 0300
Device-2: Sunplus Innovation Laptop_Integrated_Webcam_HD type: USB
driver: uvcvideo bus-ID: 1-1.4:4 chip-ID: 1bcf:2881 class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositors: 1: kwin_x11 2: Tabby
driver: X: loaded: intel unloaded: modesetting alternate: fbdev,vesa
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 928x285mm (36.5x11.2")
s-diag: 971mm (38.2")
Monitor-1: HDMI1 mapped: HDMI-A-1 pos: primary,left
model: Samsung S24F350 serial: <filter> built: 2018 res: 1920x1080 hz: 60
dpi: 94 gamma: 1.2 size: 520x290mm (20.5x11.4") diag: 598mm (23.5")
ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-2: LVDS1 mapped: LVDS-1 pos: right model: AU Optronics
built: 2010 res: 1600x900 hz: 60 dpi: 107 gamma: 1.2
size: 380x210mm (15.0x8.3") diag: 438mm (17.2") ratio: 16:9
modes: 1600x900
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.3.7 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.16.11-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0
chip-ID: 8086:008a class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Centrino Advanced-N 6230 Bluetooth adapter type: USB
driver: btusb v: 0.8 bus-ID: 2-1.5:3 chip-ID: 8086:0189 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 894.25 GiB used: 113.95 GiB (12.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: TeamGroup model: T253X5960G
size: 894.25 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0A0 scheme: MBR
Partition:
ID-1: / raw-size: 894.25 GiB size: 894.25 GiB (100.00%)
used: 113.95 GiB (12.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 894.25 GiB size: 894.25 GiB (100.00%)
used: 113.95 GiB (12.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 894.25 GiB size: 894.25 GiB (100.00%)
used: 113.95 GiB (12.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 894.25 GiB size: 894.25 GiB (100.00%)
used: 113.95 GiB (12.7%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.68 GiB used: 32.2 MiB (0.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C mobo: 60.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 2750
Info:
Processes: 320 Uptime: 2h 55m wakeups: 78 Memory: 7.68 GiB
used: 4.15 GiB (54.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1923 lib: 454 flatpak: 0
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: yakuake
inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-02-01
Last full system update: 2022-05-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            nmb.service systemd-networkd-wait-online.service
1 Like

Hi there, welcome.
Most likely not related to your problem, but I see something strange here.

Is not consistent with

Which was the kernel in use when you installed Garuda.
Could you please try a

garuda-update

Providing the relevant output?

2 Likes

I would be happy to, though I will have to do it later for reasons that I do not need to go into here.

Did you reboot?

1 Like

This program is installed manually locally, so whoever did this should know how to fix perl/python/locale errors.
We can assist with system installed packages, unless some users have experience on these issues :person_shrugging: and can help.

FWIW,

this is not an Archlinux compatible setting, wherever this is applied from (perl / python / locale.conf, etc).

3 Likes

Try deleting ~/.config/plasma-localerc

Edit: if it doesn't work, try using Grapejuice with a new user to rule out some possible causes.