Gnome doesn't show the lock screen after waking sleep/suspend

❯ garuda-inxi 
System:
  Kernel: 6.0.7-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
    root=UUID=974f3ce6-ba35-41c5-a737-23cb1e2b873f rw [email protected]
    lsm=landlock,lockdown,yama,integrity,apparmor,bpf quiet splash
    mitigations=off rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 amd_pstate.epp=1
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Swift SF314-43 v: V1.04
    serial: <superuser required>
  Mobo: LN model: Sake_CA v: V1.04 serial: <superuser required>
    UEFI: Insyde v: 1.04 date: 07/28/2021
Battery:
  ID-1: BAT1 charge: 27.4 Wh (56.4%) condition: 48.6/53.2 Wh (91.2%)
    volts: 12.8 min: 11.6 model: COSMX AP20CBL type: Li-ion serial: <filter>
    status: charging
CPU:
  Info: model: AMD Ryzen 5 5500U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7
    (7nm) family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608102
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1064 high: 2893 min/max: 400/4056 scaling:
    driver: amd_pstate_epp governor: powersave cores: 1: 400 2: 400 3: 1777
    4: 2893 5: 400 6: 400 7: 400 8: 2103 9: 400 10: 1801 11: 1397 12: 400
    bogomips: 50354
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Lucienne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0
    chip-ID: 1002:164c class-ID: 0300 temp: 43.0 C
  Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-3:3
    chip-ID: 0408:a094 class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x683d built: 2019 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon Graphics (renoir LLVM 14.0.6 DRM 3.48
    6.0.7-1-cachyos) v: 4.6 Mesa 22.2.2 direct render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Acer Incorporated
    ALI driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Acer Incorporated
    ALI driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.0.7-1-cachyos running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:4 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 68.18 GiB (14.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: EDFK0S03
    temp: 59.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 64.41 GiB size: 64.41 GiB (100.00%) used: 19.19 GiB
    (29.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%) used: 308 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 64 GiB size: 64 GiB (100.00%) used: 8.32 GiB
    (13.0%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 64.41 GiB size: 64.41 GiB (100.00%) used: 19.19
    GiB (29.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 64.41 GiB size: 64.41 GiB (100.00%) used: 19.19
    GiB (29.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.12 GiB used: 394.2 MiB (5.4%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 412 Uptime: 22h 35m wakeups: 1916 Memory: 7.12 GiB used: 4.3 GiB
  (60.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: 1407 pm: pacman pkgs: 1379 libs: 359
  tools: gnome-software,pamac,paru pm: flatpak pkgs: 28 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-11-03
  Last full system update: 2022-11-06 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Thank you for your help!

Settings -> Privacy -> Screenlock ?

What does that setting reveal?

And, is it only after suspend? What about after a non-suspend lock?

gsettings can reveal much:

gsettings list-keys org.gnome.desktop.screensaver

Good luck

Everything is good there.

Dconf Editor:

The non-suspend lock option is not there in the gnome menu, as you can see in my original post.
And it doesn't get locked when the screen goes blank after some time.

'Super+L ' have any effect?

1 Like

Try a new/test user to eliminate any ~/.settings*. [ ~/.dot-stuff ]

Also, disable all extensions and give it a shot.

2 Likes

Nope, no effect

I created a new user, and screen locking worked there!
Disabling extensions doesn't have any effect on my user account.

1 Like

~/.dot-stuff

Did you do the

gsettings list-keys org.gnome.desktop.screensaver prompt?

Of course it may be another key affecting this as well.

❯ gsettings list-keys org.gnome.desktop.screensaver
color-shading-type
embedded-keyboard-command
embedded-keyboard-enabled
idle-activation-enabled
lock-delay
lock-enabled
logout-command
logout-delay
logout-enabled
picture-opacity
picture-options
picture-uri
primary-color
secondary-color
show-full-name-in-top-bar
status-message-enabled
user-switch-enabled

Check each one with gsettings or dconf editor and narrow it down.

I think it is gsettings KEY. ddg will know how to list the toggle on each key.

There is a way to reset all gsetting keys but that is rather nuclear.

I'd suggest locating the offending key(s) individually.

1 Like

I reset every setting in the screensaver section in the dconf editor, still not effect.

May it is to do with some (.)dot stuff?

  1. Disable all Gnome Shell extensions using Extensions apps and reboot to test (sometimes only disabling an extension is not enough to actually remove it from the Shell).

  2. If you still have issues, rename ~/.config then logout, login again and test if it works. If it does, then the culprit is something inside this folder, you will have to find it yourself by trial and error (journalctl -xp3 -b may help tho).

3 Likes

Disabling Gnome extensions and rebooting doesn't have any effect.

Yup! renaming .config file and re-logging in does pinpoint the issue to the folder!

1 Like

I tried renaming the dconf folder in the .config directory and logging back in(for checking), and then reverting as before.
But now everything has become like stock gnome, and I cannot revert back, even after renaming the folder!
:sweat_smile:

Now I will reset my home directory, delete everything and start again.

Now that I have formatted my Home partition and started afresh, the issue seems to have got resolved.

Thanks, @Cannabis and @LFOM, for your Help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.