Gnome cannot render Google Sans Medium/Bold font on interface

After a fresh installation, I tried changing the default font from Google Sans Regular to Google Sans Medium. In the text box, preview changes with the font weight, but it doesnt get reflected in the Gnome interface. Please see the screenshot:

EDIT:

Just found out that not just Google Sans medium, no other medium weights are being rendered. Same issue with Noto Sans Medium

1 Like

facing the same issue on interface fonts on gnome. no matter which font i choose…still looks pixelated.

1 Like

Whats your resolution and are you on Xorg or Wayland?

Edit: I just tried and myself and found GNOME to use the medium font on its shell and menu but not in apps like Nautilus for Firefox for example

It doesnt seem to be an issue exclusive to Garuda though maybe you try it this way?

wayland with a screen resolution of 1366*768 sir

gsettings set org.gnome.desktop.interface font-name 'Google Sans Medium, 12'

As you can see that gives you medium fonts but shows "none" in the gnome tweaks application. Might be a workaround for that issue.

1 Like

@dr460nf1r3 Thank you so much for that hack!

1 Like