Gnome and full-screen games

Alright, so I decided to install Gnome on the spare SSD I have to take it on a spin (the first time I installed it it gave me the infamous white screen - great job on fixing that!) but I am experiencing issues with full-screen (native) games.

On CS:GO, the top bar doesn't allow me to go full-screen and Black Mesa opens in a tiny window. Changing resolution and/or mode doesn't seem to solve it. I've even tried disabling Gnome tweaks.

In addition to this, the lock screen is all buggy.

I've tried looking on forums, but the solutions are pretty dated (which, I guess almost certainly, means that the issues have already been patched) and none of them have worked.

Any help is greatly appreciated :cowboy_hat_face:

1 Like

Well, can you please try please try sddm instead of lightdm.
Also let us know it it works

sudo pacman -S sddm
sudo systemctl enable sddm.service
sudo systemctl disable gdm.service

And reboot

1 Like
Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /usr/lib/systemd/system/lightdm.service.
Failed to disable unit: Unit file gdm.service does not exist.
1 Like

Sorry, disable lightdm first.

sudo systemctl disable lightdm.service
sudo systemctl enable sddm.service


Thanks for the input. Still experiencing the same problems, though :confused:

Thanks for the help, but I just realised what made me dislike GNOME so much. There's just too much of a hassle to fix it if smth happens :joy:

I don't care what people say, but I always find comfort in my old love Xfce's arms :smiling_face_with_three_hearts:

Thank you anyway, appreciate it :grin:


What resolution is your desktop? i3lock might not be able to upscale the Image is what came to my mind :face_with_raised_eyebrow:
Edit: nvm just saw the resolution of the pic posted. :man_facepalming: