Glyphs missing in Konsole (fish)

Recently upgraded to KDE6 and spent the better part of the last few hours trying to get everything set up the way I had it before. Try as I might, I cannot get the Konsole terminal glyphs to appear as they once did. (See the “square” icons in the attached screenshot for what I mean).

Tried using nerdfix on starship.toml as suggested elsewhere but that had no effect. Any ideas where to start looking would be helpful. Googling and forum-searching hasn’t turned up anything that’s relevant to me. Also the glyphs appear to work in Alacritty, but not in Konsole.

I’m on stock Dr460nized by the way



Kernel: 6.8.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bb56b6c6-cca3-4ece-83fc-02bd3975f545 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=6244d32d-2c70-477c-af93-53438cff4ad5 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: Micro-Star model: MEG Z490I UNIFY (MS-7C77) v: 1.2
serial: <superuser required> part-nu: B926.C uuid: <superuser required>
UEFI: American Megatrends v: C.40 date: 07/22/2020
Info: model: Intel Core i7-10700K bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 5 microcode: 0xFA
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1325 high: 5000 min/max: 800/5100 scaling:
driver: intel_pstate governor: performance cores: 1: 800 2: 800 3: 800
4: 800 5: 800 6: 800 7: 5000 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800
14: 800 15: 800 16: 5000 bogomips: 121596
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3
bus-ID: 00:02.0 chip-ID: 8086:9bc5 class-ID: 0380
Device-2: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 550.76 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: DP-3
empty: DP-4,DP-5,HDMI-A-4 bus-ID: 01:00.0 chip-ID: 10de:1e84
class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1080 s-dpi: 92 s-size: 707x301mm (27.83x11.85")
s-diag: 768mm (30.25")
Monitor-1: DP-3 mapped: DP-0 note: disabled model: MSI MAG301CR
built: 2020 res: 2560x1080 hz: 200 dpi: 94 gamma: 1.2
size: 690x291mm (27.17x11.46") diag: 762mm (30") modes: max: 2560x1080
min: 640x480
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia x11: drv: nvidia inactive: gbm,wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.76
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2070
SUPER/PCIe/SSE2 memory: 7.81 GiB
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 2070 SUPER driver: nvidia v: 550.76 device-ID: 10de:1e84
surfaces: xcb,xlib device: 1 type: integrated-gpu name: Intel UHD
Graphics 630 (CML GT2) driver: mesa intel v: 24.0.6-arch1.2
device-ID: 8086:9bc5 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.6-arch1.2 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403
API: ALSA v: k6.8.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 3b:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp59s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 953.87 GiB used: 545.98 GiB (57.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBPNTY-1T00-1032 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11111000 temp: 48.9 C scheme: GPT
ID-1: / raw-size: 919.26 GiB size: 919.26 GiB (100.00%)
used: 545.98 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 919.26 GiB size: 919.26 GiB (100.00%)
used: 545.98 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 919.26 GiB size: 919.26 GiB (100.00%)
used: 545.98 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 919.26 GiB size: 919.26 GiB (100.00%)
used: 545.98 GiB (59.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.18 GiB used: 22.8 MiB (0.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.3 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 39.0 C pch: 67.0 C mobo: N/A gpu: nvidia
temp: 37 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 24%
Memory: total: 32 GiB available: 31.18 GiB used: 6.6 GiB (21.2%)
Processes: 395 Power: uptime: 8h 7m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.41 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 2346 libs: 616 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-05-16
Last full system update: 2024-04-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            nmb.service

Please post the output of garuda-inxi for all topics in the Issues & Assistance category as requested in the topic template.

Topic template

:warning: Missing information requested in the template may result in not receiving assistance :warning:

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

The template above should be deleted before posting your help request.

We ask that this output always be included (even if some of the information is unlikely to help solve the issue), so our forum helpers can have a consistent baseline of information to troubleshoot issues with.

That is a good clue. Probably the terminals are configured to use different fonts. Check your Konsole settings to see what font it is configured to use. Then, install whatever the nerd font version of that is.

For example, if the terminal were using DejaVu Sans Mono, this would be the needed package:

The nerd fonts are patched with all the symbols and glyphs.


Added the garuda-inxi as requested.

Regarding your suggestion, I went into Konsole’s Settings > Edit Current Profile…
And under the Appearance tab, I can see that the font is set to “FantasqueSansMono Nerd Font Mono 11pt”
So it appears to already be installed. Octopi confirms that assumption, as I can see this is currently installed:

Patched font Fantasque Sans Mono from nerd fonts library

Any other suggestions?

try the non mono font an see

This happened to me too. Fallback to a nerd font is no longer working in Konsole. Works fine in other terminals but not Konsole. KDE broke something, it’s ignoring fallback fonts in fontconfig somehow.

The only fix I found is to do the nerd symbol patch or install a pre-patched font. If you don’t want to change your font to something else, you can patch it with font-patcher.

I just tested and was able to get it working with just the one suggestion.

Are you certain you have the font installed?

sudo pacman -S ttf-fantasque-nerd

Are you certain you have the right font selected in the Konsole settings menu?

After installing the font and making this change, the icons have returned.

I don’t really care for this font myself, but of course that is only a matter of preference.

1 Like

Okay, I went through your suggestions and confirmed that the font was installed with pacman. When I went into the Konsole profile settings to noodle with the fonts, I quickly realized that something was not quite right. Where it shows the font under Appearance, it said I was using Fantasque, but when I actually went into the Choose Font menu, it looked more like I was using the plain old “Monospace” font at the top of the list. So I changed to Fantasque and got the glyphs to appear! Success!

However, I quickly realized that I was never using Fantasque to begin with. So I compared with some screenshot I had prior to updating. The Monospace font looks like how I used to have it (minus the missing glyphs – so the Monospace IS the problem font, not Fantasque). Maybe I need to patch the Monospace font?

Either way, I don’t really care at this point. After seeing Fantasque for real, I decided against it and switched to Fira which also has working glyphs and looks pretty close to my old font.

I’ll mark your reply as Solution, and leave a note here for anyone running into similar issues: If you have problems with Konsole font, go into the Choose Font menu and check that you actually have the correct font picked. Just looking at the name of it inside the Appearance menu MAY SHOW THE INCORRECT FONT!

Of course I have no way to reproduce this issue as it fixed itself as soon as I chose a new font, but just something to be on the lookout for.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.