Ghost Windows

Hello, I am a relatively new user of Garuda(2-3 Months), but I have used linux a long time before and I encountered an error, that I have been trying to fix for over a week now, but couldn't yet.

So my problem is the following:
I don't know what information might help you, so I am trying to give you as much as possible. When I start my system, it works perfectly fine for a random amount of time(Even if I don't do anything). The time it works fine varies from 5-60min. Then all windows get slightly transparent(I set this to happen with all inactive windows) and start to act really odd. Windows, that I close, run through the normal close animation and then just come back and stay there as "Ghost Windows". All ghost windows and the one that is currently active "follow", when I switch virtual desktops. Windows that followed once will keep behaving like this, until the session ends even when closed or terminated. Windows that followed onto another desktop will be visible there and block me from using other windows, that are below them. There content is updated, but I am not able to interact with them, until I switch back to the desktop, that they originated from. Restarting the plasma desktop has no effect on this.

My best attempt at solving this issue was to change any setting in the compositor and hitting "apply". This dose seem to solve the problem(Windows behave normal again), but as soon as I do it I get massive system hang(That stays until session ends), even though there are plenty of resources available. After restarting the session(With or without changing compositor settings) everything works fine again for 5-60min and it starts all over again. I already tried other compositors and other settings for them, but nothing seems to change anything. I also don't recall changing any settings, before the issue first appeared.

Nothing like this ever happened to me in all my time using linux and I really wanna avoid to reinstall my system again. I hope you guys and girls might be able to help me with this :slight_smile:

Here is my output of "inxi -Fza", in case this might help you

System:    Kernel: 5.12.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a7904b94-855f-449f-9417-ba0d533a95cd 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.22.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509JA_F509JA v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X509JA v: 1.0 serial: <filter> UEFI: American Megatrends v: X509JA.300 
           date: 12/23/2019 
Battery:   ID-1: BAT0 charge: 25.2 Wh (98.4%) condition: 25.6/32.0 Wh (80.1%) volts: 7.6 min: 7.6 
           model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Charging cycles: 246 
CPU:       Info: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake family: 6 
           model-id: 7E (126) stepping: 5 microcode: A6 cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23961 
           Speed: 692 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 692 2: 1389 3: 1049 4: 3205 5: 1437 
           6: 809 7: 1180 8: 3181 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:8a52 class-ID: 0300 
           Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 1-5:5 
           chip-ID: 13d3:5a11 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: modesetting 
           unloaded: vesa alternate: fbdev,intel display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1332 s-dpi: 96 s-size: 1013x351mm (39.9x13.8") s-diag: 1072mm (42.2") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           Monitor-2: HDMI-1 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.15-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel port: 3000 bus-ID: 00:14.3 
           chip-ID: 8086:34f0 class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 
           bus-ID: 1-10:7 chip-ID: 8087:0aaa class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 96.42 GiB (20.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1202 
           size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 
           rotation: SSD serial: <filter> rev: 20200000 scheme: GPT 
Partition: ID-1: / raw-size: 167.64 GiB size: 167.64 GiB (100.00%) used: 96.38 GiB (57.5%) fs: btrfs 
           dev: /dev/nvme0n1p4 maj-min: 259:4 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 32.4 MiB (12.7%) fs: vfat 
           dev: /dev/nvme0n1p1 maj-min: 259:1 
           ID-3: /home raw-size: 167.64 GiB size: 167.64 GiB (100.00%) used: 96.38 GiB (57.5%) fs: btrfs 
           dev: /dev/nvme0n1p4 maj-min: 259:4 
           ID-4: /var/log raw-size: 167.64 GiB size: 167.64 GiB (100.00%) used: 96.38 GiB (57.5%) 
           fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4 
           ID-5: /var/tmp raw-size: 167.64 GiB size: 167.64 GiB (100.00%) used: 96.38 GiB (57.5%) 
           fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 7.57 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 1800 
Info:      Processes: 292 Uptime: 37m wakeups: 1 Memory: 7.57 GiB used: 4.32 GiB (57.0%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2349 lib: 464 
           Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.05 

Thanks a lot in advance!

First of all i would update your system as it out of date? then reboot and see if that help

4 Likes

Hi there, welcome.
Do you use any particolar kwin script?
I don't know if this will help, just came to my mind.

3 Likes

Thanks for your reply, but sadly no I already tried disabling all of them.

1 Like

It sounds video driver related.
Have you checked Archwiki for Intel troubleshooting? I would start there.

Quick try, check if you have intel video driver installed, or find in the logs why it uses modsetting.

:smiley: and nobody uncovered the great secret to you?

Check the logs! :wink:

Most info that would help find the problem are in the logs already and waiting...
man journalctl and less /var/log/Xorg.0.log

Bring us something!

1 Like

I am currently updating my system, to see if that has any effects. I am pretty sure, that I have install the Intel drivers correctly(Never had issues with them before), but here is my Xorg.0.log in case I am missing something. Xorg.0.log · GitHub

I have done a system update now, rebooted and waited some time, but sadly the issue still persists. Is there any other log file, that might contain information useful to solve this issue?

Here is the output of "journalctl -b": journalctl.log · GitHub

Could it be the same as here?
https://bugs.kde.org/show_bug.cgi?id=439332
Or maybe
https://bbs.archlinux.org/viewtopic.php?id=268643

2 Likes

It is sadly neither of them. The first one is only about popups and "sub-windows" and the second one about an error while dragging windows. It happens without any interaction after some time on my laptop. I have notices though, that it can be also be caused by switch virtual desktops often.

It seems to be linked to the compositor, since reloading it "kinda" fixes the issue. But I really can't tell what exactly is going wrong or how to fix it.

Try turning off translucency, blur or other effects.

2 Likes

Maybe this one?
https://bugs.kde.org/show_bug.cgi?id=438552

2 Likes

This log is too long. Please, educate yourself reading the command's manual on how to filter productively. (for the next time :wink: )

Your issue seems to match to this troubleshooting advice.
Test this method, having in mind that, as your logs and inxi report, for some reason your system uses the modesetting driver, not from the intel package xf86-video-intel.

Also post

grep "^MODULES" /etc/mkinitcpio.conf
lsmod | grep i915

Also check if it also happens without external monitor connected.

3 Likes

I have tried adding "LIBGL_DRI3_DISABLE=1" to my environment variables, disabling unnecessary blur and translucency effects and running the system with only one monitor. The error sadly still did not change. The bug filo send was sadly also not the solution.

I will educate myself about the journalctl command, thanks for the advise :sweat_smile:
I hope this might help you.

grep "^MODULES" /etc/mkinitcpio.conf

MODULES=(intel_agp i915 amdgpu radeon nouveau)

lsmod | grep i915

i915                 3112960  21
video                  57344  3 asus_wmi,i915,nouveau
i2c_algo_bit           16384  4 amdgpu,radeon,i915,nouveau
drm_kms_helper        319488  4 amdgpu,radeon,i915,nouveau
cec                    81920  2 drm_kms_helper,i915
drm                   630784  28 gpu_sched,drm_kms_helper,amdgpu,radeon,drm_ttm_helper,i915,ttm,nouveau
intel_gtt              24576  2 intel_agp,i915

It may not matter to your case, but try with only this

MODULES=(i915)

Then

sudo mkinitcpio -P

and reboot.

Also, try different compositor settings (OpenGL 2.0, XRender and others) in KDE Settings

2 Likes

Oh so I'm not the only one with these ghost windows. I've just thought it's probably the shitty NVidia drivers and rebooted the system. :smiley:

1 Like

I set "MODULES=(i915)", ran "sudo mkinitcpio -P", rebooted and I already tried OpenGL 3.1, OpenGL 2.0 and XRender. There is sadly no difference between them.

1 Like

I know it's a stupid test and I'm almost ashamed to propose it :blush:, but maybe you could try to create a new user to start from clean configurations

3 Likes

I am really sorry for the long time I needed to reply. I did try to create a new user and it seems to have solved the problem, so I tried to reset every setting on my main user which did nothing. Since this annoyed my for so long now I tried every setting I could find, because I wanted find the one that caused it. I was sadly unable to find anything. Does anyone has any idea which setting might be related to an error like this?

Since there is no issue with the system (great news), do the usual KDE cleanup. It could just be the cache, or some old values in kwin and other rc files, mentioning monitor names that changed (just guessing, by experience).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.