Getting back the app menu in the app window 🚧

Please use this FAQ and Tutorials topic.

2 Likes

Hopefully, I'll write a guide about the working solution for getting back the app menu in the app window. This is something I've been struggling with and that was requested in several posts.

This would fit well in the wiki, customization tips.

Can I apply for some writing permission?
Or shall I ask someone to update it once I've wrapped it all?

3 Likes

These are the steps I am aware of to move the app menu items from the top bar back to the individual app windows.

Initial Steps

  1. Right click the top “global” menu bar and select Enter Edit Mode.
  2. Hover your mouse over Global Menu on the top left and select Remove.
  3. Hover your mouse over Window Title (Dr460nized KDE) and select Remove.
  4. Then a little right of center click the red X “Close” button to exit Edit Mode.

From my current understanding this is the primary step to return the menu bar to most apps - if it’s not on the global menu bar it shows on each individual app. But some apps have some additional steps…

App Specific Fixes
Disclaimer: I and many here will argue the below should not be done as it really does reduce the cleanliness of the UI. The menu tasks are available through keyboard shortcuts (ideal) or the necessary mouse interactions.

Dolphin (File Browser) - The menu is accessed with a hamburger button on the top right. But if you want to have the menu along the top click the Hamburger and go to More → Show Menubar with All Actions. Or press CTRL-M.

Konsole (Terminal Window) - Right click anywhere in the terminal and go to Menu → More → Show Menubar with All Actions. Or press CTRL-SHIFT-M.

Firefox/FireDragon - Single tap the ALT key. (Not permanent)

Notes
While this is simple enough I have screenshots to provide here - for a legit Tutorial. But I am unable to upload them as a new user. I will fix this when I’m able to upload.

Open ~/.config/kwinrc in your favorite txt editor (Kate) and look for BorderlessMaximizedWindows=true. Set this to false and logout and back in.

I feel like this should be exposed in the Plasma settings panel but it is not at this time.

It will fix most things but not Firefox. For that you’ll need to click the hamburger, More Tools, Customize Toolbar, and click to enable the Title Bar on the bottom left.