Garuta won't boot into live environment

I tried both rufus and etcher boot installer programs with an ISO that i downloaded a few days ago and installed onto a spare laptop, but now when I try to install it into my main PC it won't even get into the live environment.

PC specs

ASRock X570 Taichi
AMD Ryzen 9 3950X
32.00 GB DDR4 SDRAM 1799 MHz
Zotac gaming Nvidia GeForce RTX 3080Ti

Below is a photo of where it gets stuck.

Have you already tried booting selecting free drivers option in the live USB GRUB menu?


No.... I have only ever selected Nvidia propriatary drivers... Would the free drivers one be able to boot with an NVIDIA card?

Try it :slight_smile:

1 Like

Yes, and in the final step of the setup you'll be able to install the proprietary drivers.
Or after you complete system installation, also via the Garuda Assistant.

Oh wow, that worked... As a tech I should have known to try that, but at least now it is here for others to fine.

If it gets stuck and you are using an nvidia card, try the opposite drivers when first booting (in my case, I was trying to use the nvidia proprietary drivers, and the open source drivers worked)

You will get asked if you want to install the NVIDIA drivers as part of the setup assistant, that should end up working just fine for you :slight_smile:

Ok, thanks for the info.

Would you mind informing me what exactly swap is and is for? I am installing the OS onto a completely separate drive, but I do have Windows on a drive on this PC (hopefully only for now); Should I use swap or not?

Edit: NVM, ended up finding a good artical that explains it. Swap is like a window's page file... it allows the system to save ram info to the OS disk to use if ram gets low. I have 32GB RAM so I don't think I need it.

Edit 2: I ended up deciding to add swap as it doesn't hurt to have for if I ever want to hibernate the PC

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.