Garuda's PrivateBin never loads

This has been plaguing the bin for at least a few weeks now but it seems no one’s reported it o_o so here we go.
The title says it all - all the page says is

In case this message never disappears please have a look at [this FAQ for information to troubleshoot](

I’ve tried Chromium and Librewolf, and tried toggling Ublock Origin to make sure it really wasn’t blocking the page from loading, but nothing changed no matter what I tried. Even getting a new computer didn’t fix it :joy:

If there’s any additional information needed to help diagnose the problem, let me know and I’ll provide what I can :slight_smile:


  Kernel: 6.6.10-lqx1-4-lqx arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm parameters: audit=0
    intel_pstate=disable rcupdate.rcu_expedited=1
    root=UUID=867152de-1564-471a-96a0-6a749ff830c1 rw rootflags=subvol=GQtile
    loglevel=3 ibt=off radeon_modeset=1 driver=nonfree
  Desktop: Qtile v: 0.23.0 wm: LG3D vt: 2 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Mini-pc System: Micro (HK) Tech product: Venus series v: N/A
    serial: <superuser required>
  Mobo: Shenzhen Meigao Equipment model: F7BSC serial: <superuser required>
    UEFI: American Megatrends LLC. v: 1.07 date: 09/01/2023
  Info: model: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics bits: 64
    type: MT MCP arch: Zen 4 gen: 5 level: v4 note: check built: 2022+
    process: TSMC n5 (5nm) family: 0x19 (25) model-id: 0x74 (116) stepping: 1
    microcode: 0xA704103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2751 high: 4689
    min/max: 400/5263:6228:5583:5743:5423:5903:6067 scaling:
    driver: amd-pstate-epp governor: performance cores: 1: 4689 2: 4684
    3: 3726 4: 3751 5: 3743 6: 3748 7: 400 8: 400 9: 4007 10: 400 11: 4682
    12: 400 13: 3911 14: 4689 15: 400 16: 400 bogomips: 127753
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Phoenix1 driver: amdgpu v: kernel arch: RDNA-3 code: Phoenix
    process: TSMC n4 (4nm) built: 2023+ pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, DP-6, DP-7,
    HDMI-A-2 bus-ID: c4:00.0 chip-ID: 1002:15bf class-ID: 0300 temp: 49.0 C
  Display: x11 server: X.Org v: 21.1.10 compositor: Picom v: git-b700a
    driver: X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Dell P2423D serial: <filter>
    built: 2023 res: 2560x1440 hz: 60 dpi: 123 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
    drv: radeonsi inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    gfx1103_r1 LLVM 16.0.6 DRM 3.54 6.6.10-lqx1-4-lqx) device-ID: 1002:15bf
    memory: 1.95 GiB unified: no
  API: Vulkan v: 1.3.274 layers: 7 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV GFX1103_R1) driver: mesa radv v: 23.3.2-arch1.2
    device-ID: 1002:15bf surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.2-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c4:00.1
    chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_ps
    v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_sof_amd_renoir,
    snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: c4:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: c4:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.6.10-lqx1-4-lqx status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE driver: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: f000 bus-ID: 01:00.0 chip-ID: 10ec:8125
    class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
    driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 8086:2725 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:5 chip-ID: 8087:0032
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: yes address: N/A
  Local Storage: total: 953.87 GiB used: 318.72 GiB (33.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PGP41024Q-A0
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: ELFK0S.6 temp: 30.9 C
    scheme: GPT
  ID-1: / raw-size: 848.35 GiB size: 848.35 GiB (100.00%)
    used: 318.68 GiB (37.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 35.8 MiB (7.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 848.35 GiB size: 848.35 GiB (100.00%)
    used: 318.68 GiB (37.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 848.35 GiB size: 848.35 GiB (100.00%)
    used: 318.68 GiB (37.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 848.35 GiB size: 848.35 GiB (100.00%)
    used: 318.68 GiB (37.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: swap-2 type: zram size: 60.54 GiB used: 3.8 GiB (6.3%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 53.4 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (rpm): N/A
  Processes: 510 Uptime: 19h 40m wakeups: 0 Memory: total: N/A
  available: 60.54 GiB used: 11.15 GiB (18.4%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1647 libs: 441 tools: paru Shell: fish v: 3.7.0
  running-in: alacritty inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-06
  Last full system update: 2024-01-09 
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            archlinux-keyring-wkd-sync.service

Hm, I get this error repeatedly in the browser’s DevTools console:

None of the “sha512” hashes in the integrity attribute match the content of the subresource. The computed hash is “f8dr3RsBabtkDAdYevQtYkoYFWhY9jjJljksJNIiF5486QEf3KiA8QAjcS/2YjenofT2VkHYd9ps63yNWSfJWA==”.

every time the hash is different

the FAQ says something about that

I bet it’s the Cloudflare thing, and something the site admins should look into.

Unrelated, this did not pass unnoticed to my eyes:

[Cloudflare] Apart from protecting your site against DDoS it acts as a man-in-the-middle even for HTTPS sites

yeah right I feel much safer now


Oh, you are right - the same thing is happening for me too.
Quick link for the Cloudflare thing:

Man in the middle attacks? Yay! :DDDD

1 Like

Indeed, we use Cloudflare to cache certain resources. We did observe the same issue with Mastodon lately. Now that cache level is set to bypass, we have it working again.


Amazing, can confirm the privatebin works now. Thanks for the quick action! :smiley:


I hope this is not too much off-topic, but I encountered an alias that seems to have been configured by default in the standard Garuda fish conf (at least in the Gnome edition) to use pastebin or the likes through nc. If this is set by Garuda, perhaps we can make it use (the Garuda specific) privatebin instead?

Sorry for being a bit vague, but I’m currently using another laptop, so I can’t double check the details.

No way :slight_smile:

alias tb='nc 9999'

I believe this feature is specifically provided by Termbin (as opposed to something any old pastebin service can do).


Ah yes, this is it:
alias tb 'nc 9999'

Thanks for clearing that up.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.