Garuda Won't wake from sleep

Hello.

I have just installed Garuda Linux on a second machine after finding it very suitable for my requirements. The first machine is using an Intel CPU and GPU and everything functions as required.
This second machine has an AMD CPU and a Nvidia GPU. Everything functions as required except the new machine won’t wake-up from sleep (old machine does).
I have checked in terminal and my mouse and keyboard USB ports are set to enabled to wake-up the PC. The Bios is also set correctly.
Have tried both wired and wireless mice and keyboards.
I have found much information on line about this but being a new user as far as terminal goes I find most of it confusing.
Hope someone can provide assistance.

The system details-

KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.6.3-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 3 3300X 4-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: B450M GAMING

garuda-inxi

System:
Kernel: 6.6.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=063afcd1-5d45-4e3d-bb58-d1dd8013ba0e rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: B450M GAMING v: N/A
serial: <superuser required>
Mobo: Gigabyte model: B450M GAMING v: x.x serial: <superuser required>
UEFI: American Megatrends v: F50 date: 11/27/2019
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 3 3300X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3800 min/max: 2200/4349 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800 3: 3800
4: 3800 5: 3800 6: 3800 7: 3800 8: 3800 bogomips: 60684
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: ASUSTeK driver: nvidia
v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none
off: HDMI-A-1,HDMI-A-2 empty: DP-1,DVI-D-1 bus-ID: 0a:00.0
chip-ID: 10de:2182 class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia,nvidia-nvswitch display-ID: :0
screens: 1
Screen-1: 0 s-res: 5760x2160 s-dpi: 68 s-size: 2152x807mm (84.72x31.77")
s-diag: 2298mm (90.49")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled pos: primary,top-right
model: Samsung serial: <filter> built: 2018 res: 3840x2160 hz: 30 dpi: 52
gamma: 1.2 size: 1872x1053mm (73.7x41.46") diag: 1630mm (64.2")
ratio: 16:9 modes: max: 3840x2160 min: 640x480
Monitor-2: HDMI-A-2 mapped: HDMI-1 note: disabled pos: bottom-l
model: Dell P2217H serial: <filter> built: 2016 res: 1920x1080 hz: 60
dpi: 102 gamma: 1.2 size: 476x267mm (18.74x10.51") diag: 546mm (21.5")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
memory: 5.86 GiB
API: Vulkan v: 1.3.269 layers: 8 device: 0 type: discrete-gpu name: NVIDIA
GeForce GTX 1660 Ti driver: nvidia v: 545.29.06 device-ID: 10de:2182
surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256
bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.6.3-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 5.92 TiB used: 80.59 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
model: SPCC M.2 PCIe SSD size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: V1.0 temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD1003FZEX-00K3CA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A01 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Silicon Power
model: SPCC Solid State Disk size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 6B0
scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST5000LM000-2AN170
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: HDD rpm: 5526
serial: <filter> scheme: GPT
Partition:
ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 80.59 GiB (34.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 80.59 GiB (34.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 80.59 GiB (34.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
used: 80.59 GiB (34.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.4 C mobo: 33.0 C gpu: nvidia temp: 40 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 27%
Info:
Processes: 270 Uptime: 7m wakeups: 0 Memory: total: 16 GiB
available: 15.56 GiB used: 2.89 GiB (18.6%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1444 libs: 414 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-07-04
Last full system update: 2023-12-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            systemd-vconsole-setup.service
grep . /sys/bus/usb/devices/*/power/wakeup
/sys/bus/usb/devices/1-7/power/wakeup:enabled
/sys/bus/usb/devices/1-8/power/wakeup:enabled
/sys/bus/usb/devices/usb1/power/wakeup:disabled
/sys/bus/usb/devices/usb2/power/wakeup:disabled
/sys/bus/usb/devices/usb3/power/wakeup:disabled
/sys/bus/usb/devices/usb4/power/wakeup:disabled
/sys/bus/usb/devices/usb5/power/wakeup:disabled
/sys/bus/usb/devices/usb6/power/wakeup:disabled
cat /proc/acpi/wakeup | grep enabled
GPP0      S4    *enabled   pci:0000:00:01.1
GPP8      S4    *enabled   pci:0000:00:03.1
GP12      S4    *enabled   pci:0000:00:07.1
GP13      S4    *enabled   pci:0000:00:08.1
XHC0      S4    *enabled   pci:0000:0c:00.3
GP30      S4    *enabled   pci:0000:00:08.2
GP31      S4    *enabled   pci:0000:00:08.3
GPP2      S4    *enabled   pci:0000:00:01.3
PTXH      S4    *enabled   pci:0000:02:00.0
1 Like

BIOS version is rather out of date. I would first tackle updating it.

4 Likes

I have updated to the latest BIOS but that does not help. The PC tries to wake up when I tap the keyboard. The fans start spinning with no display output. I still have to power down to get it to start again.
Any Ideas?

Thanks,
Vince.

Check in your BIOS settings for PCIe ASPM or other advanced power management options and try disabling them.

Also check that pressing the power button itself is not needed to wake the device. Not holding it down like to shut it off, just give it a press and see if anything happens.

3 Likes

I have checked the BIOS and PCIe ASPM is disabled. Could not identify any other advanced power management functions.
Allowing the PC to wake up with mouse or keyboard was disabled but enabling them has done nothing to help.
Taping the power button does not get Garuda to wake. I have to turn it off to restart.
I am dual booting with windows 11 untill I can get a Linux distro to function as I need it too.
Dual booting with windows on my other PC does not cause an issue.

Thanks.

Another intervention you can try is to switch to the s2idle suspend mode by adding the mem_sleep_default=s2idle kernel parameter. You can add it to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and regenerate the Grub config (sudo update-grub), or just add it on the kernel parameters line in Garuda Boot Options and click Apply:

This is considered a less efficient suspend state from an energy use standpoint, but that is typically only problematic when running a laptop on the battery and it looks like you have a desktop.

1 Like

Just wanted to chime in that I also experience this issue on desktop, but not always - it’s like a 10% chance it won’t wake up out of sleep. I’ll try @BluishHumility 's mem_sleep_default=s2idle recommendation too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.