Garuda Wont Boot

I installed Garuda Linux on an external M2 2280 SSD because I would like to use the system as a mobile alternative for work.
Now I have the problem that Garuda Linux simply won’t boot, even if I deactivate or remove the hard drives on which Windows is installed.
Either Windows starts despite the fact that the external SSD is first in the UEFI boot order, or the external SSD is not recognized by the PC if all other hard drives are removed or deactivated.
Since I can’t even access Garuda, I don’t have a Garuda inxi file.
Does anyone have an idea how I can solve this problem.
I have already tried reinstalling the system and loaded Garuda onto a USB stick using RUFUS. Then installed Garuda on the external M2 Usb SSD.
My PC is an HP Compaq 6200 pro Microtower with I7 3770 and Nvidia GTX 1650 OC, 16 Gigabyte Ram Quad Channel. Fastboot and Secure boot are Deactivated.

Make sure also CSM is disabled (or BIOS is set to UEFI only mode) and the SATA controller is set to AHCI mode (not RAID, or anything else).

Boot to the live environment (where you ran the installer), and launch a web browser. Then log into the forum and post the garuda-inxi from the live environment.

Also from the live environment, mount the external drive (where you installed Garuda) and the local disk on the laptop (with Windows). Then post these outputs:

sudo parted -l
lsblk -f

i haven’t seen CSM, but the Bios are set to UEFI Only mode, and the SATA controller is set to AHCI because of my SSDs they work only with AHCI. the Garuda Inxi file i will post in a few min.

Welcome to the Garuda community @Kazumaru . :wave:

As we don’t have your garuda-inxi, we have no idea if your bios is up to date. As hardware support is greatly affected by the bios, having the most recent bios version installed is extremely important.

So I solved the problem while I picked out all the files you needed. The problem was that the hard drive where Garuda was installed was not formatted as a boot medium, so the BIOS system recognized the hard drive but did not boot it. I reinstalled Garuda and this time used the Delete Partitions tab and the EFI boot partition was created, with Garuda System. thx for the Help haven’t found this if u haven’t asked for the files

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.