Garuda-Welcome program

Hey, just reporting a strange bug i've encountered today, the Garuda-Welcome gui will run when clicked but none of the programs such as (Garuda assistant, Garuda settings manager or Garuda gamer) will run from the Gardua-Welcome gui, instead they will open a terminal to update then close, and will do this every time they are clicked. Each of the Garuda programs still run when run from the terminals though.

It's not a big deal but i thought i would mention it as there are no other reports of it on the forum.

System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=51bae930-2502-45af-85e7-fceef81c9acf rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=21d2e5f2-ccec-41b6-8b09-c865e5a6faab loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASUSTeK model: MAXIMUS IX FORMULA v: Rev 1.xx serial: <filter>
UEFI: American Megatrends v: 1301 date: 03/14/2018
CPU:       Info: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake family: 6
model-id: 9E (158) stepping: 9 microcode: EA cache: L2: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67200
Speed: 4503 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4503 2: 4502 3: 4500 4: 4501 5: 4501
6: 4187 7: 4499 8: 4500
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b06 class-ID: 0300
Device-2: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:1b06 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 106 s-size: 824x352mm (32.4x13.9") s-diag: 896mm (35.3")
Monitor-1: DP-2 res: 3440x1440 hz: 100 dpi: 107 size: 819x346mm (32.2x13.6") diag: 889mm (35")
OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
Device-2: NVIDIA GP102 HDMI Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:10ef class-ID: 0403
Device-3: NVIDIA GP102 HDMI Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus-ID: 02:00.1
chip-ID: 10de:10ef class-ID: 0403
Device-4: RODE Microphones RODE NT-USB type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-3:2 chip-ID: 19f7:0003 class-ID: 0300
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: ASUSTeK
driver: ath10k_pci v: kernel bus-ID: 05:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth: Device-1: ASUSTek Qualcomm Bluetooth 4.1 type: USB driver: btusb v: 0.8 bus-ID: 1-11:10
chip-ID: 0b05:1825 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 1.36 TiB used: 92.43 GiB (6.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B7QCXE7 temp: 40.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: MBR
Partition: ID-1: / raw-size: 431.05 GiB size: 431.05 GiB (100.00%) used: 92.43 GiB (21.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 431.05 GiB size: 431.05 GiB (100.00%) used: 92.43 GiB (21.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 431.05 GiB size: 431.05 GiB (100.00%) used: 92.43 GiB (21.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 431.05 GiB size: 431.05 GiB (100.00%) used: 92.43 GiB (21.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.42 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 31.29 GiB used: 4.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 37 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 265 Uptime: 27m wakeups: 0 Memory: 31.29 GiB used: 3.67 GiB (11.7%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 Packages: N/A pacman: 0 Shell: fish v: 3.3.1 default: Bash
v: 5.1.8 running-in: konsole inxi: 3.3.08

Edit: i've done several system wide updates and reinstalled the garuda-welcome program if that helps.

This is the output of garuda-welcome when run in the terminal:
Icon theme "gnome" not found.
QMetaObject::connectSlotsByName: No matching signal for on_buttonBigbluebutton_clicked()
"btrfs"

Work fine here.

Hi

I recently installed Garuda Linux this morning and the Setup-assistant wont install any programs on on my computer.

I am quite new to linux, how do I run a program so I get a terminal output so I can atleast see what is happening in the background?

Any help is greatly appreciated.

Kind regards

Josh

open up a terminal like Konsole and just type in: setup-assistant
it should open the program and display some messages as well.

1 Like

In terminal

garuda-welcome

Refresh mirrors first.

Thank you for the help.

I now have error outputs via the terminal. Would you like me to create a new topic or to reply here?

I don't want to hijack Zadoww's issue with my own if that will cause a problem.

Kind regards

Josh

I have found the set up assistant a bit hinky at times so i tend to just avoid using the GUI like the package manager if I need to tweak something I just use the CLI and run with sudo after reading pretty much everything on the Arch wiki to ensure I have covered all potential issues.

It doesn't hurt to report an issue if the Garuda-Welcome program is not working, However, as @Biotechy2k already stated the terminal is your friend.

Learn it, live it , love it. :grinning_face_with_smiling_eyes:

1 Like

Does garuda-welcome-git behave the same?

i do use the terminal and do love it :slight_smile:

it's not a big problem as i can do most of what it does myself, but still i see a problem and i want to try and fix it, so if someone else eventually has the same problem they know how.

i tried uninstalling the garuda-welcome and replacing it with garuda-welcome-git but the behavior was the same.

Edit: Weirdly starting the partition manager, add/remove software and system cleaner from garuda-welcome work as normal.

2 Likes

This problem fixed itself after the today's system update.

Comedy Central Reaction GIF by Lights Out with David Spade

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.