Garuda-Update Won't Save

Hey y’all,

I’m back to Garuda after a dual-boot with Windows 10 wrecked the bootloader. Just live USB’d and fixed it right up.

However, now when I run garuda-update, I get the following that doesn’t seem to save the update, as everytime I run it it does the same thing. These are causing issues with package installs as well because it finds conflicts. Also, not really sure what to pick for those replacements down at the bottom as there are a lot of options.

I did some research and found I can replace some of them, but for many other options I didn’t find anything on the forums or online.

Any ideas?

[🧱] × garuda-update -a
:: Synchronizing package databases...
 garuda is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 chaotic-aur is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Synchronizing package databases...
 garuda downloading...
 core downloading...
 extra downloading...
 multilib downloading...
 chaotic-aur downloading...
:: Starting full system upgrade...
:: Replace appstream-qt with extra/appstream-qt5? [Y/n] y
:: Replace attica with extra/attica5? [Y/n] y
:: Replace baloo with extra/baloo5? [Y/n] y
:: Replace bluez-qt with extra/bluez-qt5? [Y/n] y
:: Replace exa with extra/eza? [Y/n] y
:: Replace frameworkintegration with extra/frameworkintegration5? [Y/n] y
:: Replace kactivities with extra/kactivities5? [Y/n] y
:: Replace kactivities-stats with extra/kactivities-stats5? [Y/n] y
:: Replace karchive with extra/karchive5? [Y/n] y
:: Replace kauth with extra/kauth5? [Y/n] y
:: Replace kbookmarks with extra/kbookmarks5? [Y/n] y
:: Replace kcalendarcore with extra/kcalendarcore5? [Y/n] y
:: Replace kcmutils with extra/kcmutils5? [Y/n] y
:: Replace kcodecs with extra/kcodecs5? [Y/n] y
:: Replace kcolorpicker with extra/kcolorpicker-qt5? [Y/n] y
:: Replace kcompletion with extra/kcompletion5? [Y/n] y
:: Replace kconfig with extra/kconfig5? [Y/n] y
:: Replace kconfigwidgets with extra/kconfigwidgets5? [Y/n] y
:: Replace kcontacts with extra/kcontacts5? [Y/n] y
:: Replace kcoreaddons with extra/kcoreaddons5? [Y/n] y
:: Replace kcrash with extra/kcrash5? [Y/n] y
:: Replace kdbusaddons with extra/kdbusaddons5? [Y/n] y
:: Replace kdeclarative with extra/kdeclarative5? [Y/n] y
:: Replace kded with extra/kded5? [Y/n] y
:: Replace kdesu with extra/kdesu5? [Y/n] y
:: Replace kdnssd with extra/kdnssd5? [Y/n] y
:: Replace kdsoap with extra/kdsoap-qt5? [Y/n] y
:: Replace kfilemetadata with extra/kfilemetadata5? [Y/n] y
:: Replace kglobalaccel with extra/kglobalaccel5? [Y/n] y
:: Replace kguiaddons with extra/kguiaddons5? [Y/n] y
:: Replace kholidays with extra/kholidays5? [Y/n] y
:: Replace ki18n with extra/ki18n5? [Y/n] y
:: Replace kiconthemes with extra/kiconthemes5? [Y/n] y
:: Replace kidletime with extra/kidletime5? [Y/n] y
:: Replace kimageannotator with extra/kimageannotator-qt5? [Y/n] y
:: Replace kimageformats with extra/kimageformats5? [Y/n] y
:: Replace kio with extra/kio5? [Y/n] y
:: Replace kitemmodels with extra/kitemmodels5? [Y/n] y
:: Replace kitemviews with extra/kitemviews5? [Y/n] y
:: Replace kjobwidgets with extra/kjobwidgets5? [Y/n] y
:: Replace knewstuff with extra/knewstuff5? [Y/n] y
:: Replace knotifications with extra/knotifications5? [Y/n] y
:: Replace knotifyconfig with extra/knotifyconfig5? [Y/n] y
:: Replace kpackage with extra/kpackage5? [Y/n] y
:: Replace kparts with extra/kparts5? [Y/n] y
:: Replace kpeople with extra/kpeople5? [Y/n] y
:: Replace kpty with extra/kpty5? [Y/n] y
:: Replace kquickcharts with extra/kquickcharts5? [Y/n] y
:: Replace krunner with extra/krunner5? [Y/n] y
:: Replace kservice with extra/kservice5? [Y/n] y
:: Replace ktexteditor with extra/ktexteditor5? [Y/n] y
:: Replace ktextwidgets with extra/ktextwidgets5? [Y/n] y
:: Replace kunitconversion with extra/kunitconversion5? [Y/n] y
:: Replace kuserfeedback with extra/kuserfeedback5? [Y/n] y
:: Replace kwallet with extra/kwallet5? [Y/n] y
:: Replace kwayland with extra/kwayland5? [Y/n] y
:: Replace kwidgetsaddons with extra/kwidgetsaddons5? [Y/n] y
:: Replace kwindowsystem with extra/kwindowsystem5? [Y/n] y
:: Replace kxmlgui with extra/kxmlgui5? [Y/n] y
:: Replace libinput_gestures_qt with chaotic-aur/libinput-gestures-qt? [Y/n] y
:: Replace libkdcraw with extra/libkdcraw5? [Y/n] y
:: Replace libqaccessibilityclient with extra/libqaccessibilityclient-qt5? [Y/n] y
:: Replace mhwd-db-garuda-git with garuda/mhwd-db-garuda? [Y/n] y
:: Replace mhwd-garuda-git with garuda/mhwd-garuda? [Y/n] y
:: Replace modemmanager-qt with extra/modemmanager-qt5? [Y/n] y
:: Replace nerd-fonts-fantasque-sans-mono with extra/ttf-fantasque-nerd? [Y/n] y
:: Replace nerd-fonts-fira-code with extra/ttf-firacode-nerd? [Y/n] y
:: Replace networkmanager-qt with extra/networkmanager-qt5? [Y/n] y
:: Replace plasma-framework with extra/plasma-framework5? [Y/n] y
:: Replace prison with extra/prison5? [Y/n] y
:: Replace purpose with extra/purpose5? [Y/n] y
:: Replace qqc2-desktop-style with extra/qqc2-desktop-style5? [Y/n] y
:: Replace solid with extra/solid5? [Y/n] y
:: Replace sonnet with extra/sonnet5? [Y/n] y
:: Replace syndication with extra/syndication5? [Y/n] y
:: Replace syntax-highlighting with extra/syntax-highlighting5? [Y/n] y
:: Replace threadweaver with extra/threadweaver5? [Y/n] y
resolving dependencies...
:: There are 2 providers available for dbus-units:
:: Repository core
   1) dbus-broker-units  2) dbus-daemon-units

Enter a number (default=1): 2
:: There are 10 providers available for ladspa-host:
:: Repository extra
   1) ardour  2) audacity  3) carla  4) element  5) guitarix  6) muse  7) qtractor  8) rosegarden
:: Repository chaotic-aur
   9) ardour-git  10) carla-git

Enter a number (default=1): 1
:: There are 128 providers available for tessdata:
:: Repository extra
   1) tesseract-data-afr  2) tesseract-data-amh  3) tesseract-data-ara  4) tesseract-data-asm  5) tesseract-data-aze
   6) tesseract-data-aze_cyrl  7) tesseract-data-bel  8) tesseract-data-ben  9) tesseract-data-bod  10) tesseract-data-bos
   11) tesseract-data-bre  12) tesseract-data-bul  13) tesseract-data-cat  14) tesseract-data-ceb  15) tesseract-data-ces
   16) tesseract-data-chi_sim  17) tesseract-data-chi_sim_vert  18) tesseract-data-chi_tra  19) tesseract-data-chi_tra_vert
   20) tesseract-data-chr  21) tesseract-data-cos  22) tesseract-data-cym  23) tesseract-data-dan  24) tesseract-data-dan_frak
   25) tesseract-data-deu  26) tesseract-data-deu_frak  27) tesseract-data-div  28) tesseract-data-dzo  29) tesseract-data-ell
   30) tesseract-data-eng  31) tesseract-data-enm  32) tesseract-data-epo  33) tesseract-data-equ  34) tesseract-data-est
   35) tesseract-data-eus  36) tesseract-data-fao  37) tesseract-data-fas  38) tesseract-data-fil  39) tesseract-data-fin
   40) tesseract-data-fra  41) tesseract-data-frk  42) tesseract-data-frm  43) tesseract-data-fry  44) tesseract-data-gla
   45) tesseract-data-gle  46) tesseract-data-glg  47) tesseract-data-grc  48) tesseract-data-guj  49) tesseract-data-hat
   50) tesseract-data-heb  51) tesseract-data-hin  52) tesseract-data-hrv  53) tesseract-data-hun  54) tesseract-data-hye
   55) tesseract-data-iku  56) tesseract-data-ind  57) tesseract-data-isl  58) tesseract-data-ita  59) tesseract-data-ita_old
   60) tesseract-data-jav  61) tesseract-data-jpn  62) tesseract-data-jpn_vert  63) tesseract-data-kan  64) tesseract-data-kat
   65) tesseract-data-kat_old  66) tesseract-data-kaz  67) tesseract-data-khm  68) tesseract-data-kir  69) tesseract-data-kmr
   70) tesseract-data-kor  71) tesseract-data-kor_vert  72) tesseract-data-lao  73) tesseract-data-lat  74) tesseract-data-lav
   75) tesseract-data-lit  76) tesseract-data-ltz  77) tesseract-data-mal  78) tesseract-data-mar  79) tesseract-data-mkd
   80) tesseract-data-mlt  81) tesseract-data-mon  82) tesseract-data-mri  83) tesseract-data-msa  84) tesseract-data-mya
   85) tesseract-data-nep  86) tesseract-data-nld  87) tesseract-data-nor  88) tesseract-data-oci  89) tesseract-data-ori
   90) tesseract-data-pan  91) tesseract-data-pol  92) tesseract-data-por  93) tesseract-data-pus  94) tesseract-data-que
   95) tesseract-data-ron  96) tesseract-data-rus  97) tesseract-data-san  98) tesseract-data-sin  99) tesseract-data-slk
   100) tesseract-data-slk_frak  101) tesseract-data-slv  102) tesseract-data-snd  103) tesseract-data-spa  104) tesseract-data-spa_old
   105) tesseract-data-sqi  106) tesseract-data-srp  107) tesseract-data-srp_latn  108) tesseract-data-sun  109) tesseract-data-swa
   110) tesseract-data-swe  111) tesseract-data-syr  112) tesseract-data-tam  113) tesseract-data-tat  114) tesseract-data-tel
   115) tesseract-data-tgk  116) tesseract-data-tgl  117) tesseract-data-tha  118) tesseract-data-tir  119) tesseract-data-ton
   120) tesseract-data-tur  121) tesseract-data-uig  122) tesseract-data-ukr  123) tesseract-data-urd  124) tesseract-data-uzb
   125) tesseract-data-uzb_cyrl  126) tesseract-data-vie  127) tesseract-data-yid  128) tesseract-data-yor

Enter a number (default=1): 1
looking for conflicting packages...
:: garuda-common-settings and ipw2100-fw are in conflict. Remove ipw2100-fw? [y/N] y
:: garuda-common-settings and ipw2200-fw are in conflict. Remove ipw2200-fw? [y/N] y
:: plasma5-themes-sweet-full-git and sweet-theme-full-git are in conflict. Remove sweet-theme-full-git? [y/N] y
:: plasma5-themes-sweet-kde-git and sweet-kde-theme-git are in conflict. Remove sweet-kde-theme-git? [y/N] y
:: networkmanager-support and networkmanager-fortisslvpn are in conflict. Remove networkmanager-fortisslvpn? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kio breaks dependency 'kio' required by kfiredragonhelper
:: removing knotifications breaks dependency 'knotifications' required by kfiredragonhelper
:: removing kwindowsystem breaks dependency 'kwindowsystem' required by kfiredragonhelper
:: removing ki18n breaks dependency 'ki18n' required by kfiredragonhelper
:: removing kio breaks dependency 'kio' required by kipi-plugins
:: removing kio breaks dependency 'kio' required by kmozillahelper
:: removing knotifications breaks dependency 'knotifications' required by kmozillahelper
:: removing kwindowsystem breaks dependency 'kwindowsystem' required by kmozillahelper
:: removing ki18n breaks dependency 'ki18n' required by kmozillahelper
:: removing plasma-framework breaks dependency 'plasma-framework' required by latte-dock-git
:: removing knewstuff breaks dependency 'knewstuff' required by latte-dock-git
:: removing kxmlgui breaks dependency 'kxmlgui' required by libkipi
:: removing kservice breaks dependency 'kservice' required by libkipi

Nobody knows better than your Owen inxi edition. Check it thoroughly again, please.

1 Like

:point_up: Yes, where is the garuda-inxi requested in the topic template? My guess is it will reveal that this system has not been updated since last fall. :eyes:

The solution is to remove all these problematic packages, as described in this topic:

4 Likes

Thanks Bluish. I removed those packages, however I still get the same thing when I run garuda-update – just the same prompts. Like I said, I haven’t touched Garuda in a while. Last full updated in 2022. Is there another process besides garuda-update?

Here’s my garuda-inxi:

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=1e926034-725e-46e6-9059-0881a05a7307 rw rootflags=subvol=@
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: X99 OC Formula
    serial: <superuser required> UEFI: American Megatrends v: P1.40
    date: 10/09/2014
CPU:
  Info: model: Intel Core i7-5960X bits: 64 type: MT MCP arch: Haswell
    gen: core 5 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3F (63) stepping: 2 microcode: 0x49
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 20 MiB desc: 1x20 MiB
  Speed (MHz): avg: 3067 high: 3500 min/max: 1200/3500 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2867 2: 3500 3: 3500
    4: 3500 5: 2776 6: 3500 7: 3500 8: 2069 9: 3500 10: 3500 11: 1219
    12: 1650 13: 3500 14: 3500 15: 3500 16: 3500 bogomips: 95977
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com.
    driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1b06 class-ID: 0300
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-3.2:8 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 4000x2560 s-dpi: 107 s-size: 950x608mm (37.40x23.94")
    s-diag: 1128mm (44.41")
  Monitor-1: DP-4 pos: primary,bottom-r res: 2560x1440 dpi: 109
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: HDMI-0 pos: primary,top-left res: 1440x2560 hz: 60 dpi: 109
    size: 336x598mm (13.23x23.54") diag: 686mm (27.01") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
    520.56.06 direct render: Yes
Audio:
  Device-1: Intel C610/X99 series HD Audio vendor: ASRock
    driver: snd_hda_intel bus-ID: 3-1:2 v: kernel chip-ID: 046d:0ab7
    bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:8d20 serial: <filter>
    class-ID: 0403
  Device-2: NVIDIA GP102 HDMI Audio vendor: eVga.com. driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10ef class-ID: 0403
  Device-3: Logitech Blue Microphones type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3-3.2:8 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Server-1: JACK v: 0.125.0 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: kernel
    port: f000 bus-ID: 00:19.0 chip-ID: 8086:15a1 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280
  IF: wls4 state: up mac: <filter>
  Device-3: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: ASRock
    driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 04:00.0 chip-ID: 1969:10a1 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
Drives:
  Local Storage: total: 12.29 TiB used: 138.02 GiB (1.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 950 PRO
    512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B0QBXX7
    temp: 35.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD60EZRZ-00RWYB1 size: 5.46 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5700 serial: <filter>
    rev: 0A80 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD60EZRZ-00RWYB1 size: 5.46 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5700 serial: <filter>
    rev: 0A80 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 138.02 GiB
    (14.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 1.8 MiB
    (0.7%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 138.02
    GiB (14.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 138.02
    GiB (14.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
  ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 138.02
    GiB (14.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.24 GiB used: 768 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 56 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 15%
Info:
  Processes: 311 Uptime: 6m wakeups: 0 Memory: 31.24 GiB used: 3.67 GiB
  (11.8%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: 1573 pm: nix-default pkgs: 0 pm: nix-sys
  pkgs: 0 pm: nix-usr pkgs: 2 pm: pacman pkgs: 1571 libs: 358
  tools: pamac,paru,yay Shell: fish v: 3.5.1 running-in: alacritty
  inxi: 3.3.22
Garuda (2.6.3-2):
  System install date:     2021-04-29
  Last full system update: 2022-10-20
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Timeshift (maybe)
  Failed units:            bluetooth-autoconnect.service

So, based on those kfiredragonhelper issues I saw this:

And ran

paru -R kfiredragonhelper

Now I ran through the some of the same lines but it’s downloading a bunch of packages now. Looks like 3GB of stuff. Will keep everyone posted for reference.

Looks good! Thanks for the help and guidance.

Yes, sorry if I was not clear but I did not mean you need to uninstall the packages mentioned in the linked thread–rather, I meant you need to uninstall these packages:

Sounds like you got it sorted now though. Glad to hear you were able to bring it back up to date. Welcome to the community @rhh4x0r! :wave::slightly_smiling_face:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.