Garuda update upset lutris

Hello,

I've recently updated after forgetting to for week or so and suddenly Lutris doesn't seem to recognise Vulkan DXVK - I opted to ignore the warning and proceed to open the b-net client, When i launch WoW it tells me my 3D Accelerator Card is not supported.

I was playing last night before I updated via Garuda Assistant

Admittedly I'm a Garuda noob so i don't know where to start but a bit of googling got me to what my problem is - i just don't know where to fix it on this OS

I took the jump to this OS after being pro+ windows for seemingly all my life and I'll never look back - my learning has been steep so far :smiley:

Anyone able to help please?

I tried to do a vulkaninfo but got output

[email protected] in ~ as 🧙 took 32ms
λ vulkaninfo
ERROR: [Loader Message] Code 0 : setup_loader_term_phys_devs:  Failed to detect any valid GPUs in the current config
ERROR: [Loader Message] Code 0 : setup_loader_tramp_phys_devs:  Failed during dispatch call of 'vkEnumeratePhysicalDevices' to lower layers or loader to get count.
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.203/vulkaninfo/vulkaninfo.h:230:vkEnumeratePhysicalDevices failed with ERROR_INITIALIZATION_FAILED

[email protected] in ~ as 🧙 took 22ms
λ ls /usr/share/vulkan/icd.d/
.rw-r--r-- 140 root 15 Feb 01:05  nvidia_icd.json

lspci -k output

01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1)
Subsystem: Gigabyte Technology Co., Ltd Device 3733
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

Here's my garuda-inxi output

System:
Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d261498c-5a28-403f-be17-3e157d5d8bee rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: B460 Pro4 serial: <superuser required>
UEFI: American Megatrends v: P1.60 date: 09/03/2020
CPU:
Info: model: Intel Core i7-10700 bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xEE
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 4333 high: 4760 min/max: 800/4800 scaling:
driver: intel_pstate governor: performance cores: 1: 4697 2: 4708 3: 4699
4: 4699 5: 4700 6: 2103 7: 1354 8: 4700 9: 4712 10: 4760 11: 4703
12: 4704 13: 4701 14: 4700 15: 4702 16: 4696 bogomips: 92796
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3965x1200 s-dpi: 95 s-size: 1060x321mm (41.7x12.6")
s-diag: 1108mm (43.6")
Monitor-1: DP-0 pos: right res: 1920x1200 hz: 60 dpi: 94
size: 518x324mm (20.4x12.8") diag: 611mm (24.1")
Monitor-2: HDMI-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.9x11.8") diag: 609mm (24")
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:
Device-1: Intel Comet Lake PCH-V cAVS vendor: ASRock driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a3f0 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Device-3: Corsair VOID ELITE Wireless Gaming Dongle type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:4 chip-ID: 1b1c:0a55
class-ID: 0300
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d55 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Ralink RT5392 PCIe Wireless Network Adapter driver: rt2800pci
v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
chip-ID: 1814:5392 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-2: docker_gwbridge state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-3: veth41c2baa state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-4: veth58e89cf state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-5: vethb9eaf71 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Drives:
Local Storage: total: 2.39 TiB used: 612.13 GiB (25.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: Origin Inception
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: E8FM11.3
temp: 32.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Toshiba model: N/A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: ADHA0101
temp: 51.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3500312CS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
type: HDD rpm: 5900 serial: <filter> rev: SC13 scheme: MBR
ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A750
scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST500LT012-1DG142
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM1
scheme: MBR
ID-6: /dev/sdd maj-min: 8:48 vendor: SanDisk model: SSD PLUS 120 GB
size: 111.8 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00RL scheme: GPT
Partition:
ID-1: / raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 38.02 GiB (34.1%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/sdd1 maj-min: 8:49
ID-3: /home raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 38.02 GiB (34.1%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-4: /var/log raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 38.02 GiB (34.1%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-5: /var/tmp raw-size: 111.5 GiB size: 111.5 GiB (100.00%)
used: 38.02 GiB (34.1%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.28 GiB used: 18.2 MiB (0.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 28.0 C mobo: 31.0 C gpu: nvidia temp: 58 C
Fan Speeds (RPM): fan-1: 1188 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0
fan-6: 0 fan-7: 0 gpu: nvidia fan: 0%
Info:
Processes: 467 Uptime: 3h 29m wakeups: 0 Memory: 31.28 GiB
used: 6.17 GiB (19.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1809 lib: 518 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-02-17
Last full system update: 2022-03-04
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service samba.service

A link would be nice.

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Please edit your postDone for you.

and

:slight_smile:

1 Like

Even though you have updated your kernal is outdated?
Have you rebooted after update?
Also try

garuda-update

Then reboot

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.