Garuda-Update Update Error

New ‘garuda-update’ this morning but when installing, it fails with this error;

error: failed to commit transaction (conflicting files)
garuda-update: /etc/garuda/garuda-update/config exists in filesystem
Errors occurred, no packages were upgraded.

Just overwrite

sudo pacman -Syu --overwrite '*'
1 Like

Strange. Maybe you created the config manually earlier?

garuda-update -- --overwrite '*'

That command does not work, still getting the same error. :man_shrugging:

1 Like
Failed to start updatedb.service: Unit var-tmp.mount is masked.


And it “destroy” my settings :slight_smile:

sudo pacman -Syu --overwrite '*'
:: Paketdatenbanken werden synchronisiert …
 garuda ist aktuell
 core ist aktuell
 extra ist aktuell
 multilib ist aktuell
 chaotic-aur ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
Warnung: whoogle-git: Lokale Version (_r758.ge9c4ed6-1) ist neuer als chaotic-aur (0.8.3.r25.gcdf0b50-1)
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (5)             Alte Version  Neue Version  Netto-Veränderung

extra/blender         17:3.6.4-2    17:3.6.4-3            -1,20 MiB
garuda/garuda-update  4.2.3-1       4.2.4-1                0,00 MiB
extra/imagemagick             0,00 MiB
extra/openvdb         10.0.1-5      10.1.0-1              -3,92 MiB
extra/protobuf        24.3-1        24.4-1                 0,00 MiB

Gesamtgröße der installierten Pakete:  722,69 MiB
Größendifferenz der Aktualisierung:     -5,13 MiB

:: Installation fortsetzen? [J/n] 
(5/5) Schlüssel im Schlüsselbund werden geprüft                                [--------------------------------------------] 100%
(5/5) Paket-Integrität wird überprüft                                          [--------------------------------------------] 100%
(5/5) Paket-Dateien werden geladen                                             [--------------------------------------------] 100%
(5/5) Auf Dateikonflikte wird geprüft                                          [--------------------------------------------] 100%
(5/5) Verfügbarer Festplattenspeicher wird ermittelt                           [--------------------------------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 975
:: Paketänderungen werden verarbeitet …
(1/5) Aktualisiert wird openvdb                                                [--------------------------------------------] 100%
(2/5) Aktualisiert wird blender                                                [--------------------------------------------] 100%
(3/5) Aktualisiert wird garuda-update                                          [--------------------------------------------] 100%
(4/5) Aktualisiert wird imagemagick                                            [--------------------------------------------] 100%
Neue optionale Abhängigkeiten für imagemagick
    libjpeg-turbo: JPEG support [Installiert]
(5/5) Aktualisiert wird protobuf                                               [--------------------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
(1/9) Arming ConditionNeedsUpdate...
(2/9) Foreign/AUR package notification
ananicy-rules 1.r129.8ac5d97-1
mtplayer 14__2023.05.22-1
python-xpybutil 0.0.6-5
(3/9) Orphaned package notification...
libvips 8.14.5-1
(4/9) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(5/9) Warn about old perl modules
(6/9) Updating icon theme caches...
(7/9) Updating the desktop file MIME type cache...
(8/9) Performing snapper post snapshots for the following configurations...
==> root: 976
(9/9) Syncing all file systems...

 ╭─sgs@pro in ~ as 🧙 took 5s
 🕙 17:38:10
 ╰─λ upd
:: Paketdatenbanken werden synchronisiert …
 garuda ist aktuell
 core ist aktuell
 extra ist aktuell
 multilib ist aktuell
 chaotic-aur ist aktuell

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Paketdatenbanken werden synchronisiert …
 garuda wird heruntergeladen …
 core wird heruntergeladen …
 extra wird heruntergeladen …
 multilib wird heruntergeladen …
 chaotic-aur wird heruntergeladen …
:: Starting full system upgrade...
warning: whoogle-git: local (_r758.ge9c4ed6-1) is newer than chaotic-aur (0.8.3.r25.gcdf0b50-1)
 there is nothing to do
Failed to start updatedb.service: Unit var-tmp.mount is masked.
1 Like

I used Krusader and manually renamed the old ‘config’ file and then updated and it worked. Not sure what was going on there. thanks.


There is no way this was caused by updating garuda-update, it literally just removed an if clause:

Also didn’t have this error while updating to the new version :eyes:

1 Like

/me grumbles loudly

how many systems do you think i manage? only one system had that(*config exists) error…

garuda-inxi before reboot but after update

Kernel: 6.5.8-AMD-znver2 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver2
root=UUID=af8a89ce-dde7-4f59-9555-3606af1da2d7 rw rootflags=subvol=@
loglevel=3 quiet ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASRock model: A520M-HDV serial: <superuser required>
UEFI: American Megatrends LLC. v: P3.00 date: 06/29/2023
Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701030
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3754 high: 3900 min/max: 2200/4559 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3770 2: 3900
3: 3599 4: 3593 5: 3900 6: 3900 7: 3585 8: 3900 9: 3900 10: 3629 11: 3624
12: 3167 13: 3900 14: 3900 15: 3900 16: 3900 bogomips: 124608
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
speed: 8 GT/s lanes: 16 ports: active: DP-3,HDMI-A-1
empty: DP-1,DP-2,DVI-D-1 bus-ID: 05:00.0 chip-ID: 1002:67df class-ID: 0300
temp: 54.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,left
model: Samsung C32F391 serial: <filter> built: 2018 res: 1920x1080 hz: 60
dpi: 70 gamma: 1.2 size: 698x393mm (27.48x15.47") diag: 801mm (31.5")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Samsung C32F391
serial: <filter> built: 2018 res: 1920x1080 hz: 60 dpi: 70 gamma: 1.2
size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
drv: radeonsi inactive: wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 570 Series (polaris10
LLVM 16.0.6 DRM 3.54 6.5.8-AMD-znver2) device-ID: 1002:67df
memory: 7.81 GiB unified: no
API: Vulkan v: 1.3.264 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 570 Series (RADV POLARIS10) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:67df surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 07:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.5.8-AMD-znver2 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: br0 state: up speed: 1000 Mbps duplex: unknown mac: <filter>
Local Storage: total: 2.29 TiB used: 1.59 TiB (69.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: HP model: SSD EX920 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SVN139B temp: 33.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD20EZAZ-00L9GB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 0A80 scheme: GPT
ID-1: / raw-size: 459.54 GiB size: 459.54 GiB (100.00%)
used: 131.35 GiB (28.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.54 GiB size: 459.54 GiB (100.00%)
used: 131.35 GiB (28.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.54 GiB size: 459.54 GiB (100.00%)
used: 131.35 GiB (28.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.54 GiB size: 459.54 GiB (100.00%)
used: 131.35 GiB (28.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.28 GiB used: 199 MiB (0.6%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (rpm): fan-1: 1208 fan-2: 1410 fan-3: 0 fan-4: 0 fan-5: 0
gpu: amdgpu fan: 429
Processes: 413 Uptime: 2d 22h 16m wakeups: 0 Memory: total: 32 GiB
available: 31.28 GiB used: 7.77 GiB (24.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 2543 libs: 619 tools: octopi,pamac,paru
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2022-05-31
Last full system update: 2023-10-23 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:            bluetooth-autoconnect.service

I also have this error, but i can remember me that i have disabled the mirrorsearch with the option SKIP_MIRRORLIST=1. I think that was the reason that this file exists here, and every person who add this option ( maybe there are more options that can be set here ?) will have this problem.

Maybe this info helps for find the problem.

1 Like

Just after update with --overwrite ‘*’ you must edit the update config and remove the # in front of SKIP_MIRRORLIST=1

I think you are correct. I also removed the ‘#’ on two of the options, including disabling mirror search. I believe this is the culprit as to why the config file cannot be overwritten.

Okay, this is awkward but I’m pretty sure this whole thing is my fault. :face_with_peeking_eye:

I added a MR to deploy /etc/garuda/garuda-update/config a few weeks ago, as a fully commented-out file to make interacting with these options more accessible. As it was, no one would ever know these options even exist unless they read the wiki page, set up the missing directory, and added the file manually.

Of course, it never actually deployed because I forgot to update the pkgver. When @dr460nf1r3 put through this fix: fix: remove virt-manager-meta workaround (6e403d11) · Commits · Garuda Linux / Packages / Stable PKGBUILDs / Garuda Update · GitLab and updated the pkgver, it sent out the new config file as well.

Apparently, the way I did it is creating a problem for anyone who already had this file set up. What I (and probably everyone else) would have preferred would have been if a .pacnew file was created, although apparently that doesn’t just magically happen on it’s own. :smirk:

For next time, I’ll have to figure out how to set that up. :eyes:

In the meanwhile, another option instead of overwriting the file would be to move the existing config to backup before taking the update.

sudo mv  /etc/garuda/garuda-update/config /etc/garuda/garuda-update/config.bak

Then just move it back after finishing the update.

Sorry about that everyone!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.