Garuda-update failing from PGP signature Chaotic-AUR

I've seen a few different posts about this, but none of the fixes listed have fixed my problem.
When running garuda-update it gets to the very end and errors out on a PGP key failure

:: Retrieving packages...
 virt-manager-meta-5-4.2-any             3.3 KiB  11.3 KiB/s 00:00 [------------------------------------] 100%
 python-pynput-1.7.6-2.3-any           184.0 KiB   527 KiB/s 00:00 [------------------------------------] 100%
 garuda-blackarch-1.1.0-2-any           53.1 KiB   164 KiB/s 00:00 [------------------------------------] 100%
 Total (3/3)                           240.4 KiB   362 KiB/s 00:01 [------------------------------------] 100%
error: failed retrieving file 'garuda-blackarch-1.1.0-2-any.pkg.tar.zst' from cdn-mirror.chaotic.cx : Maximum file size exceeded
(673/673) checking keys in keyring                                 [------------------------------------] 100%
(673/673) checking package integrity                               [------------------------------------] 100%
error: virt-manager-meta: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/virt-manager-meta-5-4.2-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y

error: failed to commit transaction (invalid or corrupted package)

I have tried a few different things to fix this such as update remote keyring update remote fix neither of which has fixed it and update remote keyring seemed to fail in the same way. pacman -Syu also seems to run into the same issue.

Not sure where to go from here.

System:
  Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=ad73102b-016e-41e7-8285-94268bdc87b0 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=105be282-b731-4e67-a21c-f29178a98a0e loglevel=3 ibt=off
  Desktop: GNOME v: 43.5 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: Z170-A v: Rev 1.xx
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 2202
    date: 09/19/2016
CPU:
  Info: model: Intel Core i5-6600 bits: 64 type: MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1600 min/max: 800/3900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 1600 2: 1600 3: 1600 4: 1600 bogomips: 26399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Micro-Star MSI
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 03:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,left model: Asus VS248
    serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Sceptre F22
    built: 2021 res: 1920x1080 hz: 60 dpi: 103 gamma: 1.2
    size: 475x267mm (18.7x10.51") diag: 547mm (21.5") ratio: 15:9, 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 6600 (navi23 LLVM
    15.0.7 DRM 3.49 6.2.13-zen-1-zen) direct-render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 08:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp8s0 state: up mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-12:4 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-13:5 chip-ID: 0a12:0001 class-ID: e001
  Report: ID: hci1 rfk-id: 1 state: up address: N/A
Drives:
  Local Storage: total: 1.36 TiB used: 579.72 GiB (41.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 054 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: MBR
Partition:
  ID-1: / raw-size: 914.41 GiB size: 914.41 GiB (100.00%)
    used: 579.72 GiB (63.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 914.41 GiB size: 914.41 GiB (100.00%)
    used: 579.72 GiB (63.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 914.41 GiB size: 914.41 GiB (100.00%)
    used: 579.72 GiB (63.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 914.41 GiB size: 914.41 GiB (100.00%)
    used: 579.72 GiB (63.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: amdgpu temp: 47.0 C
    mem: 44.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
  Processes: 275 Uptime: 12m wakeups: 0 Memory: 15.54 GiB
  used: 3.64 GiB (23.4%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1664
  pm: pacman pkgs: 1648 libs: 478 tools: gnome-software,pamac,paru pm: flatpak
  pkgs: 16 Shell: fish v: 3.6.1 running-in: gnome-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-03-28
  Last full system update: 2023-05-08
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            anbox-container-manager.service systemd-networkd-wait-online.service```
1 Like

Hm, I have virt-manager-meta 5-4.2 installed and never got that error.
But if I try to reinstall I get the same error, and I just tried garuda-update with result:

error: failed retrieving file 'chaotic-aur.db' from cdn-mirror.chaotic.cx : The requested URL returned error: 404

I'd tend to think it's a problem of the mirror, now I try after commenting the cdn-mirror.chaotic.cx in /etc/pacman.d/chaotic-mirrorlist and report back.
If I recall correctly some similar thing happened time ago.


NO, that clears the failed retrieving but when I try reinstalling virt-manager-meta it still errors out the same way.


Maybe we just caught the mirrors off guard while synchronizing, but just in case it needs attention, I hope @dr460nf1r3 doesn't mind being pinged at midnight of a Saturday night. :grin:

6 Likes

virt-manager-meta no longer fails to install now.

As for the 404 on the db, does it still happen for you? I couldn't reproduce this right now.

2 Likes

No more 404, last time I checked around 3AM.
Still error on virt-manager, now I refresh and update and get back.
There's kernel update, will be ~10min or so.


Yes it works now.

2 Likes

Hi Guys :slight_smile:
Same issue here:
after a fresh install,
any software selected via the “Garuda Setup Assistant”, won’t install after download
due to Nico’s PGP signature being interpreted as corrupted

I tried the command fixes:

update remote keyring update remote fix

update remote keyring

but it didn’t solve the issue:

:: Proceed with installation? [Y/n]
:: Retrieving packages...
chaotic-keyring-20220803-1-any         26,9 KiB   117 KiB/s 00:00 [------------------------------------] 100%
archlinux-keyring-20230504-1-any     1164,5 KiB  2,75 MiB/s 00:00 [------------------------------------] 100%
Total (2/2)                          1191,5 KiB   805 KiB/s 00:01 [------------------------------------] 100%
(2/2) checking keys in keyring                                     [------------------------------------] 100%
(2/2) checking package integrity                                   [------------------------------------] 100%
error: chaotic-keyring: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is unknown trust
:: File /var/cache/pacman/pkg/chaotic-keyring-20220803-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

What’s next to try ?

wait :slight_smile:

2 Likes

Got the same keyring issue with fresh install.

Then I tried the offered command

Any idea to solve this?
Thx!

update remote keyring ?

2 Likes

Great, keyrings updated, first garuda-update worked as intended. Thank's a lot @dr460nf1r3

BTW, please, stop posting screenshots from terminal.

Ok, understood, but what`s the difference to @Staffonymous output?

Ein Text lässt sich leicht durchsuchen (Suchfunktion des Browsers oder einer Textverarbeitung),
man kann Fehlerausgaben kopieren und in eine Suchmaschine einfĂĽgen.
Es vereinfacht also die Arbeit der Helfenden.

Nebenbei verringert es den Forendatenverkehr und den Speicherbedarf, auch fĂĽr die Backups, die erstellt werden.

Gegen Fotos, die Sinn oder SpaĂź machen, haben wir nichts :slight_smile:

Da diese Forensoftware nichts vergisst, hilft es auch nichts, wenn man sie "löscht", man macht sie nur unsichtbar für die anderen Anwender des Forums.


A text can be easily searched (search function of the browser or a word processor),
you can copy error output and paste it into a search engine.
So it simplifies the work of the helpers.

Besides, it reduces forum traffic and memory requirements, also for the backups that are made.

We have nothing against photos that make sense or fun :slight_smile:

Since this forum software doesn't forget anything, it doesn't help if you "delete" them, you just make them invisible to the other users of the forum.

2 Likes

Ok, thx for the upgrade.
I was just short on time on fresh install so snapshot was the fastest method.
Will keep that in mind the next time I want to post output.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.