Garuda setup assistant issue

So in the latest Garuda Gamer OS, after you setup everything and update everything in order to continue using the Garuda Setup Assistant, after the update is done, Garuda setup assistant keeps saying it failed, which also blocks me from upgrading to Ultimate (so i can install Garuda Gamer apps).

Update setup

[sudo] password for gt2g:
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                          2045,7 KiB  1311 KiB/s 00:02 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
garuda                                 95,8 KiB  43,7 KiB/s 00:02 [------------------------------------] 100%
core                                  157,2 KiB   146 KiB/s 00:01 [------------------------------------] 100%
extra                                1746,9 KiB   487 KiB/s 00:04 [------------------------------------] 100%
community                               7,2 MiB   929 KiB/s 00:08 [------------------------------------] 100%
multilib                              166,0 KiB   130 KiB/s 00:01 [------------------------------------] 100%
chaotic-aur                          2045,7 KiB   557 KiB/s 00:04 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
warning: libnm: local (1.40.4-1) is newer than extra (1.40.2-1)
warning: networkmanager: local (1.40.4-1) is newer than extra (1.40.2-1)
warning: nm-cloud-setup: local (1.40.4-1) is newer than extra (1.40.2-1)
there is nothing to do

Checking for plugin updates
Nothing to install / update

System updated! 🐧
Press enter to exit

ive updated like 5 times, what should i do?

Welcome :slight_smile:

Read again :slight_smile:

Sometimes there are glitches during the update that are fixed on the next try.

Five times would be new to me but now all is well.

Could use the garuda-inxi as requested by the template, so I can only really guess here.
When I updated my systems for the first time, I usually found that I would have to restart before proceeding with the assistant (or anything else that would install through the GUI)

Thanks for reporting this, this issue was fixed. You will need to retry the update once after it "fails" again for it to work, however.


OMG, tysm! it worked now!

1 Like

I dont think it was a glitch, i think it was rather a bug. But anyway, the problem got solved because some1 from the Garuda Team (TNE) saw this and the issue has been fixed.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.