Garuda OS is stucking while working

I've been using garuda for 3 months. And it worked perfectly and I love it. But now I'm having some troubles. Since two days ago, the system started to stuck. First I thought it's because of the numerous tabs in browser. But now even with no apps running it stuck. Can anyone help me?

Followings are my system specification
OS: Garuda Linux
Host: Samsung DeskTop System CAAAAAAF
Kernel: 5.13.13-zen1-1-zen
Uptime: 1 hour, 22 mins
Packages: 1308 (pacman), 13 (snap)
Shell: bash
DE: Plasma 5.22.5
WM: KWin
WM Theme: Sweet-Dark
Terminal: konsole
CPU: Intel Core 2 Quad Q6600 (4) @ 2.4GHz
GPU: Intel 4 Series Chipset
Memory: 2.54GiB / 3.80GiB

PS: When I look at the system monitoring app it shows the memory goes 2-3gb and the cpu goes 40-65%.

Does my pc is the problem? (I mean the system requirements)

Hi there, welcome!
This is quite old. Haven't you been updating lately?
It reminds me this one, still in my mind :slight_smile:

Also, please, provide the output of inxi -Faz formatted with ~~~ before and after the text block.

6 Likes

Please open up htop and show a screenshot of it so we know what processes are running.

4 Likes

Yeah, I haven't update the system for month. I'll update it and here is the output of inxi -Faz. (I didn't get a screenshot cz it's quite big.)

╰─λ inxi -Faz
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=31462efd-23b4-43d9-9128-7cb5083a1f03 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=37a06802-8265-4d92-901e-28812d45594f loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: SAMSUNG product: Samsung DeskTop System v: CAAAAAAF serial: <filter> 
Chassis: SAMSUNG ELECTRONICS CO., LTD type: 3 serial: <filter> 
Mobo: SAMSUNG model: Samsung DeskTop System serial: <filter> BIOS: SAMSUNG v: 00PE 
date: 11/12/2009 
CPU:       Info: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP arch: Core Merom family: 6 
model-id: F (15) stepping: B (11) microcode: BA cache: L2: 4 MiB 
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19155 
Speed: 2394 MHz min/max: 1600/2400 MHz Core speeds (MHz): 1: 2394 2: 2394 3: 2394 4: 2394 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass status: Vulnerable 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 4 Series Integrated Graphics vendor: Samsung Co driver: i915 v: kernel 
bus-ID: 00:02.0 chip-ID: 8086:2e32 class-ID: 0300 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0") s-diag: 338mm (13.3") 
Monitor-1: VGA1 res: 1024x768 dpi: 63 size: 410x230mm (16.1x9.1") diag: 470mm (18.5") 
OpenGL: renderer: Mesa DRI Intel G41 (ELK) v: 2.1 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Samsung Co driver: snd_hda_intel 
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:27d8 class-ID: 0403 
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co 
driver: r8169 v: kernel port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus-ID: 1-8:4 
chip-ID: 148f:7601 class-ID: 0000 serial: <filter> 
IF: wlp0s29f7u8 state: up mac: <filter>
IF-ID-1: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:    Local Storage: total: 409.88 GiB used: 47.6 GiB (11.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3320820AS size: 298.09 GiB block-size:
physical: 512 B logical: 512 B speed: <unknown> type: N/A serial: <filter> rev: D scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 model: AITC KSM 120GB size: 111.79 GiB block-size: physical: 512 B
logical: 512 B speed: <unknown> type: SSD serial: <filter> rev: 2A0 scheme: MBR
Partition: ID-1: / raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 47.6 GiB (46.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 47.6 GiB (46.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 47.6 GiB (46.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 47.6 GiB (46.0%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.8 GiB used: 1.47 GiB (38.7%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.36 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2
maj-min: 8:18
Sensors:   System Temperatures: cpu: 70.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 262 Uptime: 1h 1m wakeups: 0 Memory: 3.8 GiB used: 2.46 GiB (64.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1308 lib: 334
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Just update your system and check whether the problem still persist or not! Also find process in

htop

with high ram usage as suggested by dragonfire.

2 Likes

use

convert your.png your.jpg
convert size 50% your.png your.jpg

Use spectacle / flameshot for partial screenshots.

1 Like

Hello guys I have updated the system but still its lagging...

So now is the time to check htop, to see what processes are taking the most of your CPU and RAM.
Apart from that, my suggestion would be to perform a full btrfs balance with the Garuda assistant and maybe switch to the linux-lts kernel.
If not enough, you could take some ideas here (It can be applied also to desktop, if not so performant):

2 Likes

I'm sorry for not informing, but I solved it yesterday. The reason for lagging is the baloo file extractor. It uses 24% of the memory and 60% of cpu. Also when I execute balooctl statatus it shows more than 2.5Gb in the file extractor. So I disable the baloo file extractor with balooctl disable. And now its fine.

Btw Thank you all for helping me.

You are using an older computer with a weak CPU and integrated GPU if I see correctly. The RAM size is also undersized for Garuda KDE.

If there is more than one browser open, it becomes sluggish.

I have marked the solution, htop, to find the culprit.

That it was baloo in this case does not help searchers when the system starts to stutter.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.