Garuda Optimization

I have Old Laptop the information about the PC is given below. I mostly use 2 to 3 application simultaneously. The other applications stuck in between, i checked the htop and the stats are as shown below. Just 2 to 3 application and the CPU consumption is almost 100%. any other ways to solve this. Like identifying and removing the unnecessary process or programs running in background or something? Previously i can run this many applications on windows 10 smoothly but in garuda linux the system hangs too much.

System Information

System:    Kernel: 5.13.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2c3e9637-10ef-4bc0-90bb-0b245dbe8da9 rw 
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Latitude E6420 v: 01 serial: <filter> Chassis: type: 9 serial: <filter> 
Mobo: Dell model: N/A serial: <filter> BIOS: Dell v: A14 date: 07/11/2012 
Battery:   ID-1: BAT0 charge: 18.0 Wh (39.0%) condition: 46.2/62.2 Wh (74.3%) volts: 11.0 min: 11.1 model: Sanyo DELL NH6K98C 
type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP arch: Sandy Bridge family: 6 model-id: 2A (42) 
stepping: 7 microcode: 2F cache: L2: 3 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19955 
Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:0126 class-ID: 0300
Device-2: Ricoh Laptop_Integrated_Webcam_FHD type: USB driver: uvcvideo bus-ID: 1-1.5:3 chip-ID: 05ca:181c
class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1")
Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 21.1.6 compat-v: 3.0 direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.13.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.33 running: no
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e v: kernel port: 4080 bus-ID: 00:19.0
chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Dell Inspiron M5010 / XPS 8300 driver: wl
v: kernel modules: bcma port: 4040 bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: wwp0s29u1u6i6 state: down mac: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4060 bus-ID: 00:1f.2
chip-ID: 8086.282a rev: 04 class-ID: 0104
Drives:    Local Storage: total: 223.57 GiB used: 51.95 GiB (23.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: B1D1 scheme: MBR
Partition: ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 51.95 GiB (23.2%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 51.95 GiB (23.2%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 51.95 GiB (23.2%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 51.95 GiB (23.2%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.68 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 56.0 C mobo: 27.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 2870
Info:      Processes: 202 Uptime: 2m wakeups: 2 Memory: 5.68 GiB used: 1.66 GiB (29.3%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1208 lib: 301 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.06

Fr what I see it's the Google Chrome and vscode that's problem


Baloo, the file indexer is also part of the high CPU usage :rofl:
Either you let it finish indexing or you turn it off in the system settings :eyes:


I recently switched to garuda, there was no problem like this in the windows.

i rarely open the file manager, all i do is code on VSCode and web surfing. if i turn off the file indexing, How it will impact my PC ? and how to turn off this thing "file indexer"

If you turn it off completely, you will no longer be able to search files in all the places that plasma allows this. Further, some applications that require it will have reduced functionality, such as elisa.

Instead of disabling it, I would consider doing one of two things:

  • Just be patient and let it finish. Once it finishes indexing it will only index new content.
  • Change the settings so that it only indexes filenames and not file content. This will make it index much faster.

it will be good of you can explain how to do that? i am new to this kind of stuff

Sure, for the first bullet point, it just involves waiting.

For the second, you can edit the file ~/.config/baloofilerc and add the line only basic indexing=true

More info on that file is here:


See this.


I would like to say that edit the file @dalto mentioned, reboot and let your system be for a couple of hours.

already done this. Even after that this problem occured

As old and slow as that PC is I am surprised it is performant at all with Garuda. The old sow's purse, silk ear thingee, I guess.


The young whippersnappers can't relate to all our old time sayings. I guess we need to update our lingo so they can grasp our meaning @c00ter.

Perhaps something more along these lines is more understandable for the pre 21st century challenged:

You can't expect the performance of a 32 core Threadripper from a single core celeron.

Any more updated versions to the old "silk purse from a sow's ear" saying.


ahh yes, but... but... but will garuda desktop load faster than this ????? -> North Star (ZX Spectrum) - YouTube

1 Like

Very well put, dear tbg :slight_smile:

You can optimise here and there, but you will always be restricted by the hardware (and the related firmware). :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.