Garuda Nvidia Wayland(Gnome) and Zoom

Hello Garuda users,

I'm using Garuda for a 7-8 months maybe and It works well. I recently got a 170 mhz monitor alongside my 60hz monitor. Since X11 does not support VRR I had to switch to Wayland. I did all of the requirements to run it and its working quite good. I'm a developer and Chrome, VSCode, Spotify, Slack, Postman all works fantastic.

But there is one problem: Zoom.

It just crashes. Here is my zoom_stoud_stderr.log file

ZoomLauncher started.
Zoom path is: /opt/zoom
cmd line: 
Start subprocess: /opt/zoom/zoom sucessfully,  process pid: 63773 
sh: line 1: pacmd: command not found
                             Class      App      Lib Possible Culprit Flags
                resip::Connection      648      648 
                      resip::Data       36       36 
                 resip::DnsResult     1080     1080 
                   resip::Headers        1        1 
          resip::MsgHeaderScanner       40       40 
                resip::SipMessage     5208     5208 
         resip::TransportSelector      864      864 
                     resip::Tuple      128      128 
              resip::UdpTransport     1144     1144 
          resip::GenericIPAddress       28       28 

zoom started.
sh: line 1: pacmd: command not found
sh: line 1: pacmd: command not found
                             Class      App      Lib Possible Culprit Flags
                resip::Connection      648      648 
                      resip::Data       36       36 
                           resip:: DnsResult       1080       1080   
                        Class             Appresip:: Headers          1          1  Lib
  Possible Culprit Flags 
                resip:: MsgHeaderScanner         40         40   
  resip:: Connection        648        648   
                resip:: SipMessage       5208       5208   
              resip:: Data  resip::      36TransportSelector        36     864  
     864   
                              resip:: DnsResult       1080       1080  resip::
Tuple        128        128   
                          resip:: Headersresip:: UdpTransport        1    1144         1    1144  

                    resip::resip::MsgHeaderScannerGenericIPAddress        40      28        40      28  

 
               resip::SipMessage     5208     5208 
         resip::TransportSelector      864      864 
                     resip::Tuple      128      128 
              resip::UdpTransport     1144     1144 
          resip::GenericIPAddress       28       28 

zoom started.
zoom started.
Client: Breakpad is using Single Client Mode! client fd = -1
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
sh: line 1: pacmd: command not found
                             Class      App      Lib Possible Culprit Flags
                resip::Connection      648      648 
                      resip::Data       36       36 
                 resip::DnsResult     1080     1080 
                   resip::Headers        1        1 
          resip::MsgHeaderScanner       40       40 
                resip::SipMessage     5208     5208 
         resip::TransportSelector      864      864 
                     resip::Tuple      128      128 
              resip::UdpTransport     1144     1144 
          resip::GenericIPAddress       28       28 

zoom started.
[CZPClientLogMgr::LogClientEnvironment] [MacAddr: 24:4B:FE:55:14:E6][client: Linux][OS:  Garuda Linux x64][Hardware: CPU Core:6 Frenquency:3.95 G Memory size:32097MB CPU Brand:AMD Ryzen 5 3600 6-Core Processor               GPU Brand:][Req ID: ]
Linux Client Version is 5.10.6 (2943)
QSG_RENDER_LOOP is 
XDG_CURRENT_DESKTOP = GNOME;   GDMSESSION = gnome;   XDG_SESSION_TYPE = wayland
Graphics Card Info:: 07:00.0 VGA compatible controller: NVIDIA Corporation TU116 [GeForce GTX 1660 SUPER] (rev a1)
Zoom package arch is 64bit, runing OS arch is x86_64
qt.scenegraph.general: threaded render loop
qt.scenegraph.general: Using sg animation driver
qt.scenegraph.general: Animation Driver: using vsync: 5.92 ms
AppIconMgr::systemDesktopName log Desktop Name: gnome 
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
Error: Send error, 22 Invalid argument
qt.scenegraph.general: Using sg animation driver
qt.scenegraph.general: Animation Driver: using vsync: 5.92 ms
QSGContext::initialize: depth buffer support missing, expect rendering errors
qt.scenegraph.general: texture atlas dimensions: 1024x512
qt.scenegraph.general: R/G/B/A Buffers:   8 8 8 8
qt.scenegraph.general: Depth Buffer:      0
qt.scenegraph.general: Stencil Buffer:    8
qt.scenegraph.general: Samples:           -1
qt.scenegraph.general: GL_VENDOR:         NVIDIA Corporation
qt.scenegraph.general: GL_RENDERER:       NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
qt.scenegraph.general: GL_VERSION:        4.6.0 NVIDIA 515.43.04
qt.scenegraph.general: GL_EXTENSIONS:    GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture GL_AMD_vertex_shader_layer GL_AMD_vertex_shader_viewport_index GL_ARB_ES2_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_fragment_shader_interlock GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gl_spirv GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_parallel_shader_compile GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_polygon_offset_clamp GL_ARB_post_depth_coverage GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_locations GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_ballot GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shader_viewport_layer_array GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_sparse_texture2 GL_ARB_sparse_texture_clamp GL_ARB_spirv_extensions GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_filter_anisotropic GL_ARB_texture_filter_minmax GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXTX_framebuffer_mixed_formats GL_EXT_Cg_shader GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_import_sync_object GL_EXT_memory_object GL_EXT_memory_object_fd GL_EXT_multi_draw_arrays GL_EXT_multiview_texture_multisample GL_EXT_multiview_timer_query GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_post_depth_coverage GL_EXT_provoking_vertex GL_EXT_raster_multisample GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_semaphore GL_EXT_semaphore_fd GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_image_load_formatted GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_sparse_texture2 GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_filter_minmax GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_sRGB_R8 GL_EXT_texture_sRGB_decode GL_EXT_texture_shadow_lod GL_EXT_texture_shared_exponent GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_EXT_window_rectangles GL_EXT_x11_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_KHR_context_flush_control GL_KHR_debug GL_KHR_no_error GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KHR_shader_subgroup GL_KTX_buffer_region GL_NVX_blend_equation_advanced_multi_draw_buffers GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_nvenc_interop GL_NVX_progress_fence GL_NV_ES1_1_compatibility GL_NV_ES3_1_compatibility GL_NV_alpha_to_coverage_dither_control GL_NV_bindless_multi_draw_indirect GL_NV_bindless_multi_draw_indirect_count GL_NV_bindless_texture GL_NV_blend_equation_advanced GL_NV_blend_equation_advanced_coherent GL_NV_blend_minmax_factor GL_NV_blend_square GL_NV_clip_space_w_scaling GL_NV_command_list GL_NV_compute_program5 GL_NV_compute_shader_derivatives GL_NV_conditional_render GL_NV_conservative_raster GL_NV_conservative_raster_dilate GL_NV_conservative_raster_pre_snap GL_NV_conservative_raster_pre_snap_triangles GL_NV_conservative_raster_underestimation GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_draw_texture GL_NV_draw_vulkan_image GL_NV_explicit_multisample GL_NV_feature_query GL_NV_fence GL_NV_fill_rectangle GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_coverage_to_color GL_NV_fragment_program GL_NV_fragment_program2 GL_NV_fragment_program_option GL_NV_fragment_shader_barycentric GL_NV_fragment_shader_interlock GL_NV_framebuffer_mixed_samples GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_geometry_shader_passthrough GL_NV_gpu_multicast GL_NV_gpu_program4 GL_NV_gpu_program4_1 GL_NV_gpu_program5 GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64 GL_NV_gpu_shader5 GL_NV_half_float GL_NV_internalformat_sample_query GL_NV_light_max_exponent GL_NV_memory_attachment GL_NV_memory_object_sparse GL_NV_mesh_shader GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_path_rendering_shared_edge GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_query_resource GL_NV_query_resource_tag GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_representative_fragment_test GL_NV_robustness_video_memory_purge GL_NV_sample_locations GL_NV_sample_mask_override_coverage GL_NV_scissor_exclusive GL_NV_shader_atomic_counters GL_NV_shader_atomic_float GL_NV_shader_atomic_float64 GL_NV_shader_atomic_fp16_vector GL_NV_shader_atomic_int64 GL_NV_shader_buffer_load GL_NV_shader_storage_buffer_object GL_NV_shader_subgroup_partitioned GL_NV_shader_texture_footprint GL_NV_shader_thread_group GL_NV_shader_thread_shuffle GL_NV_shading_rate_image GL_NV_stereo_view_rendering GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_rectangle_compressed GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_timeline_semaphore GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_uniform_buffer_unified_memory GL_NV_vdpau_interop GL_NV_vdpau_interop2 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NV_viewport_array2 GL_NV_viewport_swizzle GL_OVR_multiview GL_OVR_multiview2 GL_S3_s3tc GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
qt.scenegraph.general: Max Texture Size: 32768
qt.scenegraph.general: Debug context:    false
sh: line 1: pacmd: command not found

I know why this happens. I'm using pipewire for audio. This is not the real problem.

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

When I set the QT_QPA_PLATFORM=wayland Zoom window opens but it crashes immediately. Error log does not provide anything useful.

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

I don't know why libva fails but when I searched online I found out that this is due to Zoom's version. I tried to downgrade it to 5.9.6 and this error is gone but still not working.

I tried to use several arguments to zoom, line no-sandbox, no-gpu etc.

I know Zoom has screenshare issues with Gnome+Wayland but I can live with it. I just don't understand why I can't use zoom at all.

garuda-inxi output:


System:
  Kernel: 5.15.40-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=ee1fe203-6501-42bb-8c75-87608e596fe4 rw [email protected]
    nvidia-drm.modeset=1 quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
  Console: pty pts/0 wm: gnome-shell DM: GDM v: 42.0 Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF B450M-PRO GAMING v: Rev X.0x
    serial: <filter> UEFI: American Megatrends v: 2202 date: 07/14/2020
CPU:
  Info: model: AMD Ryzen 5 3600 socket: AM4 bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3950 min/max: 2200/4617 boost: enabled
    base/boost: 3950/4200 scaling: driver: acpi-cpufreq governor: performance
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 3950 2: 3950 3: 3950 4: 3950
    5: 3950 6: 3950 7: 3950 8: 3950 9: 3950 10: 3950 11: 3950 12: 3950
    bogomips: 94809
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: ASUSTeK
    driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: none off: DP-1,HDMI-A-1
    empty: DVI-D-1 bus-ID: 07:00.0 chip-ID: 10de:21c4 class-ID: 0300
  Device-2: Logitech C505 HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3:5 chip-ID: 046d:08e3
    class-ID: 0102 serial: <filter>
  Display: server: X.org v: 1.21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-size: <missing: xdpyinfo>
  Monitor-1: DP-1 mapped: XWAYLAND0 note: disabled pos: primary,top-right
    model: AOC AG273QG3R3B serial: <filter> built: 2021 res: 2560x1440 hz: 170
    dpi: 108 gamma: 1.2 size: 600x340mm (23.62x13.39") diag: 685mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 640x480
  Monitor-2: HDMI-A-1 mapped: XWAYLAND1 note: disabled pos: bottom-l
    model: Samsung C24F390 serial: <filter> built: 2020 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 520x290mm (20.47x11.42") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.43.04 direct render: Yes
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech C505 HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3:5 chip-ID: 046d:08e3
    class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.15.40-1-lts running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8168 v: 8.050.00-NAPI modules: r8169
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:2 chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 698.65 GiB used: 92.4 GiB (13.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 980 PRO 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QGXA7 temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 232.63 GiB size: 232.63 GiB (100.00%)
    used: 92.4 GiB (39.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 562 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 232.63 GiB size: 232.63 GiB (100.00%)
    used: 92.4 GiB (39.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 232.63 GiB size: 232.63 GiB (100.00%)
    used: 92.4 GiB (39.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 232.63 GiB size: 232.63 GiB (100.00%)
    used: 92.4 GiB (39.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.34 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C mobo: 37.0 C
  Fan Speeds (RPM): cpu: 1371 fan-2: 929 fan-3: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: 3.27
Info:
  Processes: 379 Uptime: 7m wakeups: 0 Memory: 31.35 GiB
  used: 4.85 GiB (15.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: 1228 pacman: 1224 lib: 334 flatpak: 4
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: tilix
  inxi: 3.3.15
Garuda (2.6.3-2):
  System install date:     2022-05-06
  Last full system update: 2022-05-17
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Timeshift (maybe)
  Failed units:

What happens if you set QT_QPA_PLATFORM=xcb?

3 Likes

Same with empty one, zoom opens but it's like blank but only has the frame around the window and titlebar. Screenshot below:

I believe there is one library is missing in my system and since logs are not helping I can't identify. A lot of people complains about screensharing is not working on wayland but that means they run zoom without a problem. I don't understand why can't I.

It could be this upstream bug (although this seems to be the flathub version). Status is closed, but probably to be reopened (issue was present after closure).

I was actually going to suggest trying the Flatpak to see if you have better luck.

4 Likes

GNOME+Wayland on NVIDIA is going to be painful, generally.

5 Likes

I already tried flathub version, exactly the same as normal one.

Do you have DE suggestion for running in wayland with Nvidia drivers?

No; use Xorg if you have an NVIDIA GPU.

4 Likes

What if I switch to open source drivers for NVIDIA? Will I still face same problems?

No, nouveau will work fine with Wayland, but you may find you have other issues instead.

3 Likes

Like what? Do you know any typical problems with that combination?

Performance issues, heat issues, power issues, games not running, ... I'm sure you can find this stuff out for yourself through the Arch wiki or a quick web search for e.g. "nouveau vs nvidia" .

2 Likes

Until you try it, nobody will know. Each system is a different HW/SW combination and is also depending on the programs you use.
I use nouveau on my desktop, with a Fermi (old nvidia 390 series) and it is OK.
I don't play computer games.
I didn't know that gaming is a default usage model... :rofl:

1 Like

I don't play games on linux actually. But the main reason that I switched over to Wayland is that using all the refresh rate of the monitor. If I'll have low performance, stuttering etc. there is no point for me to switch over to nouveau.

I was trying to ask this, actually.

I'll try in my free time, will report back.

Looks like you can't get more than 60hz with nouveau drivers. That's a shame.

I'll sell my Nvidia Card and get an AMD one.

I am running an arch linux based Distro. My laptop has a Nvidia GPU 1660Ti. I started working with wayland because the performance is better in the way the CPU Usage compared to XORG is much lower, the refresh rates on my Laptop 144Hz and my LG Monitor 240Hz run great.
Here are the steps I did to get wayland with Gnome (not my favorite, but for now it works) reliable running.

Below are the steps I did on my system followig that youtube video Wayland on Arch Linux (with Nvidia proprietary driver) [url]Wayland on Arch Linux (with Nvidia proprietary driver) - YouTube and they worked. AS DISCLAIMER , it worked on MY laptop, but might not work on yours or even make it under circumstances unbootable?

[url]NVIDIA - ArchWiki

"... 1.3 DRM kernel mode setting ..."
"... To enable DRM (Direct Rendering Manager) kernel mode setting, add the nvidia_drm.modeset=1 kernel parameter. ..."

  1. open terminal
  2. sudoedit /etc/default/grub
  3. adding at the end of the line GRUB_CMDLINE_LINUX_DEFAULT= ... nvidia_drm.modeset=1
  4. CRTL + X -> safe
  5. sudo grub-mkconfig -o /boot/grub/grub.cfg

"... 1.3.1 Early loading ..." based on that paragraph and the video I have also added the modules into the mkinitcpio
6. sudoedit /etc/mkinitcpio.conf
7. adding at the end of the line MODULES="... nvidia nvidia_modeset nvidia_uvm nvidia_drm"
8. CRTL + X -> safe

"... mkinitcpio ..."
because the entry was done manually it is addresses when updating the nvidia drivers it has be repeated OR using #pacman hook

  1. ls -la OR cat /etc/pacman.d/hooks/nvidia.hook <- check if nvidia.hook file exisits
  2. because I already had the entry as shown in the documentation I did close the file

Installation of GNOME DE using the Arco Linux Tweak Tool. I did try with Qtile, but do not have any knowledge regarding DEs based on Xmonad (Qtile is a fork of it). I could select it at the login (back to SDDM) but screen stayed black, had to hit CRTL + ALT + DEL to reboot.

3 Likes