Garuda live .iso

Hello ,
I am new to this forum.
I have booted a live Garuda xfce .iso to determine if it is suitable for me.
I found a few problems that may only be in the live session (I don't know).

  1. Cannot find package manager to install anything.
  2. Could not use terminal tom install either as it states that the package cannot be found. Packages tried were 'nemo' and others.
  3. In the file manager there is an entry 'Network' that shows 'Windows Network'. But clicking that produces nothing. On some other live distros, the computers on the network are shown and furthermore Windows shares in the computers are accessible.

Are these problems restricted to the live session?

As requested the result of garuda-inxi follows:

[[email protected] ~]$ garuda-inxi
  Kernel: 5.15.74-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_XFCE_TALON quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude E6410 v: 0001
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 07XJP9 v: A03 serial: <superuser required> BIOS: Dell
    v: A16 date: 12/05/2013
  ID-1: BAT0 charge: 21.1 Wh (100.0%) condition: 21.1/57.7 Wh (36.6%)
    volts: 12.2 min: 11.1 model: Sanyo DELL KY26695 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5 M 560 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
    model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1463 min/max: 1199/2667 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1463 2: 1463 3: 1463
    4: 1463 bogomips: 21277
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GT218M [NVS 3100M] vendor: Dell driver: nouveau v: kernel
    non-free: series: 340.xx status: legacy (EOL) last: release: 340.108
    kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm built: 2006-13 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,DP-2,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:0a6c class-ID: 0300
    temp: 57.0 C
  Device-2: Ricoh Laptop_Integrated_Webcam_3M type: USB driver: uvcvideo
    bus-ID: 1-1.4:3 chip-ID: 05ca:180f class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa
    dri: nouveau gpu: nouveau display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: eDP-1 model: Seiko Epson 0x5441 built: 2010 res: 1280x800
    hz: 60 dpi: 107 gamma: 1.2 size: 303x190mm (11.93x7.48")
    diag: 358mm (14.1") ratio: 16:10 modes: max: 1280x800 min: 800x600
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Dell
    Latitude E6410 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:3b56 class-ID: 0403
  Device-2: NVIDIA High Definition Audio vendor: Dell driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0be3 class-ID: 0403
  Sound API: ALSA v: k5.15.74-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Intel 82577LM Gigabit Network vendor: Dell Latitude E6410
    driver: e1000e v: kernel port: 8040 bus-ID: 00:19.0 chip-ID: 8086:10ea
    class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:422c
    class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Local Storage: total: 946.36 GiB used: 100.63 GiB (10.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10SPZX-00Z10T0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: General Flash Disk 3.0
    size: 14.84 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1.99 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.75 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 57.0 C mobo: N/A sodimm: SODIMM C gpu: nouveau
    temp: 58.0 C
  Fan Speeds (RPM): cpu: 2917
  Processes: 206 Uptime: 39m wakeups: 1 Memory: 7.75 GiB used: 1.39 GiB
  (17.9%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1239 libs: 332
  tools: paru Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.22
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.8-1):
  System install date:     2023-02-06
  Last full system update: 2023-02-06 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            snapper-cleanup.service 
[[email protected] ~]$

Welcome :slight_smile:

In terminal use

sudo pacman -Syu <app-name>




Restart, has no effect on live ISO

Did you click on WLAN icon in tray (left/right mouse button)?
Connect to your WLAN


In general, consider that:

  • our live ISO's do not have persistence,
  • so installation possibilities are limited, especially by the impossibility of doing what requires a reboot
  • some editions, including xfce, are meant to be "lightweight", so they include a fairly limited set of packages
  • I see (don't use it) xfce has Thunar and gvfs-smb in the iso profile, so you should be able to access Windows shares, according to the Arch wiki (of course if connectivity is OK)
  • as in all arch-based distributions, the use of GUI packages to install and upgrade the system is strongly discouraged (of course once installed you are absolutely free to add what you want)

I booted the live .iso again and tried the network and for some reason worked fine.
In trying to install nemo:
sudo pacman -Syu nemo
terminal tries to update the system also with large downloads (745). Normally that would be fine but not on a live system with limited resources. I had to stop it. But now I know that installing is fine.
Is there a method to access Google Drive on the installed Garuda Xfce?

How to Use Google Drive in Linux - It's FOSS › use-google-drive-linux

Rclone is actually more than just a Google Drive client. It is a command-line program to sync files and directories to and from various cloud storage services, ...

How to install google drive in arch linux - YouTube › watch

Video zu "Google Drive linux arch"

24.05.2017 · In this video i will show you how to install google drive in arch linux and configure itMathew ...


Thank you for those links, but they appear to want to install apps that will require a copy of the google drive contents on the machine.
I just want access to google drive by having a snapshot viewable in the file manager like Gnome has via the their online accounts. This allows drag-drop into or out of google drive. This is what I need but with xcfe not gnome desktop.

You know best what you want, so you should feed the search engine you trust with this data.


This is a solution I used in the past: google-drive-ocamlfuse | FUSE filesystem over Google Drive it's available on the AUR: AUR (en) - google-drive-ocamlfuse

1 Like