Garuda Linux stuck at First boot

Hello Garuda users.

I Just installed the latest Garuda KDE Dragonized gaming edition on my laptop (HP Omen 16, Ryzen 9 5900HX and RTX 3070). Booted from live usb with Nvidia driver and installed Garuda. I tried many times but, whatever i do, at the First boot After 3-4 seconds on the desktop, the mouse freeze and the PC reboot and return to Grub.
I tried:

  • Repair Grub from live usb
  • Reinstall Grub from live usb
  • Reinstall Garuda from live usb
  • Update everything on live usb and then Reinstall Garuda
  • chroot from live usb and update the Grub

But nothing works. Some suggestions? I am a noob and this Is my First Linux experience, if you Need logs I can send them, help me solve this please!

Can you check if this issue persists if you use the “normal” dr460nized version of garuda? You can install everything that gaming version has by using the preinstalled garuda gamer software.

Also, please follow the template whenever posting a help request please give us the output of


from terminal in text format. You can do it from live ISO as well.


Doesn’t seem to be a problem with GRUB since you can boot and it freezes afterwards.

I’d try to boot from USB, arch-chroot into the installation and then use journalctl to read out what exactly it is that crashes the PC.

Also while u’re at it update the PC via garuda-update in chroot.


Thank you, I’m trying normal non gaming version and gnome version right now. I’ll let you know!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.