Garuda Linux | Release 200831

This is an iso refresh released today

Changelogs :

Changes shipped in 200831 release from previous iso

  • Garuda Welcome app:
    • Added a toggle for easy switching to HiDPI Mode
    • Added a toggle to switch GDM to Wayland & fixed ~/.profile not getting applied using Wayland
    • Added a toggle to enable systemwide adblocking via Adguard DNS
    • Added a toggle for enabling / disabling the guest account
  • Garuda Network Assistant app:
    • Added wifi restart button
    • Added bluetooth restart button
    • Detect if Networkmanager or Connman is running if they are installed and not running show a dialog then give a button to start the service
  • Garuda-zsh-config
    • Switched to Powerlevel10k theme (including the patched font)
  • Garuda ISO profiles
    • Add pamac-all in Ultimate editions (Snap/Flatpak support)
  • KDE
    • Changed theming to Whitesur-dark
    • replaced vvave-git with Olivia in kde-lite edition
    • removed kde-games-meta and kaudiocreator from ultimate edition
  • GNOME
    • Changed theming to Whitesur-dark
    • Add a simple layout switcher (Garuda, GNOME, Windows & PopOS tiling)
  • XFCE
    • Changed theming to Whitesur-dark
  • Wayfire
    • Changed panel layout and replced wf-panel’s menu with nwggrid
  • Chaotic Repo
    • Added changes to pacman.conf to use chaotic-mirrorlist package
  • Grub
    • Added Shutdown,Restart,Firmware-Setup (UEFI) menu entries
    • Changed highlight text color in grub-theme-garuda to blue color

It also includes some app updates including some major version upgrades for:

  • Linux-zen 5.8.5
  • mesa 20.1.6
  • Nvidia 450.66
  • Firefox 80
  • Libreoffice 7.0 (Ultimate version only)

Download:

https://garudalinux.in/downloads.html

for now only direct and torrent links are available
sourceforge and osdn are in process of uploading

12 Likes

Enjoy it guys :blush:

5 Likes

LibreOffice Package does not work. Silently dies on GUI, “Application Error” on CLI. Tested on KDE Ultimate, Wayfire, Gnome and XFCE. All clean installs. OpenGL detection seems hit or miss on the KDE release. GNome Version defaults to using GDM-Prime, which does not load in an intel 530 desktop. Have to CTRL-F2, login and yay gdm, replace with regular gdm. Still experiencing network and boot delays due to nsswitch.conf systemd in the config. This was the case on every single one of them.

1 Like

We should make the nsswitch.conf fix default I guess. Will look into the GNOME stuff tomorrow :+1:

2 Likes

LibreOffice works after starting it in safe mode (libreoffice --safe-mode) and disabling hardware acceleration. Also, not sure how you all feel about this, but it seems unnecessary to load intel_agp radeon nouveau and i915, when the xserver will load the modesetting driver anyway (mkinitcpio.conf).

1 Like

What happens?

2 Likes

That is due to we use optimus-manager by default for intel+nvidia hybrid

As for nsswitch.conf

I think we need another release may be tomorrow :sweat_smile:

3 Likes

After the first update cycle, opengl detection fails and all transparencies are gone. Going back and flapping the compositor selection to Xrender and then back to the default brings it back, but after a couple of reboots the opengl detection crashes again. Error displayed on the display settings tab in kde.

1 Like

Does live boot has opengl problem?

2 Likes

Live session works fine.

1 Like

No they are needed to show Plymouth splash screen

2 Likes

Have you tried removing

~/.config/libreoffice

Then launch libreoffice tell me if it works

2 Likes

Sorry about the modules comment. I am on nvme and usually disable plymouth. Without it, Garuda boots to the login screen in less than 5 secs, and that includes about 2 seconds of EFI vendor logo. I also disabled the grub timeout, of course. Only thing that worked for LibreOffice was to disable hardware acceleration from libreoffice --safe-mode.

1 Like

Can you try this

sudo pacman -Rnsc garuda-vaapi

Then remove

rm -rf ~/.config/libreoffice

Then reboot and launch libreoffice

Just to confirm if its libreoffice at fault or we.

1 Like

You dont have to

If you dont tell the problem you face while using garuda we wont know if the problem exists and cant fix them

1 Like

Sadly, that does not fix the issue. Removed the Vaapi driver and the libreoffice config dir. restored default config. Silent death again.

1 Like

Ohh then its libreoffice at fault

Possibly. but if I disable hardware acceleration it works fine.

1 Like

2020-08-31_20-52

Fine here.

inxi -Fxxxza --no-host
1 Like

So probably related to his particular cpu/gpu

1 Like