Garuda Linux installation on iMac 21 2009, problems

Hi guys, I'm trying to install Garuda Linux on an "old" 2009 iMac 21.
Having confirmed that the specifications are sufficient for the installation, I go to start the live USB but unfortunately I am not allowed to format the Mac's SSD, so I can't install Garuda.
KDE partition manager tells me that some tools are needed and sends me to a link with files of a type I have never seen.
I'll post some screenshots later to show you, but in the meantime, does anyone already have an idea of ​​what the problem could be? Has anyone encountered this? Do you have a possible solution?

Thank you in advance

Why are you using KDE partition manager?

Did you try letting the installer format the drive? If there is an error message from the installer, what does it exactly say?

3 Likes

Thank you for your help.
I am using Kde partition manager because i have only this.
This is the problem i foundhttps://ibb.co/3M48Q71

On top of that. This is what happens when i tried to install

I also tried using gparted, but even then it gave me an error.
Could the problem come from the fact that the SSD contained a Mac OS system?

This is the link of the error:

Please, stop posting like in a chat room.
You can edit your post until someone replies.

1 Like

Hi there, welcome to the forum.
Check if this helps (I have no experience at all with iMac’s, macOS and the like):
https://wiki.archlinux.org/title/Mac#Installing_a_boot_loader_to_a_separate_HFS+_partition
It looks like it is suggested using the macOS Disk Utility.
There is also an AUR package ( mkfs.hfsplus tool in the hfsprogs package), but it won’t be availabe in a live USB.

Anyway, from the screenshots I see that the error arises in the last step of Calamares, when the files have already been installed and the system just needs to create the ESP partition and install GRUB (I don’t know if there is anything else actually, I am not a developer).
Maybe you could use the live USB, and from the Garuda Welcome use the “Chroot” button, to see if you can get into a terminal on the installed system. Then you could try to install that package and format the ESP partition and then install GRUB.
I’ll add a couple of other links I found, but I don’t know to what extent they are useful (maybe in case of subsequent problems with efibootmgr, called as part of the grub installation):

1 Like

Forgive me, being new to the Linux world in general it is difficult for me to find a starting point.
How should I move? or rather where I start

Edit. to be specific I'm not really a newbie. I've had to deal with Mint, Ubuntu and especially Debian
However, one thing that perhaps wasn't clear in the messages is that I'm very limited as any attempt to format or create a partition seems to be rejected.
I'm also trying to understand by reading the links you gave me which tools I should actually use, given that some, as you said, are not available live
Furthermore. What is chroot?

I know it's not going to be easy... :frowning:
First of all, try to see if the system has been installed.
From the live USB, open Garuda Welcome and hit the "chroot" button, to see if the system has been installed (if really only the ESP partition and GRUB are missing).
"chroot" is a linux command that changes the root, in this case from the live USB where you booted to the root partition of the system (hopefully) installed on /dev/sda2.
From that moment onward, if you get a root terminal (starting with #) without errors, everything you do (e.g. installations) is done on the sda2.
If chroot works, you can install that package with:

paru hfsprogs

You will be presented with some text concerning the PKGBUILD, press button 'q' to wuit it and confirm installation. And :crossed_fingers:

2 Likes

Try that, Partitioning

The newer the Apple hardware is, the more complicated or impossible it is to install anything other than macOS, as long as updates are provided for the device.
After all, they want to make money and if the hardware lasts so long, you screw with the software.

Just use forum search :slight_smile:

2 Likes

Maybe is this?

Screenshot-20230908-125050 hosted at ImgBB — ImgBB {I had to put a space in the url or it wouldn't let me put it}

Please, post garuda-inxi from live ISO as text.
You can copy the text and post here between three ~~~ in first and last line.

2 Likes
lsblk -f
NAME FSTYPE FSVER LABEL                UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                                   0   100% /run/miso/sfs/livefs
loop1
squash 4.0                                                                   0   100% /run/miso/sfs/mhwdfs
loop2
squash 4.0                                                                   0   100% /run/miso/sfs/desktopfs
loop3
squash 4.0                                                                   0   100% /run/miso/sfs/rootfs
sda
├─sda1
│    vfat   FAT32 EFI                  67E3-17ED
├─sda2
│    hfsplu       MacOs                658da1e5-576e-3827-b74e-4c41cc3faa44
└─sda3
hfsplu       Recovery HD          300b38d2-6474-3d84-88d6-438875687ac7
sdb  iso966 Jolie GARUDA_DR460NIZED_RAPTOR
2023-05-01-21-27-23-00
├─sdb1
│    iso966 Jolie GARUDA_DR460NIZED_RAPTOR
│                                      2023-05-01-21-27-23-00                     0   100% /run/miso/bootmnt
└─sdb2
vfat   FAT12 MISO_EFI             CC34-06DF
sdc
sr0
zram0
[SWAP]

~~~
terminal text
~~~

From that picture it looks like the /dev/sda1 ESP partition was created, so it might not be needed to install that AUR package.
From inside the chroot, try:

mount /dev/sda1 /boot/efi

Then try:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck

In case of errors, we could try, like in a post linked above:

grub-install --no-nvram --removable

If one of the two work:

update-grub
1 Like
╭─garuda@garuda in ~ as 🧙 took 41ms
╰─λ # mount /dev/sda1 /boot/efi

╭─garuda@garuda in ~ as 🧙 took 41ms
╰─λ grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
grub-install: error: failed to make directory: '/boot/grub'.

╭─garuda@garuda in ~ as 🧙 took 5ms
[🔴] × grub-install --no-nvram --removable
Installing for x86_64-efi platform.
grub-install: error: failed to make directory: '/boot/grub'.

╭─garuda@garuda in ~ as 🧙 took 10ms
[🔴] × update-grub
grub-mkconfig: You must run this as root

╭─garuda@garuda in ~ as 🧙 took 47ms
[🔴] × # update-grub

╭─garuda@garuda in ~ as 🧙 took 47ms
[🔴] ×


PS. I have reason to think that the partition we are interested in is /dev/sda2

The step we were trying to perform (install GRUB) was to be done on the esp, which is /dev/sda1, but now (sorry) I see that /dev/sda2 is still hfsplus instead of btrfs, so the installation was not successful...
Sorry, I'm at wit's end :frowning:

1 Like

If you don't mind, I'd be curious to see what plain old parted has to say about it.

Run parted on the SSD.

sudo parted /dev/sda

This will open the interactive parted prompt on your device. From inside parted, run print.

print

This should give some information about the current layout of the disk. Paste the output from the terminal into the thread as text (no more screenshots please). You can use the preformatted text button (looks like this: </>) to format the text as a code block.

Next, create a new partition table.

mklabel gpt

Run print again after making the partition table and paste it into the thread.

1 Like
╭─garuda@garuda in ~ as 🧙 took 47ms
[🔴] × sudo parted /dev/sda
GNU Parted 3.6
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Model: ATA Intenso SSD Sata (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size   File system  Name                  Flags
1      20.5kB  210MB  210MB  fat32        EFI System Partition  boot, esp
2      210MB   255GB  255GB  hfs+
3      255GB   256GB  650MB  hfs+

(parted) mklabel gpt
Warning: The existing disk label on /dev/sda will be destroyed and all data on this disk will be lost. Do you want to continue?
Yes/No? y
(parted) print
Model: ATA Intenso SSD Sata (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start  End  Size  File system  Name  Flags

(parted)

Looks good so far. Let's try running the installer again. You can run quit to get out of parted.

2 Likes