Garuda linux installation failed, bootloader not installed error code 1

no they don’t

the strings do not match

If they really don’t match, download again the iso file and repeat the check.

i did

I just downloaded the .sha256 file myself for the dr460nized version of garuda and,

and this,


from the file’s

b3400172f03a9ec18b6f86fb8bb6db9c2ec7bd407c35670f873a59a5ca0eee98  garuda-dr460nized-linux-zen-231029.iso

look same to me.

1 Like

This matches the sum!

1 Like

…i feel embarrassed i checked it with chat gpt

so i still dont understand why its not installing the boot loader?

You changed the BIOS to boot in UEFI mode, saved the changes and you still get --target=i386-pc?
If so, which tool are you using to create the bootable USB?
Try with Ventoy.

1 Like

fat 32 system works fine right?

For what? To format the USB it is ok. The EFI system partition, which is giving troubles is also formatted fat32.

If you still use Windows, you could also use something like rufus - GUI based ISO USB writer.

The program is also able to detect grub and gives you the choice to update the grub bootloader before copying the files to USB.

Fixed it for me on an newer PC with an X570 chipset.

A brand new computer’s BIOS probably needs to be setup for Linux before anything else, don’t ya’ll think?


So after mendling with the bios I figured out that it boots the usb on bios mode I tried everything but I can’t make it go on uefi mode so if I erase the disk will I get the same error during the installation process?

I’m afraid that booting in BIOS mode, even if you erase the disk, you’ll get the same error in the final step.
I think the key point is that you manage to boot the live USB in UEFI mode.
Have you tried with Ventoy?


Man the main problem is my mobo isn’t letting the usb or any storage device boot in uefi let alone legacy everything even I tried arch iso is booting in bios

That’s very wierd.
My only idea is that there seem to be more recent versions of your BIOS



Isn’t there a special button (physical) on your PC which is designed specifically for boot options?

1 Like

OMG you are correct my bios version is old :skull:

Thank you all for the support I really appreciate it my problem has been fixed after updating the bios and using ventoy

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.