Garuda linux changes after booting

Hello guys, I'm having some problems with garuda linux. First my headphone didn't work. Then I restarted the computer to check if it's working then. But after restarting, everything has changed. I mean there's no icons, only three. Here is a screenshot of my desktop after opening. Also the window buttons(close, minimize, ...) has moved to right from the left.

PS: Sometimes the system changes after booting up. Before my terminal has changed. Is that a bug or something?

Edit 1;
Here is my inxi -Faz

╰─λ inxi -Faz
System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=31462efd-23b4-43d9-9128-7cb5083a1f03 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=37a06802-8265-4d92-901e-28812d45594f loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop System: SAMSUNG product: Samsung DeskTop System v: CAAAAAAF serial: <filter>
Chassis: SAMSUNG ELECTRONICS CO., LTD type: 3 serial: <filter>
Mobo: SAMSUNG model: Samsung DeskTop System serial: <filter> BIOS: SAMSUNG v: 00PE date: 11/12/2009
CPU:       Info: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP arch: Core Merom family: 6 model-id: F (15)
stepping: B (11) microcode: BA cache: L2: 4 MiB
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19154
Speed: 2394 MHz min/max: 1600/2400 MHz Core speeds (MHz): 1: 2394 2: 2394 3: 2394 4: 2394
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 4 Series Integrated Graphics vendor: Samsung Co driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:2e32 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0") s-diag: 338mm (13.3")
Monitor-1: VGA1 res: 1024x768 dpi: 63 size: 410x230mm (16.1x9.1") diag: 470mm (18.5")
OpenGL: renderer: Mesa DRI Intel G41 (ELK) v: 2.1 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Samsung Co driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:27d8 class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co driver: r8169 v: kernel
port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus-ID: 1-8:5 chip-ID: 148f:7601
class-ID: 0000 serial: <filter>
IF: wlp0s29f7u8 state: down mac: <filter>
Drives:    Local Storage: total: 409.88 GiB used: 73.94 GiB (18.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3320820AS size: 298.09 GiB block-size: physical: 512 B
logical: 512 B speed: <unknown> type: N/A serial: <filter> rev: D scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 model: AITC KSM 120GB size: 111.79 GiB block-size: physical: 512 B logical: 512 B
speed: <unknown> type: SSD serial: <filter> rev: 2A0 scheme: MBR
Partition: ID-1: / raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 73.94 GiB (71.5%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-2: /home raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 73.94 GiB (71.5%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-3: /var/log raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 73.94 GiB (71.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 103.43 GiB size: 103.43 GiB (100.00%) used: 73.94 GiB (71.5%) fs: btrfs
dev: /dev/sdb1 maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.36 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2 maj-min: 8:18
ID-2: swap-2 type: zram size: 3.8 GiB used: 52.8 MiB (1.4%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 67.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 228 Uptime: 12m wakeups: 0 Memory: 3.8 GiB used: 2.38 GiB (62.7%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1382 pacman: 1362 lib: 338 flatpak: 5 snap: 15
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

I think you should reset the default settings in the Garuda assistant flagging latte and log off and on.
The changes after rebooting could be due to previous updates without rebooting.
Anyway, looking at your kernel version I think you should update again and reboot, then reset the config.
If you have lost the panel and application launcher, open the Garuda assistant from Krunner (normally shortcuts could be alt+space or alt+F2).


I updated the system and changed into the default settings of latte in Garuda assistant, and restarted. It's working fine now. But icons seems small. By the way thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.