Garuda Linux Bateleur Eagle (210809) discussions

Might be a really stupid question, but I assume all these changes will be installed when running the update command? Will it ask anything about swapping swapd zram for the new zram generator? Like a conflict or anything? Also good work! Very exciting update

3 Likes

Can we get some mate screenshots?

3 Likes

It already gained success in dragging new users & hop from other Distro. :star_struck:

Now irs on next step to be more flexible with Arch & Ubuntu flavour . :relieved:

Do yourself & get your personalized experience & tailored performance :boom:

Donation & Time are only thing dragging Garuda ,moving into major discussion Distro ( Yup , there are many more , yet Best among all other alternatives ) :heart_eyes:

2 Likes

You are going to have conflicts.

Yes, everything but changes to user configs will be applied. Depending on when your last update happened you will have to do some inputs (eg Y to remove a package) but thats nothing out of the ordinary, so to say :eyes:

2 Likes

Does this mean that we don't need to have a swap partition anymore?

Nothing changed here but the application used to generate the ZRAM device.

3 Likes

Just curious, I've updated like daily basically and over the last week or two I haven't been promoted about conflicts or anything to replace. So is there a way I can check for example, if the zram generator is being used on my system now?

You might have installed an iso which already had this particular change in :eyes:
I think you can do systemctl status zram-generator to check but there is no way its not installed if your system is up to date as garuda-common-settings depends on it :smiley:

2 Likes

Ah good point, did have to reinstall recently on my new SSD within the last couple of weeks. Had forgotten about that. Think I had the 29th of July ISO if I remember correctly.

1 Like

Hi there

I installed Garuda dragonized from the new Bateleur iso and checked for systemctl status zram-generator.

~ took 1m50s
 ╰─λ systemctl status zram-generator
Unit zram-generator.service could not be found

It's a fresh install without any changes. Is something wrong?

1 Like
╰─λ yay -Qlq zram-generator | grep ".service"
/usr/lib/systemd/system/[email protected]
╰─λ systemctl status [email protected]
Failed to get properties: Unit name [email protected] is neither a valid invocation ID nor unit name.
╰─λ free -h
gesamt       benutzt     frei      gemns.  Puffer/Cache verfügbar
Speicher:       15Gi       2,1Gi       7,8Gi       1,7Gi       5,6Gi        11Gi
Swap:           15Gi          0B        15Gi

Don't know if there is a problem or not.

2 Likes

Sorry guys, my bad. :sweat_smile: The zram-generator itself just creates the zram device at early boot.

λ systemctl | rg zram
sys-devices-virtual-block-zram0.device                                                        loaded active     plugged      /sys/devices/virtual/block/zram0
[email protected]                                                              loaded active     exited       Create swap on /dev/zram0
system-systemd\x2dzram\x2dsetup.slice                                                         loaded active     active       Slice /system/systemd-zram-setup
system-udisks2\x2dzram\x2dsetup.slice                                                         loaded active     active       Slice /system/udisks2-zram-setup
dev-zram0.swap                                                                                loaded active     active       Compressed Swap on /dev/zram0

So no, there is no issue if the zram device & swap is properly created (which it seems to be)

4 Likes

Isn't bateleur for the mate edition? how did you install KDE from the iso for MATE, i'm stoked.

"Bateleur (Eagle)" is the new codename for the current major iso release, comparable to "Serpent Eagle"

3 Likes

So for about a week it seems, I've had two entries for Garuda Linux. The normal one, and one found at /dev/sda2 (I think). But I just updated today and rebooted and it disappeared finally! What was in today's update that might fix this grub issue? Anyone know?

Please post

sudo mhwd-kernel -li
1 Like
sudo mhwd-kernel -li
[sudo] password for adamj:
Currently running: 5.13.9-2-cacule (linux-cacule)
The following kernels are installed in your system:
local/linux-cacule 5.13.9-2
local/linux 5.13.9.arch1-1
Me and english :-D

Which one is in the first advanced section?

Maybe a

sudo update-grub

help.
In the second one is also Memory check?

If it is solved, why do you post it here?

Oh sorry may have been a misunderstanding. I was just saying it's not a problem anymore since updating today. Used to show two entries but now it is normal. Doing things like updating grub hadn't worked so was just curious why it worked today. Like maybe a package update fixed it. And I posted it here because didn't see the point in making a new thread about it as isn't an issue and may be related to a recent update as of this new build as this is a discussion thread for it.

1 Like