Garuda KDE / Garuda Gnome dual boot

I have been tracking the development for KDE and Gnome team for years. About 1 year ago I picked Garuda Linux to install KDE and Gnome versions separately to follow both DE as they develop. Best way to see KDE/Gnome bugs accurately is to run it on the same distro. I was able to install and run the two Garuda distros independently from each other without any issues or crash by running completely separate partitions: 1. Garuda KDE boot partition / 2. Garuda KDE partition, then 3. Garuda Gnome Boot partition / 4. Garuda Gnome partition. ( plus two other distros in the grub menu) . This worked flawlessly for a whole year until a few days ago. Some update overwritten grub/boot rules. Updated Garuda Gnome and the update removed the Garuda KDE from the grub menu also from BIOS menu. Using Garuda KDE install iso I managed to start and repair Garuda KDE but after updating it killed the Garuda Gnome boot… Now I can go back and forth repairing the boot between the two but one or the other gets killed. Before someone suggest why don’t I install both KDE and Gnome DE on the same Garuda install I think the answer is pretty evident. Having GTK+QT running on the same system always creates endless errors and conflicts in the long run. I’m not sure what rules policies changed in the recent Garuda update that overwrites existing Garuda Boot/grub even if they are completely separated to different partitions. Is there anything I can do to keep them both working and both KDE and Gnome showing up in the grub menu as it use to work? What updates were pushed through this week that killed this well working option?

I think you need something like this.

One of the two GRUB should be treated like this (rename, change distributor etc.), the other just reinstalled from a chroot.

3 Likes

Thanks filo for the suggestion. Looking at the link you pasted, it didn’t fix user shadowreaper problem. I read chroot saved his KDE but the suggested commands he followed racked his hyprland install. I’m was also able to fix one boot at a time. What puzzles me is that both my KDE and Gnome boot/efi is on a completely seperate partation to avoid overwriting each other yet that seems to be the case since last week updates. Garuda Gnome have no business to overwrite Garuda KDE when the two boot/efi placed on different partitions.

Do you have two EFI partitions?

garuda-inxi
lsblk -f
sudo parted -l

Let’s also see the output from when you repair one of the Grubs.

It is possible they made an error somewhere. I have followed that exact process what feels like 100 times and can confirm it works. See also this guide here, where this process also appears: Multiple installations on one partition | Garuda Linux wiki

If you are using two separate EFI partitions though, your issue may be something else.

2 Likes

Which GRUB are you using? KDE’s? Gnome’s?
When booting into whichever GRUB you’re using (whether you’re using KDE’s or Gnome’s GRUB, boot into that one), have you tried running
sudo os-prober
and
sudo update-grub
in the terminal? I run minimum of 3 different Garuda distros dual booting at a time, and that’s the first thing I always do. Always grabs the other EFI partition and adds it to my GRUB screen.

It does not find all DE’s / OS’s.

sudo os-prober
/dev/nvme0n1p6:Garuda Linux:Garuda:linux:btrfs:UUID=164f2dfe-ce11-4d5f-aa4c-ce24aa6cdd6a:subvol=@
/dev/nvme0n1p8:Garuda Linux:Garuda1:linux:btrfs:UUID=b147dd48-f302-484d-80b0-661e7ff40a76:subvol=@

╭─sgs@y7p in ~ as 🧙 took 6s
🕙 03:42:03
╰─λ lsblk -f | grep 'nvme'
nvme0n1
├─nvme0n1p1 vfat   FAT32 SYSTEM_DRV  94BA-ECE1                             224,1M    12% /boot/efi
├─nvme0n1p2
├─nvme0n1p3 ntfs         Windows-SSD A2A8BB95A8BB6707
├─nvme0n1p4 ntfs         WINRE_DRV   B8F6BC25F6BBE234
├─nvme0n1p5 btrfs        KDE         fc62cc44-07ab-497b-ac89-15704c290993     57G    84% /var/log
├─nvme0n1p6 btrfs        Sway        164f2dfe-ce11-4d5f-aa4c-ce24aa6cdd6a
├─nvme0n1p7 btrfs        i3wm        21e02e96-0ed6-4629-9a39-85ffee7a4359
└─nvme0n1p8 btrfs        Hyprland    b147dd48-f302-484d-80b0-661e7ff40a76

Missing KDE (activ) and i3wm and M$.

Ok, that with i3wm was my installation error, but I can boot it with custom.cfg.
So I think os-prober is pointless. At least in my case.

You surely mean desktop environments, not distributions.

Oh weird, it’s worked literally every single time I’ve done it. Has picked up all my Garuda’s and whatever other distros I’m running, including Windows (and Windows is on an entirely different drive than all my distros).

No I mean three separate Garuda ISO’s installed as three separate partitions (“distros”) (so three separate entries in my GRUB). Bad wording on my part. One distro, three separate instances (I use each for different things is why I separate).

Was just mentioning os-prober and update-grub to OP as that’s what has worked for me 100% of the time. But it might not I suppose. Was worth the mention I think; if it does work, fantastic. If not, on to the next solution! :smiley:

I mean Garuda Linux or EnOS are distributions with some desktop enviroments like KDE, GNOME, i3wm … :slight_smile:

Again :slight_smile:

I only said separate since each as it’s own EFI partition. :slight_smile: But you’re right, same distro, just different DE’s (and different /home partitions, etc)!

I have no idea why that wouldn’t be working for you… I’m telling you, it’s worked for me 100% of the time I’ve run it. Lol Currently running Garuda’s (three separate partitions, KDE, Sway, Hyprland), Pop!_OS (just keeping track of COSMIC devel), ArcoLinux BSPWM, and Athena OS on one drive, and Windows on it’s own drive. After each install and moving Garuda GRUB back to first boot order, I go in and run the commands I gave, and it’s added the newly installed distro and detects Windows every single time. I’ve even switched GRUBs (tried Arco’s and Athena’s) and it worked on those too. Not sure why it’s not working for you. Two NVMe drives are in use, different brands, os-prober and update-grub have been flawless for me. :man_shrugging:

1 Like

But

sudo update-grub

is enough. No need to run os-prober in front.

Yeah I noticed that recently, but still do both just out of habit. Lol more so muscle memory than needed. I think I failed the DRY method on that one. :joy:

Thanks guys for the tips. In the end I ended up reinstalling each partition 1. BOOT KDE / KDE and BOOT Gnome /Gnome. I set it up exactly the same way as it was before the updates. Now it works again BIOS Grub only see one Garuda install ( same ID) but the grub menu loads up both Garuda load options.

You still are going to want to disable os-prober on anything but your main linux install as it gets run after most kernel updates as the system updates grub. the other thing to do is go into which ever one you log in more. go to

/etc/default/grub

An change the name. I set mine to

GRUB_DISTRIBUTOR=“Garuda KDE”

but it can be what ever you want. then update grub one last time. an you shouldn’t have the issue of one vanishing as long as you don’t change grub with some other distro. I normally run at least 2 garuda spins so i’m kinda used to getting a version back its never fun though

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.