Garuda KDE Freezes and Laggy

Hello, I am new to KDE and Garuda (Garuda Blackarch). I am having some freeze issues(Randomly, like everything goes smooth but when I dragging the applications suddenly freezes and comes back etc etc.)

I heard about sometimes its happens because of swap, so I tried to reduce vm.swappiness(which is set to 133 by default.) But I didn't used zram before so I failed.

I was using GNOME before without any issues, you can find my system info below.

I don't know what to do please help me, thanks.

System Specs (Garuda Assistant)

System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=82035f25-a138-4480-8585-1cb740611763 rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
           Mobo: ASUSTeK model: H81M-PLUS v: Rev X.0x serial: <filter> UEFI: American Megatrends 
           v: 2205 date: 05/26/2015 
CPU:       Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell family: 6 
           model-id: 3C (60) stepping: 3 microcode: 28 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 25598 
           Speed: 3200 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 3200 2: 3212 3: 3269 
           4: 3201 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 470.63.01 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia 
           display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1443 s-dpi: 101 s-size: 967x363mm (38.1x14.3") 
           s-diag: 1033mm (40.7") 
           Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") 
           diag: 547mm (21.5") 
           Monitor-2: DP-2 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6") 
           diag: 546mm (21.5") 
           OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 
           direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403 
           Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel 
           v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403 
           Device-3: JMTek LLC. USB PnP Audio Device(EEPROM) type: USB 
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-8:5 chip-ID: 0c76:161f 
           class-ID: 0300 
           Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK H81M-C 
           driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 703.79 GiB used: 29.39 GiB (4.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: GOODRAM model: SSDPR-CL100-240-G3 size: 223.57 GiB 
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> 
           rev: 1A0 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS725050A7E630 
           size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD 
           rpm: 7200 serial: <filter> rev: A3C0 scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Toshiba model: TransMemory 
           size: 14.45 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> 
           rev: 1.00 scheme: GPT 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw-size: 70 GiB size: 70 GiB (100.00%) used: 29.37 GiB (41.9%) fs: btrfs 
           dev: /dev/sda5 maj-min: 8:5 
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.8 MiB (26.9%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 70 GiB size: 70 GiB (100.00%) used: 29.37 GiB (41.9%) fs: btrfs 
           dev: /dev/sda5 maj-min: 8:5 
           ID-4: /var/log raw-size: 70 GiB size: 70 GiB (100.00%) used: 29.37 GiB (41.9%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
           ID-5: /var/tmp raw-size: 70 GiB size: 70 GiB (100.00%) used: 29.37 GiB (41.9%) 
           fs: btrfs dev: /dev/sda5 maj-min: 8:5 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 7.7 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 62 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 14% 
Info:      Processes: 214 Uptime: 5m wakeups: 0 Memory: 7.7 GiB used: 2.22 GiB (28.8%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1765 
           lib: 325 Client: Unknown Client: garuda-assistant inxi: 3.3.06

Balance the btrfs filesystem from Garuda assistant.

Then reboot

3 Likes

Okay starting right now.

Sadly nothing changed as I can see. Still freezes and laggy.

Install ananicy-cpp from assistant and enable it.

Then reboot see if it makes a difference

2 Likes

Installed and rebooted, no difference at all.
Is there anything I should do after installing and rebooting "ananicy-cpp" like any settings?

Well another thing to try is change kernel and see which one works

2 Likes

Current kernel is linux-zen (5.13.12-zen1-1-zen) any suggestion don't know which one to install or should I just go for linux-lts?

Linux-lts is usually a good choice for troubleshooting.

1 Like

Installed linux-lts via "Garuda Settings Manager" > "Kernel", tried to boot via GRUB its won't boot at all stuck on "Loading kernel linux-lts"

I'm not an expert of GPU stuff, but maybe freezes and lags could be due to the relevant driver.
How did you install it?
As far as I know, the best thing is to use the Garuda assistant.
Maybe you can check also how it goes with the free drivers?

3 Likes

Installed via "Gruda Settings Manager" > "Hardware Configuration".
Now installing open source drivers to test it out.

I see from the Nvidia site you have the correct driver, I think.
Maybe you could try updating your BIOS, since it seems very old?
I'm not sure this will help, but that would be good anyway, in my opinion.

2 Likes

BIOS is latest version, but open source drivers works perfectly good.
Will there be performance loss for apps that need good GPU like hashcat (for brute-forcing passwords) since I'm on Nouveau?

1 Like

No thanks, I am not doing illegal things.

2 Likes

And huge thanks for everyone who tried to help I really appreciate!

4 Likes

What exactly is the link to this particular topic?

1 Like

Again, I must admit I've not enough experience on high-performance tasks (like the one you mentioned or gaming, which has a lot of fans here), but I assume at a certain point you could find a bottleneck in the nouveau driver...
If that happens, in my opinion you could:

  • try again with proprietary drivers (maybe there'll be an update)
  • try as many kernels as possible (e.g. it seems to me that many gamers use linux-tkg, but I might be wrong)
  • ask again in the forum :slight_smile: (as mentioned, there are many Nvidia users and gamers)
2 Likes

Try using gamemode as well, I have seen it help before.

Try remove latte-dock-git. I had terrible lags and memory leaks in KDE.