Garuda KDE Dr460nized - Steam Deck - No mouse cursor with touchpads on Wayland

Hello!,
I have just started using Garuda (Coming from vanilla Arch) and I loving the setup and how snappy it is on my gaming rig and now my Steam Deck.

I do have one issue, My mouse cursor is visible when using a regular mouse on my steam deck however if i want to use the built in track pad the mouse cursor is not visible. I can tell that its moving around and see when it highlights something there is just no visible cursor.

To give some additional info I am running Wayland instead of x11 as I get better performance in game, I know this only effect wayland as when I load into x11 everything works fine.

Thanks in advance!

To get ahead of the question here is my “garuda-inxi” Neofetch info below for good measure



   System:
   Kernel: 6.5.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
   clocksource: tsc available: hpet,acpi_pm
   parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
   root=UUID=4a24e3d5-233a-493a-9245-860fef5a34c4 rw rootflags=subvol=@
   quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
   ibt=off
   Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
   dm: SDDM Distro: Garuda Linux base: Arch Linux
   Machine:
   Type: Portable System: Valve product: Jupiter v: 1
   serial: Chassis: type: 8 v: 1
   serial:
   Mobo: Valve model: Jupiter serial: UEFI: Valve
   v: F7A0116 date: 05/12/2023
   Battery:
   ID-1: BAT1 charge: 37.7 Wh (100.0%) condition: 37.7/40.0 Wh (94.2%)
   volts: 8.7 min: 7.7 model: GETAC type: Unknown serial:
   status: not charging
   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360
   serial: charge: 100% (should be ignored) rechargeable: yes
   status: discharging
   CPU:
   Info: model: AMD Custom APU 0405 bits: 64 type: MT MCP arch: Zen 2 gen: 3
   level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
   family: 0x17 (23) model-id: 0x90 (144) stepping: 2 microcode: 0x8900201
   Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
   L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
   desc: 1x4 MiB
   Speed (MHz): avg: 1957 high: 2800 min/max: 1700/2800 boost: enabled
   scaling: driver: acpi-cpufreq governor: performance cores: 1: 2800 2: 1426
   3: 1566 4: 1389 5: 1496 6: 2800 7: 1384 8: 2800 bogomips: 44800
   Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
   Vulnerabilities:
   Graphics:
   Device-1: AMD VanGogh [AMD Custom GPU 0405] driver: amdgpu v: kernel
   arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
   gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
   active: DP-1 off: eDP-1 empty: none bus-ID: 04:00.0 chip-ID: 1002:163f
   class-ID: 0300 temp: 48.0 C
   Device-2: USB C Video Adaptor driver: N/A type: USB rev: 2.0
   speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.2:3 chip-ID: 25a4:9411
   class-ID: 1100 serial:
   Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.2.1
   compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
   alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
   Monitor-1: DP-1 res: 1920x1080 size: N/A modes: N/A
   API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
   device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
   drv: radeonsi inactive: gbm
   API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.8-arch1.1
   glx-v: 1.4 direct-render: yes renderer: AMD Custom GPU 0405 (vangogh LLVM
   16.0.6 DRM 3.54 6.5.5-zen1-1-zen) device-ID: 1002:163f memory: 1000 MiB
   unified: no display-ID: :1.0
   API: Vulkan v: 1.3.264 layers: 13 device: 0 type: integrated-gpu name: AMD
   Custom GPU 0405 (RADV VANGOGH) driver: mesa radv v: 23.1.8-arch1.1
   device-ID: 1002:163f surfaces: xcb,xlib,wayland device: 1 type: cpu
   name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
   v: 23.1.8-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
   surfaces: xcb,xlib,wayland
   Audio:
   Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Valve
   driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
   link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1640
   class-ID: 0403
   Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Valve
   driver: snd_pci_acp5x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
   snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
   snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s
   lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.5
   chip-ID: 1022:15e2 class-ID: 0480
   API: ALSA v: k6.5.5-zen1-1-zen status: kernel-api with: aoss
   type: oss-emulator tools: N/A
   Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
   status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
   4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
   Network:
   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
   vendor: AzureWave driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
   gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0
   chip-ID: 10ec:c822 class-ID: 0280
   IF: wlo1 state: up mac:
   Bluetooth:
   Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
   rev: 1.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-5:3 chip-ID: 13d3:3553
   class-ID: e001 serial:
   Report: btmgmt ID: hci0 rfk-id: 0 state: up address: bt-v: 5.1
   lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c010c
   Drives:
   Local Storage: total: 1.42 TiB used: 361.28 GiB (24.8%)
   ID-1: /dev/mmcblk0 maj-min: 179:0 model: Stora size: 921.73 GiB
   block-size: physical: 512 B logical: 512 B tech: SSD serial:
   scheme: GPT
   SMART Message: Unknown smartctl error. Unable to generate data.
   SMART Message: Unable to run smartctl. Root privileges required.
   ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
   model: KBG40ZNS512G NVMe 512GB size: 476.94 GiB block-size: physical: 512 B
   logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial:
   fw-rev: 10410106 temp: 63.9 C scheme: GPT
   ID-3: /dev/sda maj-min: 8:0 vendor: Generic model: STORAGE DEVICE
   size: 55.69 GiB block-size: physical: 512 B logical: 512 B type: USB
   rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial:
   fw-rev: 1532 scheme: MBR
   SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
   Partition:
   ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
   used: 258.47 GiB (54.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
   ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
   used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
   ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
   used: 258.47 GiB (54.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
   ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
   used: 258.47 GiB (54.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
   ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
   used: 258.47 GiB (54.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
   Swap:
   Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
   ID-1: swap-1 type: zram size: 14.48 GiB used: 736.5 MiB (5.0%)
   priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
   dev: /dev/zram0
   Sensors:
   System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 48.0 C
   Fan Speeds (rpm): N/A
   Info:
   Processes: 311 Uptime: 3h 27m wakeups: 13 Memory: total: 16 GiB note: est.
   available: 14.48 GiB used: 3.88 GiB (26.8%) Init: systemd v: 254
   default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
   pm: pacman pkgs: 1885 libs: 555 tools: octopi,paru Shell: fish v: 3.6.1
   default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30
   Garuda (2.6.16-1):
   System install date: 2023-09-26
   Last full system update: 2023-09-28 ↻
   Is partially upgraded: No
   Relevant software: snapper NetworkManager dracut
   Windows dual boot: No/Undetected
   Failed units:

OS: Garuda Linux x86_64
Host: Jupiter 1
Kernel: 6.5.5-zen1-1-zen
Uptime: 3 hours, 36 mins
Packages: 1886 (pacman)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: Plasma 5.27.8
WM: kwin
WM Theme: Breeze
Theme: [Plasma], Breeze [GTK2], Sweet-Dark [GTK3]
Icons: Papirus-Dark [Plasma], Papirus-Dark [GTK2/3]
Terminal: konsole
Terminal Font: FiraCode Nerd Font Mono 12
CPU: AMD Custom APU 0405 (8) @ 2.800GHz
GPU: AMD ATI AMD Custom GPU 0405
Memory: 3603MiB / 14828MiB
1 Like

You 're using Wayland, as you say, KDE Plasma, whose development lags behind that of GNOME’s. So that makes me wonder if it might act differently under that DE and Wayland.

Also, the ‘swoosh’ indicates a reboot is in order. :smiley:

EDIT: Have you seen this thread? No idea if it helps, but… Running Wayland on DG

5 Likes

Tried the reboot, and i notice something looking in my Input settings. I think it sees the trackpad as a drawing tablet… which would explain the no mouse.

Touchpad Settings

Drawing Tablet settings

Hello I use this to use the Trackpads and to do much more configurations

################## edit ####################
Pleas use this Version

and install it via the Repo(caotic-aur) using:

pacman -S sc-controller

do not use this link it leads to an non supported Version
https:edit//github.com/kozec/sc-controller/releases
################## edit ####################

3 Likes

YOU ARE A LEGEND! That works like a charm! I literally just loaded the software and it started working correctly!!

1 Like

by the way under x11 you even get an onscreen keyboard with track pad support
by the way i just noticed I posted the wrong link

This is the actual Repo pleas check if you installed the proper version

1 Like

the one i ran looked like a Steam controller and then changed to the Steam Deck

Pleas type this in the cmd

'pacman -Q --info sc-controller'

what do you get as return
should look like this

Name                     : sc-controller
Version                  : 0.4.8.11-1
Beschreibung             : User-mode driver and GTK3 based GUI for Steam Controller
Architektur              : any
URL                      : https://github.com/Ryochan7/sc-controller
Lizenzen                 : GPL2
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : gtk3  python-gobject  python-cairo  python-pylibacl  python-evdev  xorg-xinput
Optionale Abhängigkeiten : gtk-layer-shell: wayland OSD support
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : sc-controller-git
Ersetzt                  : Nichts
Installationsgröße       : 10,84 MiB
Packer                   : UFSCar HPC Builder <[email protected]>
Erstellt am              : Do 25 Mai 2023 04:09:42 CEST
Installiert am           : Fr 26 Mai 2023 18:03:25 CEST
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Nein
Verifiziert durch        : Signatur

I actually dont get anything back. What i downloaded was a sc-controller-0.4.8+5b42308-x86_64.AppImage file that just executes.

1 Like

Ok you downloaded the appimage version
you should remove that one

and use the one in the repo/caoticAur
cause it is maintained and updated with your system

and if you use the appimage version use the “official version” from the second link

use this link/version

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.