Garuda KDE does not boot either from USB or DVD-RW

I think its nvidia driver problem

Perhaps Your graphics is not supported by the nvidia450 driver

Please try to boot with free driver.

2 Likes

Hello all
First time I tried to boot and install Garuda I had the same problem... No boot...
I read somewhere here in forum that I had to change "non-free" (I think it was default choice) to "free" and then was able to boot/install...
My laptop has NVIDIA GK107GLM [Quadro K1100M]...
As for ISO->USB I've always used Baleno Etcher without problems...

HTH
Theodore

3 Likes

Thank you @librewish, that allowed booting, but Garuda KDE Ultimate does not connect to the internet, and the screen is flickering, impossible to work in that way. I am sad because I like Garuda and mostly because it is a rolling distro, MX is not, but MX works with my hardware.
Regards

If you like to fix we need more details about your hardware ...
Post then output from

inxi -Fxxxza --no-host

otherwise thank you for testing Garuda :slight_smile:

Hello @SGS the a is not valid in my system this is the output without the a:

inxi -Fxxxz --no-host

System:    Kernel: 4.7.0-0.bpo.1-amd64 x86_64 bits: 64 compiler: gcc v: 4.9.2 
       Desktop: Xfce 4.12.3 tk: Gtk 2.24.25 info: xfce4-panel dm: lightdm 1.10.3 
       Distro: MX-16 amd64 Migrated 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V LX v: Rev X.0x serial: <filter> 
       BIOS: American Megatrends v: 1801 date: 02/28/2013 
CPU:       Topology: Quad Core model: Intel Core i7-2600K bits: 64 type: MT MCP 
       arch: Sandy Bridge rev: 7 L2 cache: 8192 KiB 
       flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54582 
       Speed: 1660 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1660 2: 1653 3: 1755 
       4: 1600 5: 1678 6: 1639 7: 1944 8: 1646 
Graphics:  Card-1: NVIDIA GF110 [GeForce GTX 570 Rev. 2] driver: nvidia v: 384.130 
       bus ID: 01:00.0 chip ID: 10de:1086 
       Display: server: X.Org 1.16.4 driver: nvidia resolution: 1600x900~60Hz 
       OpenGL: renderer: GeForce GTX 570/PCIe/SSE2 v: 4.5.0 NVIDIA 384.130 
       direct render: Yes 
Audio:     Card-1: Intel 7 Series/C210 Series Family High Definition Audio driver: snd_hda_intel 
       v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
       Card-2: NVIDIA GF110 High Definition Audio driver: snd_hda_intel v: kernel 
       bus ID: 01:00.1 chip ID: 10de:0e09 
       Sound Server: ALSA v: k4.7.0-0.bpo.1-amd64 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
       v: 2.3LK-NAPI port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
       IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 2.05 TiB used: 1.77 TiB (86.6%) 
       ID-1: /dev/sda vendor: Western Digital model: WD2002FAEX-007BA0 size: 1.82 TiB 
       speed: 6.0 Gb/s serial: <filter> rev: 1D05 scheme: MBR 
       ID-2: /dev/sdb vendor: Intel model: SSDSC2CW240A3 size: 223.57 GiB speed: 6.0 Gb/s 
       serial: <filter> rev: 400i scheme: MBR 
       ID-3: /dev/sdc type: USB vendor: Kingston model: DataTraveler 2.0 size: 7.57 GiB 
       serial: <filter> rev: PMAP scheme: MBR 
Partition: ID-1: / size: 219.94 GiB used: 201.76 GiB (91.7%) fs: ext4 dev: /dev/sdb1 
       ID-2: swap-1 size: 2.02 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 38 C 
       Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 40% 
Info:      Processes: 315 Uptime: 53m Memory: 15.62 GiB used: 3.10 GiB (19.9%) Init: SysVinit 
       v: 2.88 runlevel: 5 default: 5 Compilers: gcc: 4.9.2 alt: 4.9 Shell: bash v: 4.3.30 
       running in: xfce4-terminal inxi: 3.0.10 

I also have more detailed information here:

1 Like

You can install nvidia 390xx-dkms nvidia-390xx-utils

They are in repo

2 Likes

@librewish But Garuda does not connect to internet

systemctl status NetworkManager

From garuda

You can try

systemctl start NetworkManager

2 Likes

If your router/AP has wifi then you can use your phone as a temporary wifi receiver for your computer. Using your cell phone via USB Android phone tethering does not use your phones data plan. It simply provides access to your AP and your local network connection.

This will allow you to use your home internet wifi connection to perform the downloads/ installs you require. If you don't have a wifi connection at the location you are at, you could always try this at a local internet cafe or library to get internet connectivity.

Another option is to borrow/purchase a USB to Ethernet adapter as another temporary method to get a working Ethernet connection. This may seem like a rather frivolous waste of money for a one time use, but it will ensure you always have a working Ethernet connection in case you again experience issues with your r8168 adapter. The r8168 adapter while cheap and plentiful often has issues on many Linux distro's. A USB to Ethernet adapter is good insurance to have in case you have issues with your internal adapter.

3 Likes

Hello @librewish @SGS and the other users, thanks for your support.
I tried my DVD with Garuda KDE Lite with the free drivers and I got the Internet working fine and the screen not flickering, but now the audio is not working. When I boot from my old Linux in the SSD audio works, any idea?, probably now an audio proprietary driver is missing. I am almost ready to install Garuda KDE Lite.
Regards.

1 Like

Do it :slight_smile:

Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0 chip ID: 8086:1e20
           Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:10f1
           Sound Server: ALSA v: k5.8.8-zen1-1-zen

Maybe you need there some help too. :wink:

2 Likes

Thanks, @SGS I will install KDE Lite with the free drives then I will rely on your kind help to complete what is missing, I really like Garuda. I will need about 30 minutes from the DVD because it is slower. Regards

2 Likes

Your KDE lite need maybe the following packages

####---->> AUDIO
>extra garuda-alsa
>extra garuda-pulse 
>extra garuda-pipewire ?
>extra pulseaudio-ctl
>extra playerctl

Start with

sudo pacman -Syu garuda-alsa garuda-pulse pulseaudio-ctl playerctl
2 Likes

Thanks a lot @SGS I am posting from Garuda KDE Lite already installed on my SSD, I am going to follow your instructions, I appreciate your time and help. I will let you know.
Regards

2 Likes

Hello, I have problems upgrading the system I get several errors, conflict files, with files in the system and also a file in system newer that the file to install, I do not know what to do, it seem to me that the upgrade is inside a loop, sorry, the following is repeated several times:

Translate

Preparing ...
Cloning imagewriter build files ...
Checking imagewriter dependencies ...
Synchronizing with databases ...
Warning: kwin-scripts-window-colors: installed version (0.2-4) is newer than chaotic-aur (0.2-3)
Resolving dependencies ...
Checking for package conflicts ...
Verifying keys in the database ...
Verifying the integrity of the packages ...
Loading package files ...
Checking for package conflicts ...
The operation could not be performed:
conflicting files:

     mauikit-git: /usr/lib/qt/qml/org/kde/appletdecoration/AuroraeButton.qml already exists in the system (belongs to plasma5-applets-window-buttons)
     mauikit-git: /usr/lib/qt/qml/org/kde/appletdecoration/libappletdecorationplugin.so already exists on the system (belongs to plasma5-applets-window-buttons)
     mauikit-git: / usr / lib / qt / qml / org / kde / appletdecoration / qmldir already exists on the system (belongs to plasma5-applets-window-buttons)
> Preparando...
> Clonando imagewriter archivos de compilación...
> Comprobando imagewriter dependencias...
> Sincronizando con las bases de datos...
> Advertencia: kwin-scripts-window-colors: la versión instalada (0.2-4) es más nueva que chaotic-aur (0.2-3)
> Resolviendo dependencias...
> Comprobando conflictos entre paquetes...
> Verificando claves en la base de datos...
> Verificando la integridad de los paquetes...
> Cargando archivos de paquetes...
> Verificando conflictos entre paquetes...
> No se ha podido realizar la operación:
> archivos en conflicto:
> - mauikit-git: /usr/lib/qt/qml/org/kde/appletdecoration/AuroraeButton.qml ya existe en el sistema (pertenece a plasma5-applets-window-buttons)
> - mauikit-git: /usr/lib/qt/qml/org/kde/appletdecoration/libappletdecorationplugin.so ya existe en el sistema (pertenece a plasma5-applets-window-buttons)
> - mauikit-git: /usr/lib/qt/qml/org/kde/appletdecoration/qmldir ya existe en el sistema (pertenece a plasma5-applets-window-buttons)

It downloaded 1.2GB of files to update and it is stuk in those 4 files. I am going to sleep is very late here.
Regards

Warning is no problem, ignore it. It fixed from alone.

To fix existing files conflict do

sudo pacman -Syu --overwrite "*"

if you put ‘LANG=C’ in front it will translate to english

LANG=C sudo pacman -Syu --overwrite "*"
1 Like

Hello and thanks @SGS It did the upgrade, then I installed Alsa and got these messages, I should merge 2 files, but I do not know what to do, I do not want to make mistakes, sorry:

.pac* files found:
/etc/locale.gen.pacnew
/etc/default/grub-btrfs/config.pacnew
Please check and merge

$ LANG=C sudo pacman -Syu garuda-alsa garuda-pulse pulseaudio-ctl playerctl                                
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from reflector.luehm.com : Resolving timed out after 10000 milliseconds
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date
:: Starting full system upgrade...
warning: kwin-scripts-window-colors: local (0.2-4) is newer than chaotic-aur (0.2-3)
resolving dependencies...
looking for conflicting packages...

Packages (16) alsa-firmware-1.2.1-2  alsa-oss-1.1.8-3  alsa-plugins-1:1.2.2-2  alsa-utils-1.2.3-2  confuse-3.3-1
              libftdi-1.4-4  libusb-compat-0.1.7-1  lirc-1:0.10.1-6  pulseaudio-alsa-1:1.2.2-2  pulseaudio-jack-13.0-3
              pulseaudio-lirc-13.0-3  pulseaudio-zeroconf-13.0-3  garuda-alsa-20200912-1  garuda-pulse-20200912-1
              playerctl-2.2.1-1  pulseaudio-ctl-1.67-1

Total Download Size:    6,00 MiB
Total Installed Size:  21,61 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
 alsa-utils-1.2.3-2-x86_64                     1126,7 KiB   118 KiB/s 00:10 [-------------------------------------------]  18%
 alsa-firmware-1.2.1-2-any                        4,4 MiB   110 KiB/s 00:41 [-------------------------------------------]  73%
 alsa-plugins-1:1.2.2-2-x86_64                    4,5 MiB   108 KiB/s 00:43 [-------------------------------------------]  74%
 alsa-oss-1.1.8-3-x86_64                          4,5 MiB   107 KiB/s 00:43 [-------------------------------------------]  75%
 pulseaudio-alsa-1:1.2.2-2-x86_64                 4,5 MiB   106 KiB/s 00:44 [-------------------------------------------]  75%
 pulseaudio-jack-13.0-3-x86_64                    4,5 MiB   106 KiB/s 00:44 [-------------------------------------------]  75%
 pulseaudio-zeroconf-13.0-3-x86_64                4,6 MiB   103 KiB/s 00:45 [-------------------------------------------]  76%
 libusb-compat-0.1.7-1-x86_64                     4,6 MiB  99,3 KiB/s 00:47 [-------------------------------------------]  76%
 lirc-1:0.10.1-6-x86_64                           5,8 MiB  98,9 KiB/s 01:00 [-------------------------------------------]  95%
 pulseaudio-lirc-13.0-3-x86_64                    5,8 MiB  98,6 KiB/s 01:00 [-------------------------------------------]  96%
 confuse-3.3-1-x86_64                             5,8 MiB  94,8 KiB/s 01:03 [-------------------------------------------]  96%
 libftdi-1.4-4-x86_64                             5,9 MiB  93,3 KiB/s 01:05 [-------------------------------------------]  98%
 playerctl-2.2.1-1-x86_64                         6,0 MiB  93,0 KiB/s 01:06 [-------------------------------------------]  99%
error: failed retrieving file 'garuda-alsa-20200912-1-any.pkg.tar.zst' from lonewolf-builder.duckdns.org : Resolving timed out after 10000 milliseconds
 garuda-alsa-20200912-1-any                       6,0 MiB  79,4 KiB/s 01:17 [-------------------------------------------]  99%
 garuda-pulse-20200912-1-any                      6,0 MiB  74,2 KiB/s 01:23 [-------------------------------------------]  99%
 pulseaudio-ctl-1.67-1-any                        6,0 MiB  74,1 KiB/s 01:23 [-------------------------------------------] 100%
(16/16) checking keys in keyring                                            [-------------------------------------------] 100%
(16/16) checking package integrity                                          [-------------------------------------------] 100%
(16/16) loading package files                                               [-------------------------------------------] 100%
(16/16) checking for file conflicts                                         [-------------------------------------------] 100%
(16/16) checking available disk space                                       [-------------------------------------------] 100%
:: Processing package changes...
( 1/16) installing alsa-utils                                               [-------------------------------------------] 100%
Optional dependencies for alsa-utils
    fftw: for alsabat [installed]
( 2/16) installing alsa-firmware                                            [-------------------------------------------] 100%
( 3/16) installing alsa-plugins                                             [-------------------------------------------] 100%
Optional dependencies for alsa-plugins
    dbus: for maemo plugin [installed]
    jack: for pcm_jack plugin [installed]
    libavtp: for pcm_aaf plugin
    libsamplerate: for rate_samplerate plugin [installed]
    libpulse: for conf_pulse, ctl_pulse and pcm_pulse plugins [installed]
    speexdsp: for pcm_speex and rate_speexrate plugins [installed]
( 4/16) installing alsa-oss                                                 [-------------------------------------------] 100%
Optional dependencies for alsa-oss
    bash: for aoss [installed]
( 5/16) installing garuda-alsa                                              [-------------------------------------------] 100%
Optional dependencies for garuda-alsa
    alsa-tools
( 6/16) installing pulseaudio-alsa                                          [-------------------------------------------] 100%
( 7/16) installing pulseaudio-jack                                          [-------------------------------------------] 100%
( 8/16) installing pulseaudio-zeroconf                                      [-------------------------------------------] 100%
( 9/16) installing confuse                                                  [-------------------------------------------] 100%
(10/16) installing libftdi                                                  [-------------------------------------------] 100%
Optional dependencies for libftdi
    python: library bindings [installed]
(11/16) installing libusb-compat                                            [-------------------------------------------] 100%
(12/16) installing lirc                                                     [-------------------------------------------] 100%
Optional dependencies for lirc
    python: for lirc-setup, irdb-get and pronto2lirc [installed]
(13/16) installing pulseaudio-lirc                                          [-------------------------------------------] 100%
(14/16) installing garuda-pulse                                             [-------------------------------------------] 100%
Optional dependencies for garuda-pulse
    pavucontrol: A GTK volume control tool for PulseAudio
    pulseaudio-equalizer-ladspa: A gui equalizer for pulseaudio [installed]
    pasystray: pulseaudio system tray
    paprefs: configuration dialog for pulseaudio [installed]
    pulseaudio-ctl: Control PulseAudio volume from the shell or mapped to keyboard shortcuts [pending]
(15/16) installing pulseaudio-ctl                                           [-------------------------------------------] 100%
--------------------------------------------------------------------------
                           INSTRUCTIONS FOR USE

Simply map the following scripts to keyboard shortcuts in your DE or WM.
Xfce4 allows for this under Settings > Keyboard > Application Shortcuts.

/usr/bin/pulseaudio-ctl mute ==>  Toggle status of mute
/usr/bin/pulseaudio-ctl mute-input ==>  Toggle status of mute for mic
/usr/bin/pulseaudio-ctl up   ==>  Increase vol by 5 %
/usr/bin/pulseaudio-ctl down ==>  Decrease vol by 5 %
--------------------------------------------------------------------------
Optional dependencies for pulseaudio-ctl
    libnotify: to display volume and mute status [installed]
(16/16) installing playerctl                                                [-------------------------------------------] 100%
:: Running post-transaction hooks...
(1/8) Reloading system manager configuration...
(2/8) Creating temporary files...
Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
error: command failed to execute correctly
(3/8) Reloading device manager configuration...
(4/8) Arming ConditionNeedsUpdate...
(5/8) Cleaning pacman cache...
==> no candidate packages found for pruning
(6/8) Foreign/AUR package notification
imagewriter 1.10.1432200249.1d253d9-11
kde-service-menu-reimage 2.5-1
lib32-libva1 1.8.3-3
lib32-libva1-intel-driver 1.8.3-1
libva1 1.8.3-3
libva1-intel-driver 1.8.3-2
(7/8) Orphaned package notification
lib32-libva1-intel-driver 1.8.3-1
(8/8) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/locale.gen.pacnew
/etc/default/grub-btrfs/config.pacnew
Please check and merge
1 Like

You can ignore the locale.gen.pacnew

2 Likes

Also for your audio
Is it hdmi not working or its the audio through jack

If its from hdmi

Then chances are you need nvidia driver.

2 Likes

Hello @SGS it is through jack, audio is not working, should I install anyway the drivers suggested by @librewish ?

nvidia 390xx-dkms nvidia-390xx-utils

Thank you

1 Like