Garuda KDE Barebones Laggy

Hello all,

Garuda KDE Barebones edition is incredibly laggy and unresponsive while Barebones gnome is smooth as butter.

Output of inxi -Faz

`System:    Kernel: 5.10.72-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=45fdce4e-9d7e-4f61-97f3-8fffb44cd737 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 resume=UUID=f2c90069-6b53-4108-8b97-8f428a3833e8 loglevel=3 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z77 Professional serial: <filter> UEFI: American Megatrends v: P1.90 
           date: 03/13/2018 
CPU:       Info: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 21 cache: L2: 8 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56005 
           Speed: 3139 MHz min/max: 1600/4400 MHz Core speeds (MHz): 1: 3139 2: 4357 3: 4400 4: 3876 5: 3905 6: 4230 7: 3931 
           8: 3843 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Vulnerable: No microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics vendor: ASRock driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0162 class-ID: 0380 
           Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia v: 470.74 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300 
           Display: x11 server: X.org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nvidia unloaded: modesetting,nouveau 
           alternate: fbdev,nv,vesa resolution: <missing: xdpyinfo> 
           OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASRock Z77 Extreme4 driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:0fb9 class-ID: 0403 
           Device-3: Plantronics Plantronics C520-M type: USB driver: plantronics,snd-usb-audio,usbhid bus-ID: 1-1.6:4 
           chip-ID: 047f:c036 class-ID: 0300 serial: <filter> 
           Sound Server-1: ALSA v: k5.10.72-1-lts running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.38 running: no 
Network:   Device-1: Broadcom NetLink BCM57781 Gigabit Ethernet PCIe vendor: ASRock Z77 Extreme4 driver: tg3 v: kernel 
           port: c000 bus-ID: 09:00.0 chip-ID: 14e4:16b1 class-ID: 0200 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Broadcom NetLink BCM57781 Gigabit Ethernet PCIe vendor: ASRock Z77 Extreme4 driver: tg3 v: kernel 
           port: c000 bus-ID: 0b:00.0 chip-ID: 14e4:16b1 class-ID: 0200 
           IF: enp11s0 state: down mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.42 TiB used: 22.26 GiB (1.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD3200BEKX-75B7WT0 size: 298.09 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDX240GG25 size: 223.57 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: R201 scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3J0 scheme: GPT 
Partition: ID-1: / raw-size: 280.77 GiB size: 280.77 GiB (100.00%) used: 22.26 GiB (7.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 280.77 GiB size: 280.77 GiB (100.00%) used: 22.26 GiB (7.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-4: /var/log raw-size: 280.77 GiB size: 280.77 GiB (100.00%) used: 22.26 GiB (7.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw-size: 280.77 GiB size: 280.77 GiB (100.00%) used: 22.26 GiB (7.9%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 15.51 GiB used: 2.15 GiB (13.9%) priority: 100 dev: /dev/zram0 
           ID-2: swap-2 type: partition size: 17.07 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3 
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 37 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 347 Uptime: 22h 54m wakeups: 0 Memory: 15.51 GiB used: 5.84 GiB (37.7%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1367 lib: 348 Shell: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.06`

To fix the issue I have tried to Enable "Full Composition Pipeline" In Nvidia X Server Settings but to no avail. I am running the latest Proprietary NVIDIA drivers.

Please let me know if you need any more information.

Try disabling baloo.

1 Like

I disabled baloo but the problem still persists.

Disable the compositor.

Using Alt-Shift-F12 right. It fixes the stuttering but i want to keep the compositor running if possible for animations and transparency.

Enable the compositor, then try different combinations of compositor settings (such as XRender etc) to see if there is improvement. A log off might be best between changes to be sure they are being applied.

3 Likes

I have tried all of the options before hand and the only option that works is xrender which uses cpu rendering and the screen tears like crazy.

Is this a fresh install?

Which Nvidia driver version are you using, and how did you install it?

Try lowering the number/intensity of KDE's graphical effects such as blur etc to see if your system becomes more responsive.

Please explain the symptoms you are experiencing in greater detail.

Have you used htop to view your processor and other stats for unusually high numbers?

It's probably a long shot that this is a kernel related issue, but you should always test alternates (just to be sure). Test out the linux-lts, linux-mainline, linux, and linux-hardened kernels.

2 Likes

The install is about 3 days old. I am running driver 470.74. Is it recommended to run xanmod or zen? I am currently running the default of linux-lts.

After changing animations to instant in systemsettings still seeing same stutter.

Use whichever kernel gives you the best performance sometimes that takes a bit of experimentation. Give the ones I suggested a test out.

See if ether of these commands affects your performance when run:

kwin_x11 --replace &
plasmashell --replace &

Posting the outputs of those commands might be helpful. This time, please put 3 ~~~ before and after your text body. I edited your initial post in this manner for proper formatting to aid with readability. Please use proper text formatting when posting terminal outputs.

1 Like

The output of the first command,

kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5091:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5093:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5097:47: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5099:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5107:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5111:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5113:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5117:45: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5120:46: this compose sequence is a duplicate of another; skipping line
kwin_core: XCB error: 147 (BadOutput), sequence: 483, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 484, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 485, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 486, resource id: 85, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 487, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 496, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 497, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 498, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 499, resource id: 37, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
kwin_core: XCB error: 147 (BadOutput), sequence: 500, resource id: 0, major code: 140 (RANDR), minor code: 9 (GetOutputInfo)
OpenGL vendor string:                   NVIDIA Corporation
OpenGL renderer string:                 NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
OpenGL version string:                  3.1.0 NVIDIA 470.74
OpenGL shading language version string: 1.40 NVIDIA via Cg compiler
Driver:                                 NVIDIA
Driver version:                         470.74
GPU class:                              Unknown
OpenGL version:                         3.1
GLSL version:                           1.40
X server version:                       1.20.13
Linux kernel version:                   5.10.72
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
qml: FORCE-BLUR: starting the script
qml: ["yakuake","urxvt","keepassxc"]
kwin_core: XCB error: 10 (BadAccess), sequence: 5936, resource id: 561, major code: 142 (Composite), minor code: 2 (RedirectSubwindows)
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6391, resource id: 140509377, major code: 18 (ChangeProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 31221, resource id: 142606345, major code: 18 (ChangeProperty), minor code: 0
kwin_core: XCB error: 152 (BadDamage), sequence: 35701, resource id: 140510607, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_core: XCB error: 152 (BadDamage), sequence: 36854, resource id: 140510636, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_core: XCB error: 152 (BadDamage), sequence: 39522, resource id: 140510664, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_x11 --replace &kwin_core: XCB error: 152 (BadDamage), sequence: 50665, resource id: 140509430, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_core: XCB error: 152 (BadDamage), sequence: 50668, resource id: 140509431, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_core: XCB error: 152 (BadDamage), sequence: 50671, resource id: 140509423, major code: 143 (DAMAGE), minor code: 2 (Destroy)
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1702, resource id: 140510146, major code: 3 (GetWindowAttributes), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 1703, resource id: 140510146, major code: 14 (GetGeometry), minor code: 0
kwin_core: XCB error: 152 (BadDamage), sequence: 9111, resource id: 140513013, major code: 143 (DAMAGE), minor code: 2 (Destroy)
kwin_core: XCB error: 152 (BadDamage), sequence: 13246, resource id: 140513330, major code: 143 (DAMAGE), minor code: 2 (Destroy)

The first command seems to have fixed it!

1 Like

Very strange. I really didn't expect that would work, (but I thought it was worth a try any ways).

Not a proper fix but a workaround would be to script that command and then set it to autorun after login with KDE's "Autostart" in the System Settings.

1 Like

It does start lagging again after 1/2 of an hour though.... It is a good idea to set it as an autorun.

You could set cron to run the command every half hour, but that really seems like a hacky workaround.

Did you install htop and check on your running processes.

Htop doesn't seem to indicate any high cpu usage. Just cpu usage under 20%.

What is your memory usage like, and is it growing over time.

I would try installing kwin-git , and if that is no better try kwin-lowlatency.

Edit:

You may also want test out kwinft (and its variations).

I asked you to do this earlier, and you did not. It would be helpful to know exactly what symptoms are presenting.

Have you tested the free nvidia driver, and if so, was the problem the same?

Your display information is missing from your inxi output, are you running dual monitors?

Please post:

inxi -Ga

What about this?
Just something to try...
https://bugs.kde.org/show_bug.cgi?id=443511

4 Likes

Hopefully the OP has tested all those permutations. :wink:

You also might want to disable all kwin scripts (if using any).

You also have not stated if this issue is present on the KDE Dragonized ISO. Please test out the Draginized KDE version and report if the same issue is present.

4 Likes