Garuda Installation on HDD from USB

Hello I’m new to this reedit and to Garuda Linux, I tried installing Garuda from an USB with Rufus to install Garuda in my hdd external drive but when I boot from the USB to start the setup it stays in black, help what can I do. Help please :pleading_face:

Hi there, welcome to the forum.
Please make sure to follow at least the Installation Procedure in Garuda Linux | Download.
Especially, I suggest you try Ventoy instead of Rufus. It is very easy to use: when set-up, you can simply copy&paste the iso files in the USB (as many as you like, if you want to try several editions or distros).
Also make sure to verify the iso file checksum (search online how to do it, either from Windows or from another Linux system).

PS: this is a forum, not a reddit. It makes a difference for us :wink:

5 Likes

I’m gonna try now, thank you so much, also I’m sorry I tried writing in the reddit of the community but got deleted because I sent to support and the bot deleted it, so I just copy pasted the message and forgot to change that :rofl::sweat_smile:

Has the same checksum but it doesn’t work with ventoy either, now it didn’t even recognized the USB

Disable fast and secure boot in BIOS check if ahci is in use.

Change USB port if possible, Start M$ and shutdown the PC, do not reboot from M$.

1 Like

I have the fast boot and secure boot disabled, I come from Kali Linux, but the Garuda installer link expired or something, when I press in the link appears error 404 nginx

Correct, need a correction by @TNE ?, but you use ventoy :slight_smile:

Can you post inxi -Faz from Kali?
Did you dual boot with Win XY?
ahci?

Right now I only have the windows 11, I uninstalled the Kali because was consuming 7gb of ram with the desktop bspwm so I removed the whole disk in which it was and downloaded this, but I still have windows 11

I just checked I don’t have the ahci in device manager, what can I do?


Please do not post here in the forum, like in chat forums like Telegram.
As long as no one has responded to your post, you can edit your post.

What do you see in the BIOS for SATA controller?

this is my device manager.

In the BIOS, not in the Windows Device Manager.
I see in Windows Intel SATA Raid, which could give problems.

What can you select instead of “Optane without RAID”?
This is the Information Tab, the update should be done from another tab.
Even if you are “without RAID”, check this:
https://wiki.archlinux.org/title/Laptop/Acer#Switching_NVMe_mode_to_AHCI
Main tab.

unavailable until Supervisor password set

1 Like

It doesn’t Allow me to change anything, I have supervisor password and user password

Oh now it works the ahci

I’m gonna create again the ventoy thing and copy the iso to it, when it’s done should I press update or I copy to it and just that,
Thank you so much for helping me

1 Like

Normally just copying the iso there is enough.
In case of troubles try other tools, e.g. Balena Etcher, also this one mentioned in the Installation Procedure in the download page mentioned earlier.
Check it, it has good hints in general.

1 Like

Please!

1 Like