Garuda Installation Failed, unable to create partition

Hello Garuda expert,

I had tried to make the partition to brtf, but the installation still failed

Create a new partition (465.76 GiB, btrfs) on ‘/dev/sda’

Job: Create new partition on device ‘/dev/sda’

Command: sfdisk --force --append /dev/sda

Job: Set the label on partition ‘/dev/sda1’ to "root"

Partition table of partition ‘/dev/sda1’ does not support setting names. Job ignored.

Job: Create file system ‘btrfs’ on partition ‘/dev/sda1’

Command: mkfs.btrfs --force /dev/sda1

inxi -Faz

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZEDGAMING_RAPTOR quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20404 v: Lenovo Flex 2-14
serial: <superuser required> Chassis: type: 10 v: Lenovo Flex 2-14
serial: <superuser required>
Mobo: LENOVO model: Lenovo Flex 2-14 v: 31900059 WIN
serial: <superuser required> UEFI-[Legacy]: LENOVO v: A0CN26WW
date: 05/21/2014
ID-1: BAT0 charge: 15.4 Wh (100.0%) condition: 15.4/37.4 Wh (41.1%)
volts: 8.1 min: 7.4 model: LGC L13L4E61 type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i3-4030U bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1892 high: 1896 min/max: 800/1900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1896 2: 1880 3: 1896
4: 1896 bogomips: 15164
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
Device-2: Realtek Lenovo EasyCamera type: USB driver: uvcvideo
bus-ID: 2-4:4 chip-ID: 0bda:579c class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1490 built: 2013 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel HD Graphics 4400 (HSW
GT2) direct-render: Yes
Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:08b4 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 2-6:6 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Local Storage: total: 473.22 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD5000LPCX-24C6HT0 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A02
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Edge
size: 7.45 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.26 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.74 GiB used: 986.8 MiB (25.8%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 186 Uptime: 1h 29m wakeups: 1 Memory: 3.74 GiB
used: 2.63 GiB (70.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1821
libs: 519 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26

Try installing the regular (non-gaming) Dr460nized ISO, then install the needed gaming packages afterward with Garuda Gamer.

So, should I download the KDE Dr460nized or Gnome also can?

There are two versions of the Dr460nized ISO. One is pre-loaded with games and stuff (the one you are trying to install) and one is not. I was suggesting installing the other Dr460nized ISO to see if the installation succeeds, then add the games and stuff afterward.

Of course you can install Gnome if you wish, but it is a lot different.


Sure, I am installing it. Do I have to edit the partition now? As now the partition is empty...

You don't have to manually format the partitions, the installer will take care of that for you. Just identify the disk you want to install on and the installer does the rest.


Alright, thanks. I want to erase the disk to Garuda. I will try to boot it soon. Hopefully can be success by today. :grin:

I just tried but the installation failed.

It shows:

Installation failed

Garuda Linux Soaring has not been installed on your computer.
The error message was: Boost. Python error in job "mount"..

How did you create the installation USB?
I suggest retrying with Ventoy, if not yet used.
Check also the iso file checksum, just in case.


I created with terminal

sudo mkfs.vfat /dev/sdb -I

sudo dd if=(garuda-iso-file).iso of=/dev/sdb status="progress"

I downloaded Ventoy and install Garuda from usb

But still unable to install.

First, go to 3% mount partition, then suddenly gone all windows.

Second time, 1% failed again

Create a new partition table (type: msdos) on ‘/dev/sda’

Job: Create new partition table on device ‘/dev/sda’

Command: sfdisk --wipe=always /dev/sda

Now all partition are gone. Empty laptop

Did you use calamares?

From where you got these messages?

It seems your hardware reach not the minimum specs Grauda needs

Try Garuda Xfce and start calamares from terminal.

sudo -E calamares -D8

Post the log if installalation aso fail.

1 Like

I tried download xfce, failed again

Create a new partition (465.46 GiB, btrfs) on ‘/dev/sda’

Job: Create new partition on device ‘/dev/sda’

Command: sfdisk --force --append /dev/sda

Command: sfdisk --list --output Device,UUID /dev/sda

Job: Set the label on partition ‘/dev/sda2’ to "root"

Command: sfdisk --part-label /dev/sda 2 root

Job: Create file system ‘btrfs’ on partition ‘/dev/sda2’

Command: mkfs.btrfs --force /dev/sda2

I tried to install a few times again.

It run a while then suddenly lock screen and reopen the screen, every window disappeared.

Tried install several times again.
Still failed. Now is like this :Boost. python error in job "mount".

<div><strong>Command '['btrfs', 'subvolume', 'create', '/tmp/calamares-root-ado2rzvw/@']' returned non-zero exit status 1.</strong></div><div>None</div><div><br/>Traceback:</div><div><pre>File &quot;/usr/lib/calamares/modules/mount/;, line 363, in run

Failed again :sob: anyone can help to guide?

Create a new partition table (type: gpt) on ‘/dev/sda’

Job: Create new partition table on device ‘/dev/sda’

Command: sfdisk --wipe=always /dev/sda

Try booting to the live environment in UEFI mode (not BIOS mode). It should be a separate boot option you can choose before the ISO starts up.

1 Like

Im trying to install and i also get this error.

Just partitioning failed notreally anny more info ( the root partition)
i am keeping my old home folder

Post to the thread from the live environment:

lsblk -f
sudo parted -l

If you are using Ventoy make sure it is up to date (if you are not sure, make a new one).

Disable CSM/legacy support in the BIOS if you have it.