Garuda grub not detecting windows

Hi, I'm doing a fresh install of Garuda, windows being my other OS, installed on a separate drive. After the installation grub isn't detecting windows at all. I tried updating grub, updating the system, grub mkconfig, still couldn't get it. looked through the forum and found other post saying that the installer should handle it on it's own so i figured maybe i screwed up the installation itself. Re-installed as per directions in that thread - that instructions being to install on a clean, separate drive, creating master boot on that same drive as Garuda, but still no luck. Any ideas as to why that could be and how i could solve this ?

might be because os-prober is disabled? :eyes:

but it is enabled by default on garuda :thinking:

and kindly provide output of inxi -Faz in a proper format

5 Likes

Maybe it could help providing some more information, like the output of fdisk -l and lsblk -o name,type,fstype,size,uuid,mountpoint

2 Likes

My fdisk (nvme0n1p1 is windows EFI partition) :

Disk /dev/nvme0n1: 465,76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: PNY CS3040 500GB SSD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 069B5E03-0D5E-4D40-B3C5-09D221BDE08D

Device             Start       End   Sectors  Size Type
/dev/nvme0n1p1      2048    206847    204800  100M EFI System
/dev/nvme0n1p2    206848    239615     32768   16M Microsoft reserved
/dev/nvme0n1p3    239616 975492728 975253113  465G Microsoft basic data
/dev/nvme0n1p4 975493120 976769023   1275904  623M Windows recovery environment


Disk /dev/sda: 931,51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: Samsung SSD 870
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 45844D11-7577-44F4-8DE4-EF09DC24C1E6

Device     Start        End    Sectors   Size Type
/dev/sda1     34      32767      32734    16M Microsoft reserved
/dev/sda2  32768 1953521663 1953488896 931,5G Microsoft basic data


Disk /dev/sdb: 223,57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: CT240BX500SSD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1f742377

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1  *     2048 468857024 468854977 223,6G 83 Linux


Disk /dev/zram0: 15,61 GiB, 16757293056 bytes, 4091136 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

and disks info:

NAME        TYPE FSTYPE   SIZE UUID                                 MOUNTPOINT
sda         disk        931,5G
├─sda1      part           16M
└─sda2      part ntfs   931,5G 205E58C95E5898FC
sdb         disk        223,6G
└─sdb1      part btrfs  223,6G 90f207a9-9c4c-42fe-ba5d-e6ee64ed5e60 /var/log
zram0       disk         15,6G                                      [SWAP]
nvme0n1     disk        465,8G
├─nvme0n1p1 part vfat     100M 7CE9-A0E3
├─nvme0n1p2 part           16M
├─nvme0n1p3 part ntfs     465G B8A2EA3DA2EA002C
└─nvme0n1p4 part ntfs     623M 6C8447F78447C276

my inxi:

System:    Kernel: 5.15.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=90f207a9-9c4c-42fe-ba5d-e6ee64ed5e60 rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop System: Gigabyte product: B550 AORUS ELITE V2 v: N/A serial: <filter>
Mobo: Gigabyte model: B550 AORUS ELITE V2 v: x.x serial: <filter> BIOS: American Megatrends v: F10 date: 09/18/2020
Battery:   ID-1: hidpp_battery_0 charge: 90% condition: N/A volts: 4.1 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A serial: <filter> status: Discharging
CPU:       Info: 8-Core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25) model-id: 21 (33)
stepping: 0 microcode: A201006 cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 121372
Speed: 3464 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 3464 2: 3553 3: 3587 4: 3585 5: 3579
6: 3420 7: 3579 8: 3592 9: 3585 10: 3592 11: 3582 12: 3610 13: 3593 14: 3594 15: 3587 16: 3583
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA vendor: Gigabyte driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 0a:00.0
chip-ID: 10de:2489 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.7x13.5") s-diag: 692mm (27.3")
Monitor-1: HDMI-0 res: 2560x1440 hz: 144 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA GA104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 0a:00.1
chip-ID: 10de:228b class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: SteelSeries ApS SteelSeries GameDAC type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4.2:6
chip-ID: 1038:1283 class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.15.3-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl v: kernel modules: bcma bus-ID: 05:00.0
chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: down mac: <filter>
Drives:    Local Storage: total: 1.58 TiB used: 14.85 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: PNY model: CS3040 500GB SSD size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: CS304130 temp: 31.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 052 scheme: MBR
Partition: ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 14.85 GiB (6.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 14.85 GiB (6.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 14.85 GiB (6.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 14.85 GiB (6.6%) fs: btrfs dev: /dev/sdb1
maj-min: 8:17
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.61 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 27.0 C mobo: 27.0 C gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 362 Uptime: 1m wakeups: 2 Memory: 15.61 GiB used: 2.19 GiB (14.1%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 Packages: pacman: 1324 lib: 324 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.08

/dev/nvme0n1 (windows) Is GPT with EFI system partition, which is ok.
/dev/sdb has an MBR, so this is wrong.
I think you should reinstall Garuda in EFI mode.

2 Likes

that's what i was considering to be potentially wrong but honestly I'm not that confident with tinkering with this stuff that's why i created a mbr on the same disk as garuda during installation as per recommendation in another closed thread. I suppose that's what I did wrong ?

Alright i'll give it a go. Any other specifics during installation that i should consider ?

As far as I know the easiest solution would be open gparted/kde partition manager from live disk and format the garuda disk with gpt partition table and calameres should do the rest.

2 Likes

The easiest solution IMO would be to deep six Windows. This is not a Windows support forum and dual booting Windows is not officially supported by Garuda.

I just thought it bares repeating this occasionally. As more of these threads appear on the forum the more readers assume it's our job to get Windows working for them. It's not our job to support Windows, and I put it to you that if you're not up to fixing your own issues with Multi-booting then you shouldn't have gone there in the first place.

Perhaps you shouldn't have altered your system if you don't have the technical knowledge to fix it. Would you disassemble your cars engine and then expect others to put it back together for free? If you didn't have the skillset to fix it yourself, then you should not have tampered with your system so drastically.

Dual booting is not to be taken lightly. If you aren't very competent in resolving these types of problems yourself then maybe you should just have left well enough alone. I'm on the borderline of locking this thread because it is a waste of forum support resources to expend time resolving Windows issues. Time to put on your big boy boots and do more research yourself IMO. There are countless threads on this topic out there, because countless people have messed their system dual booting. Its time to do more research on your own IMO.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.