Garuda GPU problem

Hello, I have installed Garuda on my laptop, for now, dual booting with Windows. I tried to play games but I have much fewer fps than in Windows. I think it can be because having GPU not properly configured. I don't know for sure. When I start the game CPU is pretty idle around 10% and the game is running at poor FPS. I don't know how to check GPU. Also, nvtop writes to me: "No GPU to monitor"

System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=357ac198-66a4-4ac8-abe6-5e79af2f4a8d rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81LK v: IdeaPad L340-15IRH Gaming
serial: <superuser required> Chassis: type: 10 v: IdeaPad L340-15IRH Gaming
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN
serial: <superuser required> UEFI: LENOVO v: BGCN33WW date: 11/24/2020
Battery:
ID-1: BAT0 charge: 19.4 Wh (52.7%) condition: 36.8/45.0 Wh (81.7%)
volts: 11.3 min: 11.5 model: Celxpert L18C3PF1 type: Li-poly
serial: <filter> status: discharging cycles: 502
CPU:
Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1800 high: 2400 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 2400 3: 2400
4: 800 5: 2400 6: 2400 7: 800 8: 2400 bogomips: 38400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:3e9b
class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q] vendor: Lenovo
driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-07) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c91
class-ID: 0300
Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:2
chip-ID: 5986:2130 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,intel,nouveau,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0700 built: 2016 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa
22.1.6 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb9
class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 07:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlp7s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 35.97 GiB (7.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8L
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: L02C
temp: 33.9 C scheme: GPT
Partition:
ID-1: / raw-size: 168.86 GiB size: 168.86 GiB (100.00%) used: 35.94 GiB
(21.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 31 MiB
(12.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 168.86 GiB size: 168.86 GiB (100.00%) used: 35.94
GiB (21.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 168.86 GiB size: 168.86 GiB (100.00%) used: 35.94
GiB (21.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 168.86 GiB size: 168.86 GiB (100.00%) used: 35.94
GiB (21.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.64 GiB used: 652.5 MiB (8.3%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.0 C pch: 50.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 268 Uptime: 31m wakeups: 37265 Memory: 7.64 GiB used: 2.92 GiB
(38.1%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1435 lib: 435 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-18
Last full system update: 2022-08-18 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome to the forum

First i would reboot

Then check again

3 Likes

What I rebooted today multiple times but ok
Edit: okay rebooted

Which game? Your game might be using integrated graphics instead of Nvidia, especially if your game uses OpenGL instead of Vulkan.
If this is a Steam game, change game launch parameters to

prime-run %command%

If it is something else, run your game in a terminal emulator like

prime-run /path/to/program
4 Likes

I tried CSGO and Tlauncher: Minecraft. Okay, let me try

Maybe it helped. 40 fps in CSGO, I had like 27. But still in Windows I have more than 70. Is it possible to fix even more?

First plug in your laptop. Then enable all performance options on Garuda Assistant.

2 Likes

Sure I plugged it before playing but I didn't install all performance tweaks. But even after installation it didn't increase my fps

I really hate to say it, but linux is not known for outperforming windows through proton compatibility layer. Are you running it on the newest compatibility tool? If so, maybe have you tried glorious eggroll's release?

Is thermald installed?

2 Likes

I really hate to say it, but linux is not known for outperforming windows through proton compatibility layer.

Both CSGO and Minecraft are Linux native and are not meant to be run in Wine / Proton.

3 Likes

Disable compositor before playing with Shift+Alt+F12 and use gamemode. For Steam you do

gamemoderun prime-run %command%

For minecraft:

gamemoderun prime-run /usr/bin/minecraft-launcher
3 Likes

It isn't. I have just installed performance tweaks and uninstalled all power-saving tweaks, then rebooted.

Could you try installing it and enabling the thermald service to see if that makes a difference?

sudo pacman -S thermald
sudo systemctl enable --now thermald

You might want to try rebooting as well.

1 Like

Still no difference, also my fps are the same with and without the charger plugged in.

Did it right now with reboot but it doesn't seem to help, they are pretty much the same. Can it be somewhere locked to max fps?

Edit: in CSGO it isn't locked.