Garuda-Gnome hangs on Accounts Servce boot

I have Garuda Linux with Gnome installed on a Thinkpad T520. It has been running fine for the past month or so. I kept it up to date, and I have plenty of snapper snapshots. The machine has 16Gb RAM, plenty of SSD disk space using BTRFS. It is on the older side but hasn't had any problems running Garuda before (I am running Garuda on several newer machines and I have never seen this problem, btw).

I rebooted my machine a few days ago, and now it hangs on bootup. By that I mean, if I choose regular Garuda linux, I get a grey screen with several white dots which I've never seen before. After a little while I'm told I'm in emergency mode, but I can't type in my password and nothing changes no matter what I type.

(By the way I have no idea which of the two options to pick but both give the same result)

If I choose a snapshot only a few hours earlier, I get the same thing. Going back several days, I see the spinning Garuda logo and then a black screen. No matter how many days I go back I get the same thing. Here is what the console looks like if I press F2 during bootup from a days old snapshot. It apparently hangs on "Starting Accounts Service".

I have only tried snapper snapshots. I think I see some Timeshift snapshots from many weeks ago, but I'm a little reluctant to try snapshots that old.

Does anyone have any ideas about what I can do? I'm a little bit of a Linux noobie with about 6 months under my belt, but happy to dig in and figure this out.

Wasn't it that you should delete all TS snapshots before switching to snapper?

Boot with a live ISO, garuda-chroot into the system, backup important data and clean up the snapshots with the Garuda wizard (maybe install TS and delete the snaps) and also make a Btrfs balance. Then do a system update at the same time.

Always use forum search first, please.

There is link to chroot too.

1 Like

Thank you! I did try a search for "account services" but couldn't find anything.

Trying startx helped me to boot into one of the older snapshots successfully! Thank you. The pacman command didn't work because the database was locked. But it didn't matter because I was able to reboot successfully after restoring a few day old snapshot, then after I rebooted I updated everything.

I can't seem to find "garuda wizard". Is that the Assistant? Because in Assistant, under the "snapper" tab I don't actually see any of the Timeshift snapshots to delete.