Garuda Gaming Dragonized not connecting to wifi

I just installed garuda dragonizd gaming and it only connects to my phones wifi and not my router

I use a Dell Latitue 7390 PC

Given it will connect to wifi, why is this an issue with Garuda and not your router?

2 Likes

Restart your router and restart your system then try again...!!

3 Likes

First disconnect your hotspot.

:sweat_smile:

And welcome to forums.

2 Likes

becaue ot keeps asking me for the password to the router

Did it countles nuber of times

Diconnect??? How do you mean?

Try:-
Garuda Network Assistant -> Restart Wi-Fi module…

2 Likes

I mean turn off your mobile hotspot and then try.
You can't connect to 2 networks at same time :sweat_smile:

3 Likes

But I disconnected from my mobile hotspot. Before trying to connect to my router

Try disabling Network Manager's "MAC Address randomization" there is a toggle for that setting in Garuda's network assistant.

Also changing the connection settings for your wifi in Network Manager can help. Allowing all users to connect can sometimes resolve this issue.

Also are you using auto-login to your desktop?

4 Likes

No i don't think i use that

It didn't work it keeps asking me to input password over and over again

Did not work
It keeps asking me to input password

Well don't do that then.

You did not respond to my other suggestions, considering they were simply a matter of toggling on/off a check mark I'm not sure whyt attempting my suggestions was so difficult .The last several hours since you replied I might have thought sufficient to toggle a check mark or two.

Regardless here's some more detailed instructions if your confused:

Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot both your router and computer once you've also done:

Please don't expect further help until you've complied with the previous suggestions.

What you asked me to do didn't work, but i fixed the issue though. thanks for time. I appreciate .

Cool, you fixed it. And how?
We would appreciate if you teach us.

1 Like

Will do that

By all means, educate us.

Step One 1: Search for "Advanced Network Configuration".

Step Two: Select Prefered Wifi Network and click on settingds icon below:

Step Three: Band Might might be in automatic, so select prefered band (2.4GHz || 5GHz):

then restart PC and connect again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.