Garuda Gamer not installing software

I am testing out Garuda linux in a vm before I consider installing it on my main system. The system so far has been fairly snappy but the one thing that isn't working is the Garuda Gamer application. Everytime I select an application in there and click apply nothing happens and then it unselects the applications I have selected. Launching Garuda Gamer from a terminal shows no output or error when clicking apply and it also doesn't work as sudo.

I read another post on here that had the same problem which was solved by updating and rebooting. However I have updated my mirrorlist, updated the system twice and rebooted multiple times and it is still not working.

inxi -Faz output

System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=718ee23e-344f-416e-a871-274389ca3803
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial: <superuser required>
Chassis: Oracle Corporation type: 1 serial: <superuser required>
Mobo: Oracle model: VirtualBox v: 1.2 serial: <superuser required> BIOS: innotek v: VirtualBox
date: 12/01/2006
Battery:   ID-1: BAT0 charge: 25.5 Wh (51.0%) condition: 50.0/50.0 Wh (100.0%) volts: 10.0 min: 10.0
model: innotek 1 type: Unknown serial: N/A status: Discharging
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MCP arch: Amber/Kaby Lake note: check
family: 6 model-id: 8E (142) stepping: 9 microcode: N/A cache: L1: 128 KiB L2: 512 KiB
L3: 3 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 10848
Speed: 2712 MHz min/max: N/A Core speeds (MHz): 1: 2712 2: 2712
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT Host state unknown
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling
Type: srbds status: Unknown: Dependent on hypervisor status
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.19.0.0 bus-ID: 00:02.0 chip-ID: 15ad:0405
class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: vmware
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x997 s-dpi: 96 s-size: 508x263mm (20.0x10.4") s-diag: 572mm (22.5")
Monitor-1: Virtual1 res: 1920x997 hz: 60
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 v: kernel bus-ID: 00:05.0
chip-ID: 8086:2415 class-ID: 0401
Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020 bus-ID: 00:03.0
chip-ID: 8086:100e class-ID: 0200
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus v: N/A
modules: i2c_piix4 port: N/A bus-ID: 00:07.0 chip-ID: 8086:7113 class-ID: 0680
Drives:    Local Storage: total: 30.8 GiB used: 10.48 GiB (34.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: VirtualBox model: VBOX HARDDISK size: 30.8 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1.0 scheme: MBR
Partition: ID-1: / raw-size: 30.79 GiB size: 30.79 GiB (100.00%) used: 10.48 GiB (34.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 30.79 GiB size: 30.79 GiB (100.00%) used: 10.48 GiB (34.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 30.79 GiB size: 30.79 GiB (100.00%) used: 10.48 GiB (34.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 30.79 GiB size: 30.79 GiB (100.00%) used: 10.48 GiB (34.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.83 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 179 Uptime: 0m wakeups: 56 Memory: 3.83 GiB used: 1003.4 MiB (25.6%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1166 lib: 291 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

I could obviously just get the software I want through the terminal, but I would think a "just works" distro would have a working GUI frontend for doing just that.

There's a reason we say you shouldn't use virtual machines.
I'll fix this issue, but the issue only exists on virtualbox in the first place...

4 Likes

Hi there, welcome.
This is a VirtualBox installation, and installation in Virtual Machines is not supported officially, because Garuda is optimized for performance and to work on bare metal.
Of course, there are many of us using VM's, but it doesn't necessarily mean that every functionality should work out of the box.

This could be not the cause of your issue, of course. Just a general heads-up...

From download page recommendations:

5 Likes

Have you tried installing the same game from terminal or octopi

Ok, just making sure that this will work when I decide to install it on hardware. Do you mind explaining what the issue is on virtualbox that stops the gamer assistant from working? As far as I can tell everything else seems to be working fine.

yes i had the same problem as well, i gave up on using the setup assistant..first thing i do is goto octopi run updates and install pamac reflector and alacrity fail on me every time.since i started doing this ive had no issues at all.

you should really use bare metal though...even if its an old hard drive you have laying around. load times might be slow but at least everything will work as it should. performance and VM are two different things

Fixed version of garuda-gamer pushed, will be applied the next time you update your system.

Alacritty requires a certain minimum OpenGL version that simply just isn't provided by the VirtualBox driver.

7 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.