Garuda failing to reboot after install (hangs at Booting 'Garuda Linux')

~TLDR~ I reinstalled Garuda, ran update, rebooted, and it hangs at " Booting 'Garuda Linux': Loading Linux linux-zen... Loading inital ramdisk..." Now I don't know what to do.

So I started having an issue with games having become a slideshow after installing emacs. I know it was emacs, but I don't know why it was effecting my games. After narrowing it down to emacs, I confirmed it by snapping back to before the install. Games ran beautifully again.

So, I decided to do a little testing and see that it actually was emacs. Installed emacs again, and no I'm not using the version that comes in the setup assistant because I can't find out what version it is, and the whole point is to run doom emacs, which apparently only runs on up to v28.x.x, so I've tried several different versions, and received the same results everytime....install emacs, go to Steam and run a game, game runs like a slideshow. Snap back to before emacs, run game...runs perfectly. I'm not skilled enough to figure out why, though. Eventually, though, after doing this a few times the games just started running like sh*t even after snapping back.

So I decided to reinstall, because I don't even know how to condense all that into a logical query, and it just got worse. Reinstalled fine, but after updating, and installing everything I wanted from the setup assistant, I did a reboot, and it goes into the boot menu, I just let it auto-do it's thing, but it hangs at the black screen (right between boot menu and login screen) that says

Booting 'Garuda Linux'
Loading Linux linux-zen ...
Loading initial ramdisk ...

...and it just sits there. I just wanted to spend an evening playing games after a long week at work. :disappointed_relieved:

I would've included the garuda-inxi, but I can't get back into the OS. I can, but I know from experience now (because I've reinstalled it about 8 times today, all with the same result) that if I reboot and try to boot from an earlier image that it's going to break the grub, because it updated along with everything else. Unless there's a way to fix it once I'm in. I don't know what to do. Any ideas? TIA.

1 Like

You could also test the solution below.
TL:DR there has been recently an issue, probably in relation to plymouth-git and sddm updates.
The solution is to either remove splash boot parameter or install Plymouth.


See, I found that and wasn't sure 1. that it was actually my problem, and 2. WTF they were talking about by "Ctrl+Alt+F2 to open a text console. I tried that at every step of the boot attempt and it does nothing. I'm not sure where I'm supposed to bring this console up. I can "C" to open grub, but I'm pretty sure they don't mean that.

Heh...would you be willing to walk me through how to do it? I'm that new. Thanks, btw, to both of you for replying.

It's already described there ("when you are in the GRUB line..."). I couldn't do it more detailed... :blush: Believe me, it has been applied by many users. Not difficult at all.


No, I mean I don't know anything about grub. Like, when you say in there

"When you are in the line you want to use"

I don't know what you're talking about. I don't know how to get to a line that I would want to use. I've got about 50 total hours in Linux, and that's broken up over the last month. Hell, I'm not even sure where to find good info, because old info doesn't seem to hold up well over the years.

Grub is the menu normally shown after you switch on, showing Garuda, Advanced options, other operating systems, if used...
Usually the focus is on the first line, Garuda, so just press button E and continue.
You have to do this within a few seconds, or it will proceed and hang
Hope this helps ...

1 Like

OH! Well, unfortunately that was a lot of "Hey, look how stupid I am" for nothing. Removed splash, ctrl+x, and it goes right back to the same hang.

Any idea what the other one that ..SGS shared? It's the same thing, I guess it's expected to know that part, but I have no idea what they mean by Ctrl+Alt+F2 to open a text console", and that's all it says about that? That doesn't even open a terminal (that I know of) in the actual desktop, does it?

Disregard that I figured it out....apparently my kb just wasn't responding, but I just got it to a textual login.


Okay, so I got into a text console, I'm not sure if I did this exactly correctly because I'm doing the troubleshooting on my laptop and the trouble is on my desktop. No copy/paste. So I tried

sudo reflector -a6 -f5 --save /etc/pacman.d/mirrorlist

but I did it like "mirrorlist garuda-update", and that threw an unrecognized error at garuda-update. So I retried but did a shift+enter after "mirrolist" and then put the garuda-update, and that tried to run but threw this error....

WARNING: failed to rate http(s) download ( Download timed out after 5 second(s)

And it just keeps going like that trying different mirrors, I assume, and just timing out. So I tried just the top line of that command without garuda-update, and it still throws the same "WARNING" error.

Well this is just getting more exciting! Any ideas? :grin:

Is there possibly a different way to run that sudo reflector -a6... command? Like a different command for the same effect? I know that can be a thing sometimes...a lot of times.

Try just

1 Like

I did already, it updated but didn't fix anything.

Ctrl+Alt+F2 open TTY (F1-F7) here TTY 2


Thanks, yeah I figured it out eventually, it was just that my kb wasn't responding after it hit the hang up screen, but only sometimes.

Anyone else have any ideas? I tried to find more info last night, but like I said earlier, I don't know enough about what's going on to even form a proper google query. Trying to google the lines it's stuck at just brings me back to what's shared here already. I'm still just staring at a text console that I have no idea what to do with other than run an update once in a while and hope something changes, and then reboot over and over and over until my kb decides to open the console again.

I'm having the exact same issue. Tried 'update' and 'garuda-update' in terminal and get the same black screen after rebooting. I can easily get back into the computer back tabbing down to 'Garuda Snapshots' when Grub loads and just booting into the one before updating, luckily, but I still need to be able to update my software. I'm convinced there's a bad update out there, but the trouble is finding it.

1 Like

Right, see and that's the problem, I haven't tried with this particular install (I reinstalle like 8 times yesterday just trying to see what I could get it to do) but last time I tried to revert one of these snapshots it broke my grub, and rebooting just bricked the system.

I had same problem with Zen kernel update. I reinstalled the mainline kernel and there was no issue after the update.
just my 2 cents

1 Like

This fixed it for me. I tried changing Plymouth-Git to the normal ver first and after that didnt work I went this Splash route. Removing 'splash' let me boot just fine after an update.

1 Like

Yeah, I had tried that initially, and no go for me. However....

I wouldn't necessarily call it a "solution" but after reinstalling again, and grabbing the mainline kernel, myself, it has successfully rebooted. I immediately came to report, gonna finish setup assistant, and see what happens then. Will report back if it goes wrong.

Well, after installing everything and rebooting a few times, things seem to be "working as intended" :laughing: :laughing: I can finally do some gaming.

Many thanks to everyone that offered help! I really appreciate it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.