Garuda dual boot with Windows 10 - GRUB

I am attempting to dual boot Windows 10 and Garuda Linux. When I first tried installing Garuda Linux I got the error that the legacy version failed to install:

The bootloader could not be installed. The installation command <pre>grub-install --target=i386-pc --recheck --force /dev/sda</pre> returned error code 1.

There was no UEFI option for me to select as shown in the picture below, so how do I install the UEFI version of the bootloader? Thanks


Was "Master Boot Record.." the only option in the dropdown list "Boot loader location"?
Also, was the BIOS set in UEFI mode?


There was a “System partition /“ option but nothing that mentioned UEFI explicitly.

I might need to double check my BIOS is in UEFI mode but I think it’s in UEFI mode by default.

BIOS is set to UEFI boot, there was a “System Partition /“ option but nothing else. There is no mention of the word UEFI during installation at all.

You should make sure you do have an available EFI system partition.
I cannot see clearly the picture from the mobile, but it looked like the first one was that. Maybe you can recheck with KDE partition manager.
Also make sure that fast boot and secure boot are disabled in the BIOS.

There’s an EFI partition in /dev/sda1

"BIOS" Next to "Select storage device" indicates you have booted in CSM mode. Look for something like "CSM mode / Legacy Mode" in your UEFI, disable it, check if Windows still boots just in case and proceed with Garuda installation.
You should see UEFI next to "Select storage device"


Ohhhh, I had to have CSM disabled. Gotcha!

Yes, that's what I meant with uefi mode

1 Like

Disabling CSM fixed the issue! Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.