Garuda Dragonized KDE seems really slow

Hi, I am finding a new installation of Garuda really slow, which seems odd given my machine's specs (inxi output at the bottom). Typing in this dialog is I see the output a few characters behind the keys I'm pressing and everything else seems to be lagging too. As I type this I can see that my CPU isn't going above 20% and averages around 2% and free tells me that I have 25Gib of ram available, and y network is hardly being used.

Could this be because I'm running on integrated graphics -- kde is sometimes a bit heavy? Is Chrome just behaving badly and messing me up? Tbh, I have just started using Fire Dragon and the typing seems to be less laggy, but I can't use this for work as I need profile support from Chrome (plus, my client uses Chrome so everything has to work in Chrome). Typing also appears laggy in slack and teams.

In case its relevant, I installed most of these packages using yay, and I have been using gnu/linux professionally since it was first released.

Here's the output from top:

top - 11:42:34 up 13:18,  1 user,  load average: 0.84, 0.98, 0.88
Tasks: 356 total,   1 running, 355 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.9 us,  0.5 sy,  0.0 ni, 97.4 id,  0.8 wa,  0.3 hi,  0.1 si,  0.0 st
MiB Mem :  39742.5 total,  12688.9 free,   7027.8 used,  20025.8 buff/cache
MiB Swap:  39811.0 total,  39808.7 free,      2.2 used.  26892.4 avail Mem 

PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                                                                                                                
22416 root      10 -10  832472 247060 158960 S   2.0   0.6   8:27.57 Xorg                                                                                                                                                                   
23375 bryan     10 -10 3709264 235960 116924 S   2.0   0.6  12:33.02 kwin_x11                                                                                                                                                               
158734 bryan     25   5   24.4g 259436 104424 S   2.0   0.6  12:17.57 chrome                                                                                                                                                                 
206842 bryan     19  -1 3441852 422088 157420 S   2.0   1.0   9:34.73 zoom                                                                                                                                                                   
168195 bryan     17  -3 1385860 152692 125108 S   1.7   0.4   0:20.47 konsole                                                                                                                                                                
24270 bryan     20   0 7061956 776344 193092 S   1.3   1.9   6:09.07 latte-dock                                                                                                                                                             
209223 bryan     19  -1  776556 354244 301788 S   1.3   0.9   7:30.42 steam                                                                                                                                                                  
553196 bryan     20   0   28.4g 183332 111184 S   1.3   0.5   0:25.46 chrome                                                                                                                                                                 
43891 bryan     20   0   16.6g 356004 180204 S   1.0   0.9   9:16.52 chrome                                                                                                                                                                 
43933 bryan     20   0   17.0g 194104 128416 S   1.0   0.5   9:44.25 chrome                                                                                                                                                                 
43934 bryan     20   0   16.3g 119264  86172 S   1.0   0.3   3:29.85 chrome                                                                                                                                                                 
550479 bryan     20   0  246284  34288  29816 S   1.0   0.1   0:05.54 ksystemstats                                                                                                                                                           
524898 root      20   0       0      0      0 I   0.7   0.0   0:02.51 kworker/0:1-events                                                                                                                                                     
24273 bryan     39  19  377448  60936  51452 S   0.3   0.1   0:04.53 kdeconnectd                                                                                                                                                            
24382 bryan     20   0   15708  14036   2136 S   0.3   0.0   1:46.08 ksysguardd                                                                                                                                                             
54857 bryan     20   0   24.4g 286132  91388 S   0.3   0.7  10:24.39 slack                                                                                                                                                                  
521689 root      20   0       0      0      0 I   0.3   0.0   0:04.22 kworker/u24:17-phy0                                                                                                                                                    
545189 root      20   0       0      0      0 I   0.3   0.0   0:01.09 kworker/u24:9-i915                                                                                                                                                     
551488 root      20   0       0      0      0 I   0.3   0.0   0:00.65 kworker/u24:6-btrfs-endio-write                                                                                                                                        
1 root      20   0  166776  12072   8532 S   0.0   0.0   0:02.52 systemd                                       

As you might see, I'm running zoom, chrome, steam, teams, and slack, along with chrome. I need to use this machine for Development and DevOps but as it stands performance is so low I'm going to have to abandon it soon. Please help as I don't want to do that.

I've tried closing apps, to see if anything is causing the issue, but nothing seems to help.

╭─[email protected] in ~/Downloads took 3s
╰─λ inxi -Faz
System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5fb5df04-c979-42d5-b0c1-2d08720eb02f rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: Dell model: 02MJVY v: A00 serial: <filter> UEFI: Dell v: 1.20.0 date: 06/07/2021
Battery:   ID-1: BAT0 charge: 49.3 Wh (100.0%) condition: 49.3/97.0 Wh (50.8%) volts: 12.6 min: 11.4 model: SMP DELL GPM0365
type: Li-ion serial: <filter> status: Full
Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter> charge: 45% rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 9 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52799
Speed: 1000 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1000 2: 1000 3: 1000 4: 1000 5: 1000 6: 1000 7: 1000
8: 1000 9: 1000 10: 1000 11: 1000 12: 1000
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel bus-ID: 0000:00:02.0
chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nouveau v: kernel bus-ID: 0000:01:00.0
chip-ID: 10de:1c8c class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-12:5 chip-ID: 0c45:671d class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9")
Monitor-1: eDP1 res: 3840x2160 hz: 60 dpi: 287 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Rivet Networks driver: ath10k_pci
v: kernel bus-ID: 0000:3b:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp59s0 state: up mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 0cf3:e300
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: intel_nvme_remap v: N/A port: 4060
bus-ID: 0000:00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:    Local Storage: total: 476.94 GiB used: 16.17 GiB (3.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC401 NVMe 512GB size: 476.94 GiB block-size:
physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 80003E00 temp: 35.9 C scheme: GPT
Partition: ID-1: / raw-size: 122.64 GiB size: 122.64 GiB (100.00%) used: 16.05 GiB (13.1%) fs: btrfs dev: /dev/nvme0n1p4
maj-min: 259:4
ID-2: /boot/efi raw-size: 650 MiB size: 646 MiB (99.38%) used: 124.2 MiB (19.2%) fs: vfat dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 122.64 GiB size: 122.64 GiB (100.00%) used: 16.05 GiB (13.1%) fs: btrfs dev: /dev/nvme0n1p4
maj-min: 259:4
ID-4: /var/log raw-size: 122.64 GiB size: 122.64 GiB (100.00%) used: 16.05 GiB (13.1%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 122.64 GiB size: 122.64 GiB (100.00%) used: 16.05 GiB (13.1%) fs: btrfs
dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 69 MiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: swap-2 type: zram size: 38.81 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A gpu: nouveau temp: 55.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 367 Uptime: 13h 27m wakeups: 31142 Memory: 38.81 GiB used: 13.52 GiB (34.8%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1204 lib: 295 Shell: Bash v: 5.1.8
running-in: konsole inxi: 3.3.08

Welcome

Try installing the nvidia driver and test see if that helps

1 Like

Thanks. I'll give it a go too see if its the integrated graphics causing the problem, but it's not a long-term solution as it hammers my machine's cooling. I was stupid enough to buy a Dell XPS 9570 and have regretted it ever since. If I use the nvidia card my fans spin up like a hovercraft and the machine overheats and throttles within minutes.

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

I just edit your post.

1 Like

Does the same thing occur from the live disk?

Have you tested alternate kernels yet?

I would suggest testing at least linux, linux-lts, linux-mainline, and linux-hardened.

I would also suggest testing a fresh install, and not installing any extra software packages until after your system installation is complete. Check your performance with only a base install (no extra packages). Let Baloo finish indexing your system (check baloo's usage stats). If your system performance is reasonable with a base install then assess your system for software conflicts. Once Baloo is done indexing start slowly selectively installing the software you normally use. Reboot after each new package is installed. Use your system for an hour or so after each install to assess for slowdowns. Work your way methodically through all the extra programs you use to discover if any particular software package might be responsible for negatively impacting your performance.

Good luck and welcome to Garuda.

1 Like

Not sure what that means. It has beat out XFCE in the resources category as one of the lightest.

It is probably the integrated graphics. You also said you installed everything via yay. Did you install Garuda's Welcome app? In there there are options for Performance that might help.

Did you tried to stop baloo ? It's a cpu hog on my machine and I had to disable it.

try: balooctl status
balooctl stop
balooctl disable

Regards,
BT

2 Likes

It is also takes up large chucks of drive space. I noticed mine got up to over 10gig, had to blow it out.

That's a weird thing. I use the NVidia cards with several distros since the days the started releasing Linux drivers and have yet to see a high CPU load because of that.
My guess is that something loops (like restarting over and over) and maybe together with logging kills your performance.
If that's the case it's not so easy to pin it in htop or alike because the process may go away so quickly it won't account to a significant CPU load per instance but the shear number makes the difference. I've never used it myself but it seems like the command perf is what you could use to get an idea of what is abusing your CPUs (perf(1) - Linux manual page).

1 Like

As I just fixed it on my system: There is a bug related to the nvidia driver and kwin_x11. Although the logging shouldn't slow down a system as extremely as you described it sure does not hurt to stop it anyway.
The fix I applied is documented at Nvidia 495 log spam - full message queue / Kernel & Hardware / Arch Linux Forums