Garuda Dr460nized - problem with nvidia drivers

I want to switch from windows 10 to linux soon. I ran garuda linux on live usb with nvidia drivers but the system didn't boot, then i rebooted and booted with open source drivers and everything worked. The question is how do I fix the error with these drivers? I will add that a few days ago I installed Manjaro linux on a friend's laptop and the nvidia drivers worked.

My gear:

  • CPU: i3 12100F
  • GPU: GTX 1050ti
  • Gigabyte B660M DS3H DDR4 motherboard

Thanks in advance for your answer.

1 Like

Hello @Vejr0nPl nice to see your interest into Linux and in Garuda.

Well, although you might have driver issues you could start a Live version already. As it is stated in the posting template for this forum, you need to provide us the output of garuda-inxi.
Otherwise it will be more like an guess and hit or rather miss than a proper assistance.

Also note, for posting your inxi output you need to format it as seperate code by using

three tildes ~~~

on the start of the code output and tildes at the end, for a better
readability. Don't worry about the fact that the garuda-inxi gives you a ton of output. Simply copy paste it between the three tildes as just said and everyone can have a good read and will be able to help ya.

Welcome back to the forum, :+1:t3:

Bruce :shark:


It happens to me, even after the setup and installing the NVIDIA propietary drivers on desktop

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZEDGAMING_RAPTOR quiet
systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B660M DS3H DDR4 v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F6
date: 08/08/2022
Info: model: 12th Gen Intel Core i3-12100F bits: 64 type: MT MCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 5
microcode: 0x2C
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 799 high: 800 min/max: 800/5500 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 798 7: 800 8: 800 bogomips: 52838
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI
driver: nouveau v: kernel non-free: 530.xx+ status: current (as of 2023-03)
arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1
speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:1c82
class-ID: 0300 temp: 37.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: nouveau unloaded: modesetting
alternate: fbdev,nv,vesa dri: nouveau gpu: nouveau display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer SA240Y serial: <filter>
built: 2021 res: 1920x1080 hz: 75 dpi: 93 gamma: 1.2
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.3 Mesa 23.0.3 renderer: NV137 direct-render: Yes
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb9
class-ID: 0403
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-5:4 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 1012.46 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: SSD NM620 1TB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: V1.23 temp: 41.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Generic model: Flash Disk
size: 58.59 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> rev: 8.07 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 36.0 C mobo: N/A gpu: nouveau temp: 37.0 C
Fan Speeds (RPM): N/A
Processes: 243 Uptime: 3m wakeups: 0 Memory: 15.46 GiB
used: 2.35 GiB (15.2%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1821
libs: 519 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.16-1):
System install date:     2023-06-29
Last full system update: 2023-06-29 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:            garuda-live-keyring.service ~~~

As I write, I'm on a live USB but for now I'm not going to install the system on the disk because I have no way to copy the games and my internet is too slow to download everything from scratch.

And I will add that I write everything through google translate because I do not know English so well, so if something seemed incomprehensible to the poor, it was because of that.

I don't know why but the last 2 lines were written between two tildes even though I wrote it after them. Sorry, I must have done something wrong

A sample :slight_smile:
Post always your terminal in- and output as text like
Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1

I had the same problem with mine, it works just fine with the option to boot in with open source drivers, but the nvidia driver option kept hanging at start up.

@KalusVP @Novaflame try installing the LTS kernel and see if you are able to complete the Nvidia driver installation with that.

sudo pacman -S linux-lts linux-lts-headers

You can select the kernel from the advanced boot options in the Grub menu.

@Vejr0nPl I encourage you to complete the installation with open-source drivers, then install Nvidia drivers after the fact. From within the live environment it is impossible to make any changes that will help the driver installation succeed.


This is the install approach I've always taken with Garuda. I only ever use open-source drivers for the install and add nvidia after I've booted into a successfully installed Garuda.

Okay, I installed Garuda and I'm already updating the system. What should I do next to install drivers well?

You can use the HW assistant (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration) and autoinstall drivers.
Altrrnatively the same command executed by the HW assistant is:

sudo mhwd -a pci nonfree 0300
1 Like

such an error occurred:

Using "video-nvidia-dkms" configuration for device: 0000:01:00.0 (0300:10de:1c82) nVidia Corporation GP107 Display Controller [GeForce GTX 1050 Ti]
> Installing video-nvidia-dkms...
Acquiring /etc/mhwd-x86_64.conf
It has lib32 support: true
Acquiring /var/lib/mhwd/db/pci/graphic_drivers/nvidia-dkms/MHWDCONFIG
Processing ID: 0300
Acquiring /var/lib/mhwd/scripts/include/0300
Processing ID: 0302
:: Database synchronization with packages…
garuda download...
core download...
extra download...
downloading multiple libraries...
chaotic aura download...
dependency solving…
looking for conflicting packages...
warning: recurring events detected:
warning: nvidia-utils will be set before egl-wayland settings

Packages (20) dkms-3.0.11-1 egl-wayland-2:1.1.12-1 eglexternalplatform-1.1-2 gobject-introspection-1.76.1-3 gwe-0.15.5-3.4 lib32-nvidia-utils-535.54 .03-2 lib32-opencl-nvidia-535.54.03-2 libdazzle-3.44.0-1 libxnvctrl-535.54.03-1 nvidia-dkms-535.54.03-1 nvidia-settings-535.54.03-1 nvidia-tools -535.54.03-1 opencl-nvidia-535.54.03-1 python-injector-0.20.1-2.3 python-mako-1.2.4-3 python-markupsafe-2.1.3-1 python-peewee-3.16.2- 2 python-py3nvml-0.2.7-1.3 python-rx-3.2.0-4 garuda-nvidia-config-1:r63.2f652e8-3

Download: 0.19 MB
Installed: 1026.23 MiB

:: Continue installation? [Y/n]
:: Downloading packages…
gwe-0.15.5-3.4-free download...
checking the key database...
checking the composition…
error: gwe: signature from "Pedro Henrique Lara Campos <[email protected]>" is earlier
:: The file /var/cache/pacman/pkg/gwe-0.15.5-3.4-any.pkg.tar.zst is valid (Invalid or system package (PGP signature)).
Do you want to delete? [Y/n] error: transaction failed (Incorrect or damaged package)

Errors occurred, no package occurred.
Error: pacman failed!
Error: script failed!

if something is wrong, I'm sorry because the terminal is in my language and I had to pass it through the translator

Try from a terminal

sudo pacman -S chaotic-keyring

And repeat the autoinstall.


I did and still the same error

@dr460nf1r3 (or anyone else maintaining the chaotic-aur :slight_smile: ): maybe this could be fixed rebuilding gwe?


Just did it! :slight_smile:


I checked and there is no such file at all


But I found this file in this directory. And I checked it is the latest driver version for my GPU.

.rw-r--r--   45M root 15 cze 14:51 ď…› nvidia-dkms-535.54.03-1-x86_64.pkg.tar.zst
.rw-r--r--   566 root 15 cze 14:51 ď…› nvidia-dkms-535.54.03-1-x86_64.pkg.tar.zst.sig
.rw-r--r--  785k root 23 cze 08:58 ď…› nvidia-settings-535.54.03-1-x86_64.pkg.tar.zst
.rw-r--r--   566 root 29 cze 12:12 ď…› nvidia-settings-535.54.03-1-x86_64.pkg.tar.zst.sig
.rw-r--r--  281M root 29 cze 13:05 ď…› nvidia-utils-535.54.03-1-x86_64.pkg.tar.zst
.rw-r--r--   566 root 29 cze 13:09 ď…› nvidia-utils-535.54.03-1-x86_64.pkg.tar.zst.sig

Have you re-tried autoinstall ?


Yes, and it failed. And then I tried to manually install the drivers through the file from the nvidia website, but after adding the nouveau driver to the blacklist, the system did not start and I did not know how to install the drivers further

Failed with the same signature error or a different one?
The drivers from the Nvidia site should be avoided. As a last resort, try installing the nvidia-dkms package.