Garuda Crashes while Update (and on other occasion)

Hello

I have the following Problem:
My System crashes doing Updates:

at this Step: (last line)
====> dkms install --no-deapmod nvidia/525.60.11 -k 5.15.81-1-lts
compleat output only as a Picture

in form of a total freeze.
also I noticed that Firefox loses new created bookmarks.

I already tried an role back via Snapper (6,0.10-> 5.15 Lts) but this only changed the problem from instant reboot to freeze

this Problem also occurs as random not reproducible Crashes during Gaming (last 2 weeks)

and reproducible during an compiling experiment last Tuesday

with best Regreads


sudo garuda-inxi
[sudo] Passwort für XXXXX:
System:
Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dd482690-3cb7-4e23-bf52-f6fdfdbb1afc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X470 AORUS GAMING 5 WIFI v: N/A
serial: N/A
Mobo: Gigabyte model: X470 AORUS GAMING 5 WIFI-CF serial: N/A
UEFI: American Megatrends LLC. v: F63c date: 07/20/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Illuminated Living-Room Keyboard
K830 serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 2S
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 7 2700X socket: AM4 bits: 64 type: MT MCP arch: Zen+
gen: 2 level: v3 note: check built: 2018-21 process: GF 12nm
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3700 min/max: 2200/3700 boost: enabled
base/boost: 3700/4350 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
5: 3700 6: 3700 7: 3700 8: 3700 9: 3700 10: 3700 11: 3700 12: 3700
13: 3700 14: 3700 15: 3700 16: 3700 bogomips: 118400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: Gigabyte driver: nvidia
v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.0 chip-ID: 10de:1b06 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 159 s-size: 613x352mm (24.13x13.86")
s-diag: 707mm (27.83")
Monitor-1: DP-2 res: 3840x2160 hz: 60 dpi: 161
size: 607x345mm (23.9x13.58") diag: 698mm (27.49") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce GTX 1080
Ti/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA GP102 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1
chip-ID: 10de:10ef class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
chip-ID: 1022:1457 class-ID: 0403
Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-2:2 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 6.37 TiB used: 1.79 TiB (28.1%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 3B7QCXE7 temp: 39.9 C scheme: MBR
SMART: yes health: PASSED on: 156d 19h cycles: 2,338
read-units: 67,192,595 [34.4 TB] written-units: 368,669,540 [188 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 QVO 1TB
family: based SSDs size: 931.51 GiB block-size: physical: 512 B
logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 23 C
SMART: yes state: enabled health: PASSED on: 232d 13h cycles: 1698
written: 2.32 TiB
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000VN008-2DR166
family: IronWolf size: 3.64 TiB block-size: physical: 4096 B logical: 512 B
sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5980 serial: <filter> rev: SC60
temp: 28 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 346d 12h cycles: 2297
read: 13.37 TiB written: 7.18 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 QVO 1TB
family: based SSDs size: 931.51 GiB block-size: physical: 512 B
logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 24 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 233d 10h cycles: 1702
written: 2.29 TiB
Partition:
ID-1: / raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 57.44 GiB (14.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p4
maj-min: 259:4
ID-3: /home raw-size: 505.98 GiB size: 505.98 GiB (100.00%)
used: 52.35 GiB (10.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-4: /var/log raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 57.44 GiB (14.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
ID-5: /var/tmp raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 57.44 GiB (14.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 512 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.5 C mobo: N/A gpu: nvidia temp: 55 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 411 Uptime: 45m wakeups: 10 Memory: 31.25 GiB
used: 6.11 GiB (19.6%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2254
pm: pacman pkgs: 2214 libs: 570 tools: gnome-software,octopi,pamac,paru
pm: flatpak pkgs: 40 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: yakuake inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-09-18
Last full system update: 2022-11-27
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

Can you run a memtest? Spurious failure like this is quite often an indication of hardware failure. If you have the opportunity to, try disabling XMP or your equivalent too and disable any overclocks.

2 Likes

I use no overclocking or XFR

can you recommend me an memtest software or send me an link for an tutorial pleas?

is this one good?!

so the good news first:

the Problem disappeared on its own
what did I do:

eating some ting at my parents house :wink:

and reseting my uefi to default config (100% sure I did that before)

after that I could run the update with no problem

second I dit an memtest with Memtest86+ and it finished with an green PASSED so I assume everything is fine.
If someone has any more Ideas Pleas tell.

I will run the Compiling experiment again wen I have some Time (Tuesday ?!)

with Best Regreads ant thanks for the Help

ps. this is my recent garuda Inxi Output:

System:
Kernel: 6.0.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dd482690-3cb7-4e23-bf52-f6fdfdbb1afc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X470 AORUS GAMING 5 WIFI v: N/A
serial: N/A
Mobo: Gigabyte model: X470 AORUS GAMING 5 WIFI-CF serial: N/A
UEFI: American Megatrends LLC. v: F63c date: 07/20/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Illuminated Living-Room Keyboard
K830 serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 2S
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 7 2700X socket: AM4 bits: 64 type: MT MCP arch: Zen+
gen: 2 level: v3 note: check built: 2018-21 process: GF 12nm
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3700 min/max: 2200/3700 boost: enabled
base/boost: 3700/4350 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
5: 3700 6: 3700 7: 3700 8: 3700 9: 3700 10: 3700 11: 3700 12: 3700
13: 3700 14: 3700 15: 3700 16: 3700 bogomips: 118400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: Gigabyte driver: nvidia
v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0a:00.0 chip-ID: 10de:1b06 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 159 s-size: 613x352mm (24.13x13.86")
s-diag: 707mm (27.83")
Monitor-1: DP-2 res: 3840x2160 hz: 60 dpi: 161
size: 607x345mm (23.9x13.58") diag: 698mm (27.49") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce GTX 1080
Ti/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA GP102 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1
chip-ID: 10de:10ef class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
chip-ID: 1022:1457 class-ID: 0403
Sound API: ALSA v: k6.0.11-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-2:2 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 6.37 TiB used: 1.8 TiB (28.2%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 3B7QCXE7 temp: 36.9 C scheme: MBR
SMART: yes health: PASSED on: 156d 20h cycles: 2,340
read-units: 67,256,984 [34.4 TB] written-units: 368,697,506 [188 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 QVO 1TB
family: based SSDs size: 931.51 GiB block-size: physical: 512 B
logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 23 C
SMART: yes state: enabled health: PASSED on: 232d 17h cycles: 1700
written: 2.32 TiB
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000VN008-2DR166
family: IronWolf size: 3.64 TiB block-size: physical: 4096 B logical: 512 B
sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 5980 serial: <filter> rev: SC60
temp: 28 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 346d 16h cycles: 2299
read: 13.37 TiB written: 7.18 TiB Pre-Fail: attribute: Spin_Retry_Count
value: 100 worst: 100 threshold: 97
ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 QVO 1TB
family: based SSDs size: 931.51 GiB block-size: physical: 512 B
logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 1B6Q temp: 24 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 233d 13h cycles: 1704
written: 2.29 TiB
Partition:
ID-1: / raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 61.92 GiB (15.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
used: 608 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p4
maj-min: 259:4
ID-3: /home raw-size: 505.98 GiB size: 505.98 GiB (100.00%)
used: 53.15 GiB (10.5%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-4: /var/log raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 61.92 GiB (15.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
ID-5: /var/tmp raw-size: 390.62 GiB size: 390.62 GiB (100.00%)
used: 61.92 GiB (15.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.25 GiB used: 1024 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.1 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 407 Uptime: 10m wakeups: 4 Memory: 31.25 GiB
used: 4.23 GiB (13.5%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2259
pm: pacman pkgs: 2219 libs: 571 tools: gnome-software,octopi,pamac,paru
pm: flatpak pkgs: 40 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: yakuake inxi: 3.3.23
Garuda (2.6.10-1):
System install date:     2022-09-18
Last full system update: 2022-12-04
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

the rollback to 6.0 is intended

So I tried the compiling experiment today and the error is gone

Lets hope it stays that way

Thanks for the Help

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.