Garuda can't read NTFS partition anymore

I have a 14 TB hard drive that I wanted to save all data but moved to a BTRFS partition, I formatted it all to NTFS despite knowing I’d do a full move to linux in the future, but enough about that. Earlier I decided instead of deleting all partitions off the drive and formatting it I decided I should shrink the partition, then turn the empty partition to btrfs, then move all data to the new partition then grow the btrfs to the whole drive. Well, after it finished shrinking I can no longer mount the drive, the partitioning program failed to create the empty space to brtfs as I set in the program, and I can no longer mount the ntfs drive in garuda like I used to. The ntfs partition is still usable in the Windows 10 OS I still have on the 3rd drive I have on this PC.

Now that you know my dilema I’m looking for a way to get my old data to the btrfs partition.

╰─λ garuda-inxi
System:
Kernel: 6.7.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7b56fc96-0e19-473d-badd-73a065550c34 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MPG B550 GAMING EDGE WIFI (MS-7C91)
v: 1.0 serial: <superuser required> uuid: <superuser required> UEFI: American
Megatrends LLC. v: 1.80 date: 12/15/2021
CPU:
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3710 high: 4005 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3601 2: 3700
3: 3609 4: 3600 5: 3713 6: 3973 7: 3653 8: 3600 9: 3700 10: 4005 11: 3700
12: 3667 bogomips: 88801
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
vendor: Tul / PowerColor Red Devil driver: amdgpu v: kernel arch: RDNA-2
code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3
bus-ID: 2d:00.0 chip-ID: 1002:73df class-ID: 0300
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu d-rect: 4480x2520 display-ID: 0
Monitor-1: DP-2 pos: top-right res: 2560x1440 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: bottom-l res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6700 XT (radeonsi
navi22 LLVM 17.0.6 DRM 3.57 6.7.9-zen1-1-zen) device-ID: 1002:73df
memory: 11.72 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 6700 XT (RADV NAVI22) driver: mesa radv v: 24.0.2-arch1.2
device-ID: 1002:73df surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.2-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 2d:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.7.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 29:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 2a:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp42s0 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:6 chip-ID: 8087:0032
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 14.81 TiB used: 715.21 GiB (4.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-256G-1006 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: HPS2 temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST14000NM001G-2KJ103
size: 12.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: SN02 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 EVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: SanDisk model: Ultra size: 28.64 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s
lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: 1.00
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 715.21 GiB (38.4%)
fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 715.21 GiB (38.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 715.21 GiB (38.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 715.21 GiB (38.4%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.54 GiB used: 251.2 MiB (1.6%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.4 C mobo: N/A gpu: amdgpu temp: 56.0 C
mem: 54.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
Memory: total: 16 GiB available: 15.54 GiB used: 5.23 GiB (33.6%)
Processes: 378 Power: uptime: 1h 3m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.21 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1970 libs: 558 tools: octopi,paru,yay
Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish
v: 3.7.0 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-12-16
Last full system update: 2024-03-12
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:
1 Like

Check if ntfs-3g is installed

First you will need to make a new partition in the empty space. Then you should be able to format the empty partition as Btrfs. If you are stuck, provide some more details so we can see what is happening.

Probably the drive has been marked dirty. Are you getting an error like “wrong fs type, bad option, bad superblock blah blah blah”? Try using ntfsfix (ntfsfix(8) — Arch manual pages), something like this:

sudo ntfsfix -d /dev/whatever_partition_it_is
2 Likes

Boot into Windows & run “chkdsk /f /r” on that drive from a DOS prompt.

3 Likes

A red box appears at the top of dolphin when I click the drive, here is the text:

An error occurred while accessing 'CUMDRIVE', the system responded: The requested operation has failed: Error mounting /dev/sda2 at /run/media/zoey/CUMDRIVE: wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage or helper program, or other error

Edit 1: yes, that is the error, lol.

The command at the bottom fixed it!

Colour me impressed, that’s a very large porn storage drive. :rofl:

No judgement, just sayin. :wink:

3 Likes

And what type of data do you keep…nevermind. Prurient minds do not want to know. But, just so you don’t get any flack, like outright laughing, say…I’m sorry I just can’t continue without. HARHARHARHARHARHAR

:exploding_head: :rofl: :face_with_open_eyes_and_hand_over_mouth: :rofl: :rofl: :rofl:

EDIT: Effin’ tbg beat me to it, LOLOL

EDIT 2: What is really funny is that even Windows users searching the 'net for a solution to “can’t read NTFS partition” named CUMDRIVE are going to see this in the results. Caturday strikes again! :joy_cat:

3 Likes

Were our near identical posts because great minds think alike, or because fools seldom differ!

:smiley:

3 Likes

Gotta have some fun, right? :joy:

3 Likes

Damn tootin!!! Sorry if that doesn’t translate well to German.

To the OP, best not to respond to the silly comments posted above. Responding will be somewhat like replying to a no win question such as “do you still beat your wife”. Best to simply cut your losses in situations like this and simply take the dignified way out by requesting a thread lock. :smiley:

3 Likes


Edit: no wonder the kernel marked the drive “dirty”. :rofl:

5 Likes

Q1: @SGS have an appropriate avatar/icon?
Q2: @TilliDie wallpaper or…um…‘splash’ screen?

EDIT: @The_Teto Please forgive the jokes & puns. Trust me, you’ve now and forever henceforth earned your place here. That comes with all the rights, honors, AND permission to sling :poop: right back at us (bad) jokesters. :smiley:

3 Likes

it has seen some shit

1 Like

I thought it was funny, and it’s not just for porn :roll_eyes::roll_eyes::roll_eyes:

1 Like

Also had issues with NTFS not being able to be read for years; sometimes running check disk in windows fixes it; after a number of updates this is more stable.

I confirm that NTFS isn’t fully stable in Linux. Sometimes drives get corrupted and can only be fixed in Windows.

This is particularly relevant for NTFS USB drives. If you unplug it without unmounting it, it may become unreadable in Linux and only fixable in Windows.

NTFS is not open-source; Linux partial implemented is reverse-engineered.

Something to be aware of.

1 Like

And sometimes even Windows cannot correct a severely corrupted NTFS drive. Bye, bye data.

1 Like

I fixed it by using the ntfsfix command then a little bit later i made the btrfs partition on the remaining space and one again wasn’t allowing me to mount the first partition, being an ntfs so I used the command again, and it immediately fixed it again. Lol

1 Like

Nobody worry about me, my most important stuff is saved on 3 drives, a usb and google drive (inb4 someone tells me of flaws of cloud storage, it’s kinda irrelevant as I’m TRYING to spread this data around)