Garuda boot options not applying

Dears,

I have a freshly installed Imperial Eagle installed in dual boot. It starts Garuda automatically. All of that works fine.

When I use Garuda Boot Options to change the Os to boot to (in Grub), it applies the change. But when I reboot, I can't see the change.

Thank you in advance for the help.

Best regards

you have to use the bootloader of garuda since the changes you make in garuda apply only to garuda's grub. check if your boot order is set to garuda's bootloader first. which is the other OS you are dual booting with?

thank you for the very quick reply pupperemeritus.

The other OS is Windows10

does it work?

I have the same Problem (Garuda/Windows 10 Dual boot) . I use the garuda bootloader, changes are simply not applied.
I have a second question: how can i set grub to remember my last boot choice?
(i tried setting it with garuda boot options, but the option disappeared)

I did use the Garuda Boot Options to change the setting. I thought this was the way to change the boot order. Currently the bootorder is garuda first. In grub I do see Windows 10 as an option. If I choose it manually it boots to W10 just fine. But when I try to set Grub to boot from Windows automatically, it still doesn't work.

I believe there is currently a bug in grub preventing the boot order sticking when using btrfs.

1 Like

Thank you for the update. I am sure an update will come in time

hello, i have the exact same problem. Is there may a way to change the boot order with an other program? maybe a bootloader from a other linux distrubution?
Idk much about linux in general. So may it is a dub question.

You could likely change the boot order using refind rather than grub, but then you would lose being able to restore timeshift snapshots at the grub boot menu. Hardly seems worth losing the handy snapshot system restore feature just to save having to manually select a different kernel if you desire to switch.

As far as I'm aware the situation has not changed in the last few months. Grub will currently not allow you to modify the boot order with Garuda's default install configuration using btrfs.

If you install Garuda using a separate /boot partition (not formatted as btrfs) then theoretically this should allow you to change your default boot order using grub.

I haven't tested this myself yet. You can add a /boot partition post install, but it's not exactly a trivial matter. You can search for directions on how to configure this yourself post install, or add a separate /boot partition if you reinstall Garuda in the future.

1 Like

Settings in the Garuda boot options

How do I manage to change the boot entry in the 'Garuda Boot Options'?
In my case instead of 'Garuda' to 'Garuda (on dev / sda3)
It can be changed and adopted, but always falls back to the default option.

I can't find anything corresponding in the wiki or in the forum.

1 Like

same here. more bugs.
I have zen kernel installed first by default and tkg-MuQSS that I want to boot as a first.
garuda boot options are changing nothing. if I choose in the grub next time it won't be remembered.

I can file a bug report but what should it regard to ? grub or boot options ?
for now I can uninstall zen to have only one option so It is not annoying me off each time I reboot

Are you

sudo update-grub

after change?

Or /etc/default/grub

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

?

1 Like

Unfortunately it failed. I'm still too stupid for your alternative suggestion. But I am learning...

Thank you @SGS for your tireless efforts.

1 Like

It's not an essential problem either, but a luxury problem, as I call it. I don't mind using the cursor key in the bootloader. :smiley:

1 Like

Edit these options in /etc/default/grub and update-grub

GRUB_DEFAULT=0
#GRUB_SAVEDEFAULT=true

The number means the menu options lines in the menu, starting from 0 (0=1st entry, 1=2nd entry, etc.)
Grub_savedefault should be disabled (# at line start disables the setting).
Make sure there is no double entry with the same names in the file.

3 Likes

I think I know what you mean. I just didn't dare to change anything. I'll leave that on Saturday evening and prefer to enjoy a glass of Royal Salute. :yum:

2 Likes

This is debatable as to whether it should be classified as a grub bug, or simply an unfinished feature implementation with Grub.

Grub will not save any changes with regards to changing the default kernel when using btrfs.

The only workaround when using grub with btrfs (if you wish to be able to save a kernel change) is to install Garuda with a separate /boot partition formatted as ext2 or ext3.

This is a known issue with Grub.

3 Likes

Thank you very much for this information.

2 Likes

I have sorted out my boot priority by uninstalling all other kernels and leaving only the one I want to boot (tkg-MuQSS), Then I have installed lte as fail-safe, backup one. after the reboot, default is the requested one...

1 Like